cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

235
Views
5
Helpful
2
Replies
Highlighted
Beginner

WS-C3850-24S DHCP-Server issue

Hi Community,

 

I am using a WS-C3850-24S as a dhcp server to deploy other switches.

Now I noticed that the 3850 provides a new IP to the dhcp client when the client is reconnecting to the 3850.

In detail when I do a shut no shut on the SVI of the client (in this case a WS-C2960C-8PC-L) the clients gets a new IP.

Is this a normal behaviour? I don't think so.

Here are more details about the 3850:

WS-C3850-24S
03.06.05E

ip dhcp pool DHCP-ZTP-POOL
network 10.1.178.0 255.255.255.0
default-router 10.1.178.1
option 150 ip 10.1.178.5
lease 1

 

I expect that the DHCP client gets the same IP until the lease times out.

 

I would be happy about a hint or an idea how I can solve this issue.

 

Thanks

Sebastian

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Re: WS-C3850-24S DHCP-Server issue

Try changing the lease options :

 

The lease command takes up to three options: lease days [hours] [minutes], with hours and minutes being optional. You can specify a maximum period of 365 days, 23 hours and 59 minutes, and a minimum of 1 second. The default is one day.

 

lease {days [hours] [minutes] | infinite}


Example:
Device(dhcp-config)# lease 30
 

(Optional) Specifies the duration of the lease.

  • The default is a one-day lease.

  • The infinite keyword specifies that the duration of the lease is unlimited.

 

BB
*** Rate All Helpful Responses ***

View solution in original post

2 REPLIES 2
Highlighted
Beginner

Re: WS-C3850-24S DHCP-Server issue

Hello,

Yes this is normal behavior for a Cisco device running a DHCP server. By default, the Cisco device has dhcp conflict logging enabled, which will keep a persistent database of the assigned IPs, and will assign a new IP with each new request. This is a default behavior. In the past I have ran into issues like this with IP phones exhausting the dhcp pool because I didn't turn of dhcp conflict logging. The feature is turned off with "no ip dhcp conflict logging".

 

This is a great article that explains this much better than I can :)

http://blog.ipspace.net/2007/08/dhcp-conflict-logging-true-story.html

 

Also here is a similar post just for more information.

https://community.cisco.com/t5/switching/no-ip-dhcp-conflict-logging/td-p/3028936

 

HTH,

Barry

 

Highlighted
VIP Mentor

Re: WS-C3850-24S DHCP-Server issue

Try changing the lease options :

 

The lease command takes up to three options: lease days [hours] [minutes], with hours and minutes being optional. You can specify a maximum period of 365 days, 23 hours and 59 minutes, and a minimum of 1 second. The default is one day.

 

lease {days [hours] [minutes] | infinite}


Example:
Device(dhcp-config)# lease 30
 

(Optional) Specifies the duration of the lease.

  • The default is a one-day lease.

  • The infinite keyword specifies that the duration of the lease is unlimited.

 

BB
*** Rate All Helpful Responses ***

View solution in original post