cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1109
Views
0
Helpful
2
Replies
Highlighted

X.25 XOT communication not working

Hi,

We are migrating some access from Decnis into TCP/IP at X.25 links and we have XOT configured at our router.

The point is that for 4 of 5 accesses this is working fine but at one of them not, and the following log is shown:

Feb 3 14:46:51.138 MET: From (12): 141271158400 To (8): 14182077

Feb 3 14:46:51.138 MET: Facilities: (6)

Feb 3 14:46:51.138 MET: Packet sizes: 128 128

Feb 3 14:46:51.138 MET: Window sizes: 3 3

Feb 3 14:46:51.138 MET: Call User Data (16): 0x00000000  (x25-multiprotocol)

Feb 3 14:46:51.138 MET: Serial0/0/0: X.25 O R1 Call (29) 8 lci 6

Feb 3 14:46:51.138 MET: From (8): 14127115 To (8): 14182077

Feb 3 14:46:51.138 MET: Facilities: (0)

Feb 3 14:46:51.138 MET: Call User Data (16): 0x00000000  (x25-multiprotocol)

Feb 3 14:46:51.450 MET: Serial0/0/0: X.25 I R1 Call Confirm (5) 8 lci 6

Feb 3 14:46:51.450 MET: From (0): To (0):

Feb 3 14:46:51.450 MET: Facilities: (0)

Feb 3 14:46:51.450 MET: [172.26.93.31,58315/10.216.8.91,1998]: XOT O P3 Call  Confirm (11) 8 lci 4093

Feb 3 14:46:51.450 MET: From (0): To (0):

Feb 3 14:46:51.450 MET: Facilities: (6)

Feb 3 14:46:51.450 MET: Packet sizes: 128 128

Feb 3 14:46:51.450 MET: Window sizes: 3 3

Feb 3 14:46:56.329 MET: Serial0/0/0: X.25 I D1 Reset (5) 8 lci 6

Feb 3 14:46:56.329 MET: Cause 5, Diag 1 (Local procedure error/Invalid  P(S))

Feb 3 14:46:56.329 MET: Serial0/0/0: X.25 O D3 Reset Confirm (3) 8 lci 6

Feb 3 14:46:56.329 MET: [172.26.93.31,58315/10.216.8.91,1998]: XOT O D1 Reset  (5) 8 lci 4093

Feb 3 14:46:56.329 MET: Cause 3, Diag 1 (Remote procedure error/Invalid  P(S))

Feb 3 14:46:56.661 MET: Serial0/0/0: X.25 I D1 Reset (5) 8 lci 6

Feb 3 14:46:56.661 MET: Cause 0, Diag 0 (DTE originated/No additional  information)

Feb 3 14:46:56.661 MET: Serial0/0/0: X.25 O D3 Reset Confirm (3) 8 lci 6

Feb 3 14:47:01.157 MET: [172.26.93.31,58315/10.216.8.91,1998]: XOT I P4 Clear  (5) 8 lci 4093

Feb 3 14:47:01.161 MET: Cause 0, Diag 0 (DTE originated/No additional  information)

Feb 3 14:47:01.161 MET: Serial0/0/0: X.25 O R1 Clear (5) 8 lci 6

Feb 3 14:47:01.161 MET: Cause 0, Diag 0 (DTE originated/No additional  information)

Feb 3 14:47:01.221 MET: Serial0/0/0: X.25 I R1 Clear Confirm (3) 8 lci 6

Feb 3 14:47:01.221 MET: <detached>: XOT O P7 Clear Confirm (3) 8 lci  4093

Feb 3 14:47:06.173 MET: [172.26.93.31,58322/10.216.8.91,1998]: XOT I  P/Inactive Call (37) 8 lci 4093

Looking at X.25 documentation it wasn't clear to me what exactly could be the source of this problem, so could somebody help me with that? If found this kind of problem?

The destination that doesn't work is 14182077.

Rds,

Luiz

PS: Here is the routing configuration:

version 12.4
service pad to-xot
service pad from-xot
service  tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug  datetime msec localtime show-timezone
service timestamps log datetime msec  localtime show-timezone
no service password-encryption
!
hostname  Sincrono_CVU_01
!
boot-start-marker
boot-end-marker
!
logging  buffered 64000 debugging
enable secret 5  $1$63MM$o5Q2qH3WpCMFSV6ZYepYd.
!
no aaa new-model
!
resource  policy
!
clock timezone MET 1
clock summer-time METDST recurring last  Sun Mar 1:00 last Sun Oct 1:00
clock calendar-valid
ip  cef
!
!
!
!
!
x25 profile XOTLink dte
x25 win 3
x25  wout 3
x25 routing
!
!
!
!
!
!
interface  Loopback0
ip address 10.216.9.161 255.255.255.255
!
interface  Loopback1
ip address 10.216.9.162 255.255.255.255
!
interface  Loopback2
description Faurecia Bancos
ip address 10.251.124.33  255.255.255.255
!
interface Loopback3
description Faurecia  Escapamentos
ip address 10.251.124.34 255.255.255.255
!
interface  Loopback4
description Peguform
ip address 10.251.124.35  255.255.255.255
!
interface FastEthernet0/0
description SCUR_INDUS_CI1  G6/19
ip address 10.216.8.91 255.255.255.128
speed  100
full-duplex
standby 200 ip 10.216.8.93
standby 200 timers 1  3
standby 200 priority 110
standby 200 preempt delay minimum  40
standby 200 authentication hsrp200
standby 200 track  Serial0/0/0
!
interface FastEthernet0/1
no ip  address
shutdown
duplex auto
speed auto
!
interface  Serial0/0/0
no ip address
encapsulation x25
x25 version 1988
x25  address 14127115
x25 htc 10
x25 win 3
x25 wout 3
x25  use-source-address
x25 pad-access
!
router ospf  1
log-adjacency-changes
passive-interface default
no  passive-interface FastEthernet0/0
network 10.216.8.91 0.0.0.0 area  0
network 10.216.8.92 0.0.0.0 area 0
network 10.216.8.93 0.0.0.0 area  0
!
ip route 0.0.0.0 0.0.0.0 10.216.8.126
!
ip http server
ip  http authentication local
no ip http secure-server
!
translate ruleset  faurecia_BC_CVP from telnet to pad
match source-addr 10.251.124.33
match  source-addr 10.251.124.33
match source-addr 10.251.124.33 dest-port  23
set pad dest-addr 14182058
set pad dest-addr 14182058
set telnet  local 10.251.124.33 pad dest-addr 14182058
set telnet local 10.251.124.33  pad dest-addr 14182058
translate ruleset faurecia_ESC_CVP from telnet to  pad
match source-addr 10.251.124.34
match source-addr  10.251.124.34
match source-addr 10.251.124.34 dest-port 23
set pad  dest-addr 14182061
set pad dest-addr 14182061
set telnet local  10.251.124.34 pad dest-addr 14182061
set telnet local 10.251.124.34 pad  dest-addr 14182061
translate ruleset furecia_01 from telnet to pad
match  source-addr 10.216.9.161
match source-addr 10.216.9.161
match  source-addr 10.216.9.161 dest-port 23
set pad dest-addr 14127116
set pad  dest-addr 14127116
set telnet local 10.216.9.161 pad dest-addr  14127116
set telnet local 10.216.9.161 pad dest-addr 14127116
translate  ruleset peguform_01 from telnet to pad
match source-addr  10.216.9.162
match source-addr 10.216.9.162
match source-addr  10.216.9.162 dest-port 23
set pad dest-addr 14127121
set pad dest-addr  14127121
set telnet local 10.216.9.162 pad dest-addr 14127121
set telnet  local 10.216.9.162 pad dest-addr 14127121
translate ruleset peguform_CVP from  telnet to pad
match source-addr 10.251.124.35
match source-addr  10.251.124.35
match source-addr 10.251.124.35 dest-port 23
set pad  dest-addr 14182077
set pad dest-addr 14182077
set telnet local  10.251.124.35 pad dest-addr 14182077
set telnet local 10.251.124.35 pad  dest-addr 14182077
!
logging facility syslog
logging host  10.229.138.182 filtered
access-list 99 permit 10.251.127.224  0.0.0.7
snmp-server community rot0399 RO
x25 route ^8100 xot  10.216.8.1
x25 route ^8200 xot 10.216.8.2
x25 route ^8300 xot  10.216.8.3
x25 route ^8600 xot 172.26.93.33
x25 route ^8500 xot  172.26.93.32
x25 route ^8400 xot 172.26.93.31
x25 route .* interface  Serial0/0/0
x25 route .* xot 10.216.8.92 xot-source FastEthernet0/0
!
control-plane
!
!
line con 0
line aux  0
line vty 0 5
login local
transport input all
transport output  all
!
scheduler allocate 20000 1000
ntp clock-period 17178544
ntp  server 138.21.64.65
ntp server 138.21.66.146
ntp server  138.21.64.122
end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

interface  Serial0/0/0
no ip address
encapsulation x25
x25 version 1988
x25  address 14127115
x25 htc 10
x25 win 3
x25 wout 3
x25  use-source-address
x25 pad-access


The information above says the packet window is 3; the link layer window
is probably 7, not 3, please check this.

also confirm  check  in the line if you need x25 map... or translate.

View solution in original post

2 REPLIES 2
Highlighted
Beginner

interface  Serial0/0/0
no ip address
encapsulation x25
x25 version 1988
x25  address 14127115
x25 htc 10
x25 win 3
x25 wout 3
x25  use-source-address
x25 pad-access


The information above says the packet window is 3; the link layer window
is probably 7, not 3, please check this.

also confirm  check  in the line if you need x25 map... or translate.

View solution in original post

Highlighted

Hi Sakella,

You've really got the point because we found out that historically used the window size as 3 but at SP it was set as 2.

For other 3 suppliers it never became a serious problem or even was noted because when this happens, communications was resetted and channels was cleared retrying until get to transmit the message that is very small(text file). But now when we were migrating this specific suppliers router used the default X.25 timer to clear the channel that is around 3 minutes, and how application tried to retransmit before this time, channel was busy and the error was show.

This router specifically has a problem and had to be replaced, but showed us this other old problem that wasn't being seen for us or the SP support until we requested them to use analyzers at L2 and 3 of X.25.

But your lecture was really correct, thanks for the answer.

Luiz