Showing results for 
Search instead for 
Did you mean: 

Add vBond to vMange

Juraj Papic
Level 3
Level 3

Hi all


Im working with viptela version 18.4.1 every time I try to add the vBbond to the vMange I get this error connect timed out



24 Replies 24

Make sure the vbond IP you use is reachable from vmanage over VPN 0.

I have this probelm as well. It is reachable from vBond to vManage and visa versa


Level 4
Level 4



Even I am facing this issue, both the controllers are inter-reachable 


Please help



Arjun B.

Alfonso Lopez
Cisco Employee
Cisco Employee

Hi Juraj,


I had the exact same problem:

vManage 18.4.1

vBond responds to ping via vpn 0

Tried many things, played with certificates, different IPs, etc.


I ultimately solved it redeploying the vBond VM and just configuring vpn 0.

I was immediately able to add the vBond controller from vManage.

I then configured vpn 512 in vBond.


I have no idea why the old vBond was not added. Hope that helps.

You need to disable Tunnel interface from VPN0 interface while adding the vBond in the vManage.

And re-enable it later on while adding the cEdge/vEdge

Arjun Bhosale

In my case I did NOT have to disable the tunnel interface in VPN 0 before adding the vBond from the vManage GUI.
The only difference is that before I was trying to add a vBond running 18.3.6. It worked when I tried to add a vBond running 18.3.3.

Something similar happened while adding vSmarts:
When adding vSmarts running 18.3.6, they did appear under Device-Controllers after adding, but no system-ip, site-id or hostname was learned by vManage. Hence, when trying to attach a vSmart template, it said "device is offline". This happened regardless of installing or not installing a certificate.
I tried now adding a vSmart running 18.3.3 and all that information is now learned by vManage after installing the certificate.



I have the same problem with adding vBond to vManage in 19.2.1:-( The same problem that vManage can not get system-ip and hostname from vBond. When I tried to change device mode from CLI to vManage and apply tempates it was not succesful because of the 3rd row

[27-Mar-2020 0:53:35 CET] Starting Checks.
[27-Mar-2020 0:53:35 CET] Validating if device scheduled for template push are active
[27-Mar-2020 0:53:35 CET] DeviceIP: -, uuid: 05efb049-809c-4879-b865-650a9a3cae74 is not connected to vmanage
[27-Mar-2020 0:53:35 CET] Sending message to vmanage:
[27-Mar-2020 0:53:35 CET] Published messages to vmanage(s)
[27-Mar-2020 0:53:35 CET] Checks completed.

 Then it showed me that device is offline even though it's reachable:

[27-Mar-2020 0:24:35 CET] Configuring device with feature template: vBond-TMPL
[27-Mar-2020 0:24:35 CET] Generating configuration from template
[27-Mar-2020 0:24:36 CET] Checking and creating device in vManage
[27-Mar-2020 0:24:37 CET] Device is offline
[27-Mar-2020 0:24:37 CET] Updating device configuration in vManage
[27-Mar-2020 0:24:38 CET] Configuration template vBond-TMPL scheduled to be attached when device comes online. To check the synced state, click Configuration > Devices > Device Options


And I had already problem to add vManage template in this version - it worked just from CLI. It looks like a lot of bugs in this SW version.

At the end I have found solution.

I had both of vManage and vBond in CLI mode. I found out that when I put vBond IP address and port in GUI settings it did not write it down into vManage CLI configuration.

So I added new controller (vBond) in Gui again, filled out IP address and login plus Generate CSR and send to Certificate Authority for signing option. Then I was waiting for certification to be installed (automatic Cisco certification process). After that I went to vManage CLI by ssh and simply configured system vbond <IP address> and committed. After a while I saw State Up to vBond by command  show transport connection.

Then everything was fixed in GUI too - in Devices vBond system-IP, Hostname and site-id was retrieved, vManage showed me vBond updated state in Certificates view, it was visible in network map etc... Hurray

I have tried this - remove the Tunnel interface from VPN0 but no luck. I am still getting " Key exchange was not finished, connection is closed".





Level 1
Level 1

Just ran into this problem.  My fix was fairly simple, I deployed the wrong version of vbond (20.3.2), which was not compatible with my vmanage (19.2.31).  Redeployed vbond using version 19.2.31, and was able to add it to vmanage with no issues.

Level 1
Level 1

Had the same problem even on version 19.2.3.


Tried redploying the vbond.. same problem.


Ultimately figured it out.   On vbond, when you create the interface ge0/0 under vpn 0, it will auto add tunnel interface even if you didn't specify to.   Go into config mode on the vbond, and and do a 'no tunnel interface' under int ge0/0.   commit changes, and try again.  Should add this time.

Correct It`s working now.

Yes, it is working now. 

Jason Xie
Level 1
Level 1

I have the same issue too when adding the vBond to the vManager. Have this issue been resolved?  I have tried the solutions proposed but still not good.