cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Choose one of the topics below for SD-WAN Resources to help you on your journey with SD-WAN

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC!
We will not comment or assist with your TAC case in these forums.

507
Views
0
Helpful
1
Replies
Highlighted
Beginner

cisco switch 9200L-24P Booting issue

dear all,
 
I was trying to get familiar with the 9200 series with but now I'm stuck. It is about the 9200L-24P switch
I have peformed a factory reset with command "factory-reset all". The switch is now in factory mode without any IOS. It stays in the rommon mode.
 
To load a IOS I want to use the TFTP for transfer
 below are steps that I try to perform. please review the steps and advice
 
step 1   check directory
switch: dir
usage:
        dir <path-to-directory>
supported filesystem(s):
         flash: ro flash
     usbflash0: rw front-panel USB 0
     usbflash1: rw front-panel USB 1
switch: dir flash:
Attributes        Size         Name
 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
 
 step 2   set IP iddr to communicate with the TFTP server for the IOS transfer
 set ip_addr 192.168.1.100/255.255.255.0
 set BAUD 115200
 
 setp 3   verify communication with the TFTP server
 ping 192.168.1.10
 switch: set ip_addr 192.168.1.100/255.255.255.0
switch: ping 192.168.1.1
ICMP: Set ip-address before using ping!
Failed to ping 192.168.1.1 
 
the communication has been failed. What can go wrong here, because is should accept the IP addr ( cable is tested, same subnet )

step 4 boot the switch from the tftp
boot tftp://192.168.1.10/cat9k_lite_iosxe.16.10.01.SPA.bin
 
step 5 copy the ios to the flash a
copy tftp://192.168.1.10/cat9k_lite_iosxe.16.10.01.SPA.bin flash:
 
step 6
how can I let the switch boot from the flash at the next restart, because it will be booted from the TFTP.

 

errors

when I try to set an IP address, the switch is not remembering the IP. Because this should be set first.

even when I try to load it from usb, it is asking to format in the MBR mode fat 16.

 

please help/advice

 
 

1 REPLY 1
Highlighted

I solved my problem this way:


On a good switch:
From another switch that is running the same IOS, from the enabled prompt#:

copy flash:[Name of .bin file] usbflash0:
Answer the question of name to the destination location.


On the bad switch:
Boot switch to get to the Rommon prompt":".
Insert the usbflash drive.
Type: boot:usbflash0:[Name of .bin file], system will reboot from the image on the usb flash drive.
Once the switch finishes booting, you should be at the user prompt, >, get into the enabled mode.
Type: copy usbflash0:[Name of .bin file] flash:
Type: reload

Switch will now try to boot from what the BOOT var is set to. You might need to get back into the Rommon and change the BOOT variable. To see what all of the variables are set to,
Type: set
You should bee a list of current variables:

switch: set
ABNORMAL_RESET_COUNT=0
AUTOREBOOT_RESTORE=0
AUTO_SWITCH_CONSOLE_DISABLE=0
BAUD=9600
BOOT=flash:cat9k_lite_iosxe.16.12.03a.SPA.bin
BSI=0

Make sure you type the variable name the same as it is on this list. To get the switch to boot the .bin file on the switch,
Type: set BOOT flash:[Name of .bin file]
Issue a set command again to validate the set BOOT command is correct.
Power cycle the switch.

Like I said, this is what worked for me. I hope this helps.

Content for Community-Ad
This widget could not be displayed.