cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Choose one of the topics below for SD-WAN Resources to help you on your journey with SD-WAN

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC!
We will not comment or assist with your TAC case in these forums.

393
Views
0
Helpful
1
Replies
Highlighted

Leak default route from vpn 0 BGP to vpn 1

Hi, im facing the next issue:

 

We have two branch with 1 mpls + 1 internet link.

 

Primary branch is publushing default route via BGP to the MPLS link, secondary branch is doing the same but with as-prepend on the default route.

 

When primary branch loses the internet link, service vpn (vpn 1) is not learning a default route via vpn 0, even while vpn 0 still has a default route learned via bgp on the MPLS link, i have tried several ways to acomplish this without luck.

 

vpn 1 config is very simple:

 

Primary:

vpn 1
interface ge0/0
ip address 192.168.1.1/24
no shutdown
!
ip route 0.0.0.0/0 vpn 0

 

 

Secondary:

vpn 1
interface ge0/0
ip address 192.168.3.1/24
no shutdown

!
ip route 0.0.0.0/0 vpn 0


Once internet on primary goes down, the route table for vpn 1 drops default route:

 

PROTOCOL NEXTHOP NEXTHOP NEXTHOP
VPN PREFIX PROTOCOL SUB TYPE IF NAME ADDR VPN TLOC IP COLOR ENCAP STATUS
---------------------------------------------------------------------------------------------------------------------------------------------
1 192.168.1.0/24 connected - ge0/0 - - - - - F,S
1 192.168.3.0/24 omp - - - - 3.1.1.1 private1 ipsec F,S

 

 

Whats the correct way to still have internet connection via the mpls link?

 

 

Thanks in advance !

1 REPLY 1
Highlighted
Cisco Employee

Hi Juan,

As far as my knowledge goes, route leaking from vpn 0 to vpn 1 is not supported so far. This feature support is in the roadmap but not in available version.

I haven't tested it though...

 

Regards,

Jayesh