cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

AnyConnect compatibility with macOS High Sierra (10.13)

29006
Views
6
Helpful
21
Comments
Cisco Employee

We're pleased to announce that AnyConnect is macOS High Sierra (10.13) compatible.


Our recommended version for High Sierra is 4.5MR2 (4.5.02033), available today 9/25/17. This version includes additional guidance to ensure that the AnyConnect Kernel Extension (KEXT) is properly approved by the end user. This is a new requirement in High Sierra.


4.4MR4 and 4.5MR1 have also been tested for High Sierra compatibility, but will provide no further guidance to the end user (beyond the single OS prompt) that manual steps are required to provide full AnyConnect capabilities. Additionally, with these older (compatible) AnyConnect releases, a reboot may be required after manually approving the AnyConnect extension to continue to run. This step is not required with 4.5MR2.


Note: Customers using Host Scan must be running version 4.3.5038 or later of the module in order to detect the presence of the macOS 10.13 firewall.


We will continue to look at any way we can optimize this experience in subsequent maintenance releases.

Please direct any questions to ac-mobile-feedback@cisco.com.

21 Comments
Cisco Employee

Good Evening,

I have Mac OS X High Sierra 10.13.2 and Cisco AnyConnect Secure Mobility Client 4.5.02036 does not work. It installs but every time I need to establish a VPN it fails at "activating vpn adapter". After a while it says the connection is unsuccessful.

Any insight would be much appreciated.

Thank You.

Cisco Employee

This is a bug in macOS 10.13.2 beta.  Refer to: Re: MacOS 10.13.2 beta 1, AnyConnect 4.... - Cisco Support Community. Apple is working on this and tracking under Radar # 35186937.

Contributor

Somebody reported in the thread you reference that it was fixed in B3. Also, I’m running High Sierra release and the same version of AC without problems. Is the problem only affecting certain combinations?

I have just installed 4.5.02036 , again the same problem persists. It connects with the end-point, get's an ip address, routing information, dns servers, proxy server settings etc, but only web traffic is forwarded over the tunnel interface. Any attempt with any email client (mac mail, outlook, thunderbird) simple refuses to push traffic over the tunnel interface (i m using wireshark for verification). So i decided to switch again to Openconnect that everything works without any problems.

Cisco Employee

Please contact us at ac-mobile-feedback AT cisco.com with a copy of your DART (Diagnostics report) so that we can investigate.

As the problem persists with AnyConnect even in the case of uninstalling websecurity component and as there are no other ideas i will stay with OpenConnect that works without problems.

Beginner

Just upgraded to macOS High Sierra 10.13.1 (17B1003)

and when I tried to start AnyConnect I got a pop-up stating: 'No components loaded. Quitting application.'

I tried installing 4.5.0233 and receive the same error.

Beginner

Just Upgraded Mac OS High Sierra, and the connection Drops at te 40 sec. I used de the version 4.503040 and just can't connect. At the 42 second stops and put in reconnecting forever. @psd help me! what can I do?

I try to go back with sierre but isn't possible, and I think that isn't the solution! I just what to know if I need to wait for some patch or a new version ....

Beginner

I am running High Sierra 10.13.2 and had the same issues. VERSION 3.1.14018 WORKS.

Beginner

Can anyone tell me the link to down load the any connect vpn client for Mac os 10.13.3?

Thank you

Cisco Employee
Beginner

Thank you for your help. I really need the free client due to the fact that the VPA built into High Sierra keeps disconnecting.

Cisco Employee

If your cisco.com not entitled to download, perhaps you may schedule a dCloud demo and provision AnyConnect that way. See Connect Laptop to a dCloud Session Using Cisco AnyConnect

I looked at the instructions  and found the dCloud users need download the software from Cisco.com first, if not already installed.

Cisco Employee

AnyConnect is a licensed product. See AnyConnect Licensing Frequently Asked Questions (FAQ) - Cisco

Since you are a partner, please see Cisco Security Licensing and Software Access

Beginner

After upgrade to MAC OS X 10.13.4, Cisco anyconnect doesn't work. The error its showing "AnyConnect cannot confirm it is connected to your secure gateway.  The local network may not be trustworthy.  Please try another network.” I also tried reinstalling the client but no luck. The version I am using is 4.5.03040. Any insight would be appreciated. .