cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

ISE 2.5 Beta Registration is Open

6209
Views
5
Helpful
7
Comments
Cisco Employee

image.png

 

We are excited to announce the opening of the ISE Beta community for the Cisco Identity Services Engine (ISE) 2.5 Beta for everyone that is a member of the Cisco Customer Connection Program (CCP)!  The ISE 2.5 Beta is scheduled to run from September 26 – November 20, 2018.

 

Downloads, questions and issues are handled within the private ISE Beta. We will not answer any questions about ISE 2.5 in the public or partner areas of the Cisco Communities until after it is released.

 

image.png How to Join the ISE Beta Community

  1. Join the Cisco Customer Connection Program (CCP) if you have not already
    image.pngThis requires a valid CCO User ID and NDA acknowledgement.
    Authorization to the CCP may take up to 1 hour after registering.
  2. Go to the Security Track
  3. Select Open Betas > Access and sign up for open betas
  4. Choose Identity Services Engine (ISE) 2.5
  5. Click on the Sign Up for Trial button and complete the ISE Beta registration survey
    If you have already registered, click the Go to Trial Space button.
  6. After completing the survey, you will be authorized and redirected to the private
    You will also receive a confirmation email with links and information about the .

 

Even if you don't join the ISE Beta, you owe it to yourself to review the amazing ISE Resources to help you with your ISE deployment!

image.png
Releases
image.png
Licensing
image.png
Planning
image.png
Deploy
image.png
Scale
image.png
Operate
image.png
Optimize
image.png
Resources

 

 

7 Comments
Hall of Fame Community Legend
Please attach the Release Notes.
Cisco Employee
Leo, you must register for the Beta to access the documents or software as clearly stated in my original post.
Cisco Employee

is this version compatible with WLC 8.7/8.8?

Hello, Is there an official table or a list of new features for Cisco ISE 2.5? Best regards, Mike Ghahremani

Hi peaple, I want to upgrade ise 1.4 to 2.4, and my question is concerning licensing. someone can answer me please?

Beginner
Hi Santos. What kind of question do you have regarding Licensing? Regards Mike