cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

MGRE Easy Steps

622
Views
0
Helpful
0
Comments
dhr.tech1
Beginner

 

 

 

 

 

 

 

 

 

                           Setup MGRE

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                                                                                By           Dhruv Sharma

 

 

Contents

1       Topology. 3

2       Initial setup. 3

2.1         R1. 3

2.2         R2. 4

2.3         R3. 4

2.4         R4. 5

3       Configuration. 6

3.1         mGRE setup R1. 6

3.2         mGRE setup R3. 6

3.3         mGRE setup R4. 6

3.4         EIGRP Setup. 7

4       Verification. 7

4.1         EIGRP. 7

4.2         mGRE. 8

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1         Topology

image.png

 

Introduction

 

The traditional implementation of a GRE tunnel involved the configuration of a point-to-point tunnel going between two sites. This type of configuration works well when this is the behavior and there are a limited number of tunnels that need to be configured. However, if there are a large number of spoke sites, the configuration of the hub router and the number of independent IP address ranges (one per tunnel) could be hard to manage. Thus we need to use mGRE.

NHRP is used similarly to the Address Resolution Protocol (ARP) on Ethernet with mGRE, it provides the ability to map a tunnel IP address  with a logical (Non-Broadcast Multi-Access (NBMA)) IP address; this allows mGRE to have dynamically set up tunnels without having to explicitly configure a mapping entry between each potential next-hop destination. 

2         Initial setup

 

All Routers are running an underlay network of BGP.

 

2.1       R1

 

router bgp 10

 bgp log-neighbor-changes

 network 10.0.0.0

  neighbor 10.10.10.11 remote-as 20

 

 

 

 

2.2       R2

 

router bgp 20

 bgp log-neighbor-changes

 network 10.0.0.0

 network 20.0.0.0

 network 40.0.0.0

 neighbor 10.10.10.10 remote-as 10

 neighbor 20.20.20.1 remote-as 30

 neighbor 40.40.40.1 remote-as 40

!

 
 

 

2.3       R3

 

!

router bgp 30

 bgp log-neighbor-changes

  network 20.0.0.0

 neighbor 20.20.20.20 remote-as 20

!

 

 

 

2.4       R4

 

!

router bgp 40

 bgp log-neighbor-changes

  network 40.0.0.0

 neighbor 40.40.40.40 remote-as 20

!

 

 
 

 

 

 

 

 

 

 

 

3         Configuration

 

3.1       mGRE setup R1

 

!

interface Tunnel1

 ip address 192.168.1.1 255.0.0.0

 ip nhrp map 192.168.1.3 20.20.20.1

 ip nhrp map 192.168.1.2 40.40.40.1

 ip nhrp map multicast 20.20.20.1

 ip nhrp map multicast 40.40.40.1

 ip nhrp network-id 1234

 tunnel source GigabitEthernet2

tunnel mode gre multipoint

!

 

3.2       mGRE setup R3

 

!

interface Tunnel1

 ip address 192.168.1.3 255.255.255.0

 ip nhrp map 192.168.1.1 10.10.10.10

 ip nhrp map 192.168.1.2 40.40.40.1

 ip nhrp map multicast 10.10.10.10

 ip nhrp map multicast 40.40.40.1

 ip nhrp network-id 4567

 tunnel source GigabitEthernet1

tunnel mode gre multipoint

!

 

3.3       mGRE setup R4

 

!

interface Tunnel1

 ip address 192.168.1.2 255.255.255.0

 ip nhrp map 192.168.1.1 10.10.10.10

 ip nhrp map 192.168.1.3 20.20.20.1

 ip nhrp map multicast 10.10.10.10

 ip nhrp map multicast 20.20.20.1

 ip nhrp network-id 678

 tunnel source GigabitEthernet1

tunnel mode gre multipoint

!

 

3.4       EIGRP Setup

 

R1

!

router eigrp 27

 network 11.0.0.0

 network 192.169.1.0

!

R3

!

router eigrp 27

 network 12.0.0.0

 network 192.168.1.0

!

 

R4

!

router eigrp 27

 network 13.0.0.0

 network 192.168.1.0

!

 

4         Verification

 

4.2       mGRE

 

 

From output of this capture, it is proven that traffic is flowing over mGRE.

image.png

 

 

 

 

Content for Community-Ad