cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco VSM Software Assistant - 6.3.2

6206
Views
5
Helpful
25
Comments

Hello Everyone,

 

The Cisco VSM Software Assistant version 6.3.2 is here!  In addition to assisting partners, customers, and Cisco personnel with installations and upgrades to the new 6.3.2 VSM software, it also supports installing and/or upgrading CIVS-ENC for the new 8 and 16 port encoding cards (CIVS-ENC-8P and CIVS-ENC-16P).

 

The Challenge

 

Not all VSM users and installers are proficient with Linux and I’ve always felt that it would be great if they could perform an installation or upgrade and not have to be concerned with what an RPM file is, or how to uninstall and/or install one.  Not worry about Java, JRE, or symbolic links, and not forget to update the MySQL database, or worse, accidentally run the database_create script instead of database_update.  An upgrade process  that would verify that they have the necessary files on the server prior to launching the upgrade would be invaluable.

 

I'd even say that those proficient with Linux and the VSM environment would likely appreciate an easier upgrade process.

 

The Solution

 

With the attached script, you can simply download the necessary VSM software .zip files from Cisco.com and put them and the script in any directory on the server.  You can then run the script and answer only a few simple YES or NO questions and feel comfortable that the installation or upgrade will be a success.  The entire process is scrolled to the screen as well as logged to a file for analysis, if necessary, after the upgrade/install.

 

How to use the script to perform and install or upgrade

 

  1. Download the necessary .zip files from Cisco.com
  2. Copy them to the VSM server in any directory
  3. Copy this script to the same directory as the .zip files
  4. Make this script executable   (chmod +x vsmSoftware632.sh)
  5. Run the script (./vsmSoftware632.sh)
  6. Answer simple questions when prompted.

 

Tips

 

  • If the script errors out when you try to run it, then it may have been converted to DOS format during the transfer.  The typical error if this happens is /bin/bash^M unrecognized interpreter.   Try running the following command first, then run the script again

 

    • dos2unix –k vsmSoftware632.sh

 

  • If you need to e-mail the script to someone and it gets blocked by e-mail, then you can remove the .sh extension.  The script file can have any file extension you want, or none at all.  It will work.

 

Explanation

 

The script can do a clean install or an upgrade.  The clean install will allow you to choose which VSM components you want to install, then verify that the necessary .zip files are present.  Any existing components will be removed.  If VSOM is being installed, then the database_create.sh script is called.  When this is called, it will first check for an existing database (from a prior installation), and if one exists, it will ask you if you want to create a new one or not.  If you choose no to this prompt, then you’ll need to manually update the database when finished.

 

If you choose the upgrade option when launching the script, then it will only upgrade VSM components that are currently installed on the system.  If VSOM is installed, it will backup, then update the MySQL database as part of the upgrade.

 

Please use the script and I'd love to get your feedback here.  Let me know what you like about it, what you don't like about it, and what suggestions you have for it.  Of course, I also want to know if you run into any problems caused by the script.  I can't fix it if I don't know it's brokien ;- ) This script is not officially supported by our developement team, but I will try to get updates out as soon as possible when a bug...er...newly discovered feature...is found.

 

Thank you,

Sean

 

Sean Merrow     CCIE 25197

Physical Security CSE

Cisco Systems

 

 

Scenario 2:

Problem:

Once again user had multiple hard drives fail all at once that forced him to replace them and do a factory restore (time number 6).  He got Suse reinstalled, updated the VSMS server to 6.3.3, restored from backup.  Now the VSOM server sees the VSMS as up, but cannot see a version number, capacity, and says no repositories avaliable.  The VSMS server has 2 local repositories defined and active.

Has anyone seen this before and have any idea how to resolve it?

 

Solution:

I have VSOM on seperate server with 55 Media servers and yes I have seen this countless times. The first thing you should do is UPGRADE FW package on your servers to 11.0.1-0046 <-- this will fix lot of your issues with muiltple drive failures.

If this issue happens after FW upgrade follow these procedures. Because more then likely your operating System is still intact and all your data is still GOOD. Beleive me I fixed this many many times

If you have hard drive fail and after rebuild second drive fails, go into WebBios CTRL-H and look at drive states normally one drive will say OFFLINE and other FAILED. Make offlline drive - ONLINE and reboot server. After reboot ,WebBios check state of hard drives Which will probably say Unconfigured Spun Up.

Command MegaCli -cfgForeign -Scan -aALL

Command MegaCli -cfgForeign -Clear -aALL

Now make Foreign drive as Hot Spare

Comamnd MegaCli -PDHSP -Set -Physdrv \[E:S\] -aALL

E - Enclosure ID S - Slot drive number

 

Source Discussion

https://supportforums.cisco.com/discussion/11992816/vsms-recover-failure

Comments
Beginner

Hi Sean,

I've just used the script and updated from 6.3.1 to 6.3.2. It worked perfectly.

Thank you very much putting that huge effort into the script, it'r really great!

Cheers,

Chrigi

Beginner

Hi Sean,

I have also update from 6.3.1 to 6.3.2 with the script. It worked!

Thanks!

Beat

Beginner

Thanks Sean!

Enthusiast

Hello,

Can i upgrade directly from 4.2.1 to 6.3.2?

Thank you

Enthusiast

Yes, you can use this tool to go from 4.2.1/6.2.1 directly to 6.3.2.

Sean

Beginner

Hi Sean

This script sounds great, can I upgrade from 6.3.0 to 6.3.2 using this script without affecting existing archives ?

Also, I see 6.3.2 requires "jre-6u17-linux-i586.rpm",  does this also need to be upgraded when upgrading from 6.3.0 or does 6.3.0 contain the relevant JRE ? I am assuming I dont have to create any symbolic links or uninstall JRE from 6.3.0 since this is the same version required for 6.3.2 ?

Thank-you

Maj

Enthusiast

Hello Maj,

Sorry for the delayed response.

  • Yes, you can upgrade from 6.3.0 to 6.3.2 without affecting existing archives.
  • 6.3.0 and 6.3.2 use the same exact JRE.  However, the script will uninstall the JRE and re-install it as part of the upgrade process.  It will also make sure the symbolic link is created.  Easy Peasy.
  • Just make sure you have all the proper .zip files and follow the instructions on this page and your upgrade should be fine.

Hope this helps,

Sean

Enthusiast

There is a bug with this script.  If you are upgrading a server that has VSMS and CIVS-ENC the script will uninstall both but will only install VSMS.  I have to install CIVS-ENC manually

Erik

Enthusiast

Thanks Erik.  I'll look into this right away.  Can you please send me the log that was generated when this happened?

Sean

Enthusiast

I found the mistake, fixed it, and published a corrected version here.

Thanks again for letting me know.

Sean

Frequent Contributor

Just had my first opportunity to use this script.

It's EXCELLENT.

Thanks again,

Scott.

Beginner

Is this script also working for upgrade from 6.3.2 to Video Surveillance Manager 6.3.2 MR1 ?

Frequent Contributor

What is this 6.3.2 MR1 you are speaking of?

Nevermind... I must have somehow missed this release?  It states 28-NOV, but I didn't see it till today.

I'm going to attempt the script  to upgrade a server in our lab.  I'll let you know how I make out in the event Sean doesn't reply between now and then.

Cheers!

Cisco Employee

We tried it out in our lab here and it worked fine.

Enthusiast

Hey Folks,

Sorry for the super late reply here.  As long as the files names are the same, with the exception of the build number, then the script should continue to work fine.  For example, the script will only look for 6.3.2 files:

Cisco_VSOM-6.3.2-

So as long as the ONLY thing changing is the build number after the 6.3.2- then you should be good to go. 

Sean