cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
150
Views
0
Helpful
3
Replies

Connecting Cisco Catalyst 3750x to HP virtual connect Flex10/10D

hisham600l
Beginner
Beginner

Hi there, 

I have an HP enclosure c7000 gen2 with 2 HP VC Flex-10/10D and I'm trying to connect this switch to our Cisco 3750x using link aggregation. I'm using 1Gb SFP on both sides and both switches are recognizing the connection. However, when I've done the configuration on Cisco side, the interface status on the 3750x changed from connected to suspended. It seems that's because of port-channel configuration.

Below is my configuration on Cisco 3750x:

 

interface GigabitEthernet1/1/3
description "C7000"
switchport trunk allowed vlan 301,302,401,601,602,701,801
switchport trunk encapsulation dot1q
switchport trunk native vlan 998
switchport mode trunk
channel-group 14 mode desirable
!

 

interface GigabitEthernet1/1/4
description " C7000-2"
switchport trunk allowed vlan 301,302,401,601,602,701,801
switchport trunk encapsulation dot1q
switchport trunk native vlan 998
switchport mode trunk
channel-group 14 mode desirable
!

 

interface Port-channel14
description ### C7000-Enc-03 ###
switchport trunk allowed vlan 301,302,401,601,602,701,801
switchport trunk encapsulation dot1q
switchport trunk native vlan 998
switchport mode trunk
no shutdown

 

On the HP side I've created the uplink and added all VLANs in it but the link status is "Linked-Standby" which means the link is not transmitting any data as I understand. 

Please help me to get the proper configuration to get over this issue. 

 

Regards,

 

3 Replies 3

johnd2310
Collaborator
Collaborator

Hi

Your configuration should be "channel-group 14 mode active".  The configuration "channel-group 14 mode desirable" is used if you are using PAgP. In your case you want to use LACP and LACP modes are active or passive.

Thanks

John

**Please rate posts you find helpful**

Hi John, 

Thank you for your reply. I've changed the mode to active and still the same issue. Once I add the interface to the port channel, the interface status is changing to ""Suspended.

Its been Long time have touched HP switches, does your HP switch support LACP, if not change mode on and test as below both the side :

shutdown the port channel on both sides and make it ON both sides and no shut on both sides.

channel-group 14 mode on

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers