cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5157
Views
21
Helpful
33
Replies
Beginner

Wes,

Wes,

Any chance you can give a time frame when 6.5 will be supported?  

Thanks,
Brian

Highlighted
Cisco Employee

Hello folks - 6.5a works ok,

Hello folks - 6.5a works ok, VSM installs in vSphere and while VMware doesn't make it easy to integrate the plugin with vCenter, here is a great workaround I used and it was flawless:  

http://seanblee.blogspot.com/2017/01/register-nexus-1000v-vsm-with-vcenter-65.html

I simply inserted these steps and the plugin works just fine.

HTH,

Mike

Beginner

Wes, can you or Cisco please

Wes, can you or Cisco please comment on when ESXi 6.5 will be supported for Nexus 1000V?  There's FUD being spread out there that Nexus 1000V will never be supported on ESXi 6.5. If that's the case, we need to abandon plans to buy 1000V Advanced+VSG, and start looking for other solutions.

Further, I have been unable to download Nexus 1000V from CCO since Dec 7th, and after 9 emails to ent-dl@cisco.com (most of which trying to get them to understand 1) this is a product cisco has, 2) it's free, and 3) no, I can't give you a PAK for a free product) there has been no response after supposed "internal escalation".  I'm still stuck on 3.1.15 while 3.2.8 is available, but unable to be downloaded.

Judging by this forum, and this link

https://supportforums.cisco.com/discussion/13198181/unable-download-cisco-nexus-1000v-eval-version-vmware-vsphere

I'm not the only one.  In fact, hitting "register" for the free trial gives me a 404 error.

If Cisco is not going to support this product going forward, it would be great if Cisco would at least let people know.  End of Life notices were just posted for version 4, which leads me to believe the product isn't dead... but all of Cisco's actions speak to the contrary.

Please let me know this product is moving forward.

Beginner

Hello, I'm hoping there is an

Hello, I'm hoping there is an update with ETA on this, or at least confirmation that VMware hasn't eliminated the possibility of N1K support on vCenter 6.5?

Got yesterday the information

Got yesterday the information (deep cisco information) that in End of Q1 2017 Cisco will offer a Version running on vSphere 6.5. Hopefully this will be confirmed (official) very soon.

Bad news from VMware:

Bad news from VMware:

##snap##

VMware is announcing the iiscontinuation of its thiri party virtual

switch (vSwitch) program. VMware intenis to ieprecate the APIs

usei by thiri party virtual switches, ani expects to remove the

APIs as part of a future upiate to VMware vSphere 6.5 as well

as future releases of the vSphere platform. Customers are

encouragei to begin migrating from thiri party vSwitches

incluiing Cisco Nexus 1000V, Cisco VM-FEX, Cisco AVS, HPE

5900v ani IBM DVS 5000v to vSphere Distributei Switch.

VMware will continue to support the 3ri party virtual switch APIs,

up to VMware vSphere 6.5 Upiate 1 ani prior vSphere versions,

as long as an active support ani subscription services contract

exists. In the next major vSphere release, ani upiate releases

post vSphere 6.5 Upiate 1, thiri party vSwitch APIs will be

completely removei ani thiri party vSwitches will no longer

work.

VMware is making free migration tools available to assist

customers in transitioning to vSphere Distributei Switch or,

customers can work with VMware's Professional Services

Organization.

If you are using 3ri party vSwitches, please contact your sales

representative with any questions ani to begin a transition plan.

##snap##

So Cisco, what does this mean??

Andy

Beginner

Andy, where did you receive

Andy, where did you receive this information?  This has been suspected but to date I haven't seen anything from VMware on the matter.  I also got the promise of Q1 support update from Cisco, but if 1000V support is going away after 6.5U1 we will have to make much bigger plans (that's a really short notice for deprecating such a huge piece of vmware).

If you received this in an email communication rather than published somewhere could you forward me a copy?

Hello,

Hello,

this is an information from VMware (basicly Screenshot from "My VMware"), but i get told that this will be a KB comming soon.

This will bring a lot of company's in big trouble. 

Cisco Employee

I received the same info from

I received the same info from a customer today - but could not verify on VMWARE site, or any other search?  

Participant

Here:

Here:

https://blogs.vmware.com/networkvirtualization/2017/03/native-vswitch.html

Moving forward, VMware will have a single virtual switch strategy that focuses on two sets of native virtual switch offerings – VMware vSphere® Standard Switch and vSphere Distributed Switch™ for VMware vSphere, and the Open virtual switch (OVS).  This strategy is about investing in the priorities of our customers and simplifying the platform to create the best, most secure experience possible.

It's not what is stated but what is not stated that is very revealing.  Their strategy going forward does not include third party Virtual Switches - because apparently 99% of their vSphere customers use their Native Virtual Switch.

Ivan Pelelnjak also wrote about it here:

http://blog.ipspace.net/2017/03/update-virtual-switches-in-vsphere.html

Hello,

Hello,

now its really official:

https://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=2149722&sliceId=1&docTypeID=DT_KB_1_1&dialogID=376768263&stateId=0%200%20431679313

Beginner

FYI, Release 5.2.1SV3(3.1)

FYI, Release 5.2.1SV3(3.1) was released yesterday.  Release notes show:

"This release of the Cisco Nexus 1000V supports vSphere 5.5, 6.0, and 6.5a release trains."

Release notes here

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus1000/sw/5_2_1_s_v_3_3_1/release/notes/b_Cisco_N1KV_VMware_521SV331_ReleaseNotes.html

https://software.cisco.com/download/release.html?mdfid=282646785&softwareid=282088129&release=5.2(1)SV3(3.1)&relind=null&rellifecycle=null&reltype=null&i=rn

I'm still unable to download it, as I reported to Cisco in January - they apparently haven't fixed the issue with CCO entitlements.

I didn't see anything in the release notes responding re: VMware's announcements.

It's a shame - I'd pay for 1000V+VSG in a heartbeat if it were going to be supported.  I migrated a couple hosts to VDS last night, and the fact that I have to do it through the slow, flash-based VMware web client made the job 5 times longer.

The 99% customer base VMware mentions are either people who don't know any better or are just drinking the VMware kool-aid.

Enthusiast

That's really interesting

That's really interesting piece of information. If this is just an internal memo from VMware, we should wait for Cisco's response. I'm pretty sure the install base of 3rd party vSwitches are quite huge.

Beginner

I've worked out how to

I've worked out how to install vSphere 6.5 with Nexus 1000V (or well, I actually did a somewhat upgrade from 6.0).

For the adventurous, here are my steps:

Since I was upgrading from vSphere 6.0, I already had ESXi 6.0 hosts installed. I'm not a fan of automated vCenter upgrades, so I installed a clean vCenter 6.5. While migrating everything over, I quickly found out that I cannot find a way to import my previous N1K extension. Temporarily migrated everything to a dVS.

So, since deploying N1K via OVAs obviously wouldn't work now, I decided to try VSUM. Installed it and deployed a Nexus 1000V. That worked, but.. VEM modules were shown as unsupported. Alright, updated all the VEM modules on the ESXi (6.0) hosts. Nexus 1000V started to work again.

After that I started to upgrade ESXi hosts to 6.5. No go - couldn't remediate since the N1K VEM was incompatible with ESXi 6.5.

Used the hacky solution provided by Reuben Farrelly above with slight modifications. Instead of changing the dependency to 6.5.0, I changed it to "greater than 5.5.0". If wouldn't have done that, I would've had to
*) Remove the previous VEM from all ESXis
*) Upgrade to ESXI 6.5
*) Install the repackaged VIB

Changing it to greater than 5.5.0 simplified it. Now I just had to
*) Upgrade the VEM on all the hosts (scripted it over SSH)
*) Upgrade ESXi to 6.5

Everything seems to work. N1K shows all modules attached and networking works.

Obviously a hacky solution but if you're coming from vSphere 6.0 and just interested in trying out vSphere 6.5, this is probably one of the easiest ways.

Enthusiast

Hello Reuben,

Hello Reuben,

have you tried installing N1KV using VSUM? This is rather straight forward process (with vCenter App 6.0).

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus1000/vsum/2-x/getting_started/b_Cisco_Nexus_1000V_Manager_Getting_Started_Guide_Release_2_x/b_Cisco_Nexus_1000V_Manager_Getting_Started_Guide_Release_2_x_chapter_01.html

Marcel

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards