cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
436
Views
0
Helpful
5
Replies
Highlighted
Beginner

Nexus 5596T with N2k-C2232PP and C2960s

Hi, we´re using two Nexus 5596s with VPC as Distribution Layer Switches - And 2960s as Access Layer switches - which is working Perfectly fine. Besides the fact that we are running out of Ports on the nexus swtiches. But as a solution we bought 2 Nexus 2232P Fex modules. We are planning to install them redundantly to both switches (I already prepared the config which I will post below). The only thing im asking myself right now is - how do i configure a redundant uplink for a Catalyst 2960x. Do I simply need to configure a Portchannel or do I need a VPC aswell when the Fex Modules are both connected to both Nexus switches? Config (will be applied on both Nexus switches) : 

 

interface port-channel3
description downstream.sw-di-203/204_FEX
switchport
switchport mode fex-fabric
fex associate 100
no shut

interface eth1/47
switchport
switchport mode fex-fabric
fex associate 100
channel-group 3
no shut

exit

fex 100
description upstream.sw-di-203/204

interface port-channel4
description downstream.sw-di-203/204_FEX
switchport
switchport mode fex-fabric
fex associate 101
no shut

interface eth1/48

switchport
switchport mode fex-fabric
fex associate 101
channel-group 4
no shut
exit

fex 101
description upstream.sw-di-203/204
Everyone's tags (2)
5 REPLIES 5
Highlighted
VIP Mentor

Re: Nexus 5596T with N2k-C2232PP and C2960s

As per my understanding, you already have set up running nexus and cat 2960 switch.

 

If you like to add new FEX, they connect to nexus 5K,( there is no Dual homed, then your config works as expected)

 

If they are dual-homed like FEx connected to 5K1 and 5K2 -then you need to add vpc config to port- channel.

 

how do i configure a redundant uplink for a Catalyst 2960x

I have not understood this statement? if you thinking to connect to 2960 to both 5K you mean, Port-channel at 2960 end, vPC at nexus side.

 

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Nexus 5596T with N2k-C2232PP and C2960s

Thanks for the Reply. In the meantime I have come so far to know that I want a "Active/Active FEX with Enhanced vPC" (see: https://community.cisco.com/t5/server-networking/difference-between-vpc-and-enhanced-vpc/m-p/2450401/highlight/false#M9055 )

The only thing that I need to know is if it is possible to connect more 2960s switches to the Fex modules with a Port-Channel (vpc?). I only ever see clients connectected to those. See Picture in Post I linked above.

Highlighted
VIP Mentor

Re: Nexus 5596T with N2k-C2232PP and C2960s

As i have provided the information, FEX to extend the network in DC environment. for the End Device to Connect like servers.

 

If you like Cat 2960 connect into the network, suggest and recommend to connect to Nexus 5K rather to FEX ?  does this answer your question?

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Nexus 5596T with N2k-C2232PP and C2960s

Unfortunately I do not have enough ports on the Nexus itself to attach 6 more Stacks of 2960s 

Highlighted
VIP Mentor

Re: Nexus 5596T with N2k-C2232PP and C2960s

To be honest, I have not tried it

i understand your restrictions and limitation of ports

 

2 options :

Options1 :

Migrate any server can move to FEX

 

Options2 :

You can try that is risk connecting Switch to FEX (i do not recommend)

(why risk is by default FEX port set a Portfast).

 

BB
*** Rate All Helpful Responses ***