cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1459
Views
5
Helpful
8
Replies
Highlighted
Enthusiast

Nexus 9000v vxlan evpn

Hi. 

Does VXLAN EVPN inter-vxlan routing work in data plane on Nexus 9000v? I followed steps documented, but the ping messages don't pass between vxlans. Intra-vxlan traffic has no issue. 

8 REPLIES 8
Enthusiast

Re: Nexus 9000v vxlan evpn

There are just vxlan type-2 routes inside BGP EVPN table, but no any type-5. Why isn't there any type-5 routes?

here is my shared configs of VTEPs (nexus 9000v (nxos.7.0.3.I7.2)):

 

fabric forwarding anycast-gateway-mac 1234.5678.90ab
!
vlan 2
  vn-segment 2
  name customer_A_vlan
vlan 3
  vn-segment 3
  name customer_B_vlan
vlan 4
  vn-segment 4
  name customer_A_L3_routing_vxlan_vlan
vlan 5
  vn-segment 5
  name customer_B_L3_routing_vxlan_vlan
!
vrf context A
  vni 4
  rd auto
  address-family ipv4 unicast
    route-target both auto
    route-target both auto evpn
vrf context B
  vni 5
  rd auto
  address-family ipv4 unicast
    route-target both auto
    route-target both auto evpn
!
interface Vlan2
  description customer A 
  no shutdown
  vrf member A
  ip address 99.1.1.1/29
  fabric forwarding mode anycast-gateway
!
interface Vlan3
  description customer B 
  no shutdown
  vrf member B
  ip address 99.1.1.20/29
  fabric forwarding mode anycast-gateway
!
interface Vlan4
  no shutdown
  vrf member A
  ip forward
!
interface Vlan5
  no shutdown
  vrf member B
  ip forward
!
interface nve1
  no shutdown
  host-reachability protocol bgp
  source-interface loopback1
  member vni 2
    mcast-group 224.1.1.1
  member vni 3
    mcast-group 224.1.1.3
  member vni 4 associate-vrf
  member vni 5 associate-vrf
!
router bgp 2
  address-family ipv4 unicast
  address-family l2vpn evpn
  neighbor 2.2.2.2
    remote-as 2
    update-source loopback1
    address-family ipv4 unicast
      send-community
      send-community extended
    address-family l2vpn evpn
      send-community
      send-community extended
  vrf A
    address-family ipv4 unicast
      advertise l2vpn evpn
  vrf B
    address-family ipv4 unicast
      advertise l2vpn evpn
!
evpn
  vni 2 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 3 l2
    rd auto
    route-target import auto
    route-target export auto

intra-vxlan traffic is fine. but between vxlans, isn't. 

Enthusiast

Re: Nexus 9000v vxlan evpn

Any Idea guys? Isn't there anyone who has worked with VXLAN on Nexus throughout the Data Center forum on Cisco?!!
Enthusiast

Re: Nexus 9000v vxlan evpn

I found the answer by myself. Thought I could get my answers here but it seems no one cares. 

Cisco Employee

Re: Nexus 9000v vxlan evpn

Can you at least share what you did to fix it? 

Enthusiast

Re: Nexus 9000v vxlan evpn

Hi;
Please refer to the post that I wrote about this in more details. http://www.tcpuniverse.com/cisco/deploying-vxlan-with-cisco-nexus-9000v-part-1/
Contributor

Re: Nexus 9000v vxlan evpn

Did you ever resolve this? I am trying to build a Spine Leaf architecture as well and am looking for some help.

Contributor

Re: Nexus 9000v vxlan evpn

Hey I just say this and I care bro :)

I am looking for some help with building Spine Leaf architecture.

Beginner

Re: Nexus 9000v vxlan evpn

hi,

can you share what was missing in your config? It looks fine to me.

 

BR

V

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards
This widget could not be displayed.