ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1037
Views
0
Helpful
1
Replies
Highlighted
Beginner

peer-link is down,vPC keep-alive is Suspended

SW1#

interface Ethernet1/1
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/2
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/3
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 20 mode active

interface port-channel10
no switchport
ip address 1.1.1.1/24

 

interface port-channel20
switchport mode trunk
spanning-tree port type network
vpc peer-link

vpc domain 100
role priority 4098
peer-keepalive destination 1.1.1.2 source 1.1.1.1
delay restore 150
auto-recovery

SW2#

interface Ethernet1/1
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/2
no switchport
channel-group 10 mode active
no shutdown

interface Ethernet1/3
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/4
switchport mode trunk
channel-group 20 mode active

 

interface port-channel10
no switchport
ip address 1.1.1.2/24

 

interface port-channel20
switchport mode trunk
spanning-tree port type network
vpc peer-link

vpc domain 100
role priority 4096
peer-keepalive destination 1.1.1.1 source 1.1.1.2
delay restore 150
auto-recovery

SW1# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
p - Up in delay-lacp mode (member)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
10 Po10(RU) Eth LACP Eth1/1(P) Eth1/2(P)
20 Po20(SU) Eth LACP Eth1/3(P) Eth1/4(P)
sw2# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
b - BFD Session Wait
S - Switched R - Routed
U - Up (port-channel)
p - Up in delay-lacp mode (member)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
10 Po10(RU) Eth LACP Eth1/1(P) Eth1/2(P)
20 Po20(SU) Eth LACP Eth1/3(P) Eth1/4(P)

SW1# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
Peer status : peer link is down
vPC keep-alive status : Suspended (Destination IP not reachable)
Configuration consistency status : failed
Per-vlan consistency status : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 inconsistency reason : Consistency Check Not Performed
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Enabled, timer is off.(timeout = 240s)
Delay-restore status : Timer is off.(timeout = 150s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po20 up -

sw2# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 100
Peer status : peer link is down
vPC keep-alive status : Suspended (Destination IP not reachable)
Configuration consistency status : failed
Per-vlan consistency status : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 inconsistency reason : Consistency Check Not Performed
vPC role : none established
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Disabled (due to peer configuration)
Auto-recovery status : Enabled, timer is off.(timeout = 240s)
Delay-restore status : Timer is off.(timeout = 150s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po20 up -

Everyone's tags (1)
1 REPLY 1
Highlighted

Re: peer-link is down,vPC keep-alive is Suspended

Hi,

Show vpc clearly states that

vPC keep-alive status : Suspended (Destination IP not reachable) that means the somehow your routing is not working.

 

vpc domain 100
role priority 4098
peer-keepalive destination 1.1.1.2 source 1.1.1.1

 

Here, by default Management VRF is chosen to route. So please check what VRF you are using in order to route the keepalive link traffic.

You can check if any firewall in between that might be blocking the default port UDP / 3200 used by the keepalive process.

 

 

This widget could not be displayed.