Showing results for 
Search instead for 
Did you mean: 

SMU Manager v2 (AKA CSMv2) and Service Packs (SP)

Cisco Employee

Are you tried of SMU management? Working out the Pre-requistes and Supersede list of a SMU?

Do you want a simple tool which does complete software management on XR platforms?

Do you want in app downloads of your SMUs so you don't need to search for them on CCO?

Do you want a simple view of all the SMUs and SPs available, their impact, the functions they touch?

CSMv2 is your tool, it's a complete end-2-end software management application for all XR platforms, download it and start using it now:

CSMv2 features

  - Service Pack and SMU management on ASR9000, CRS and NCS6000

  - In-App SMU and Service Pack download

  - Create your own SMU TAR(An alternative is SP)

  - SMU Size Calculation(handy for RSP2) and Proxy Lan support


The next version of CSM will support complete SMU, SP Management and provisioning of SW, zero touch simplified major and minor release upgrades that cut down your OPEX and Maintenance windows and simplify and ensure your upgrade is easy and successful. Stay tuned, for now, start using CSMv2.


Learn more:

Download CSM

User Documentation

Video Training

Service Packs





Hi Eddie,


I have a few questions regarding service pack and CSM 2.0.


I just finished upgrading from 4.3.0 to 4.3.4 (ASR9K with ISM). 


1. I have installed and activated following packages

install activate 


But after that I do not see SP1 in show install active summ

Active Packages:


This is because SP2 supersedes SP1, and install activate disk0:asr9k-px-4.3.4.sp1-1.0.0  was not necessary, right?

In show version I see both, SP1 and SP2 and this is a little bit confusing.


asr9k-os-mbi-4.3.4.sp2, V 1.0.0[SMU], Cisco Systems, at disk0:asr9k-os-mbi-4.3.4.sp2-1.0.0

asr9k-os-mbi-4.3.4.sp1, V 1.0.0[SMU], Cisco Systems, at disk0:asr9k-os-mbi-4.3.4.sp1-1.0.0


2. On CSM 2.0 I still see that a large number of SMUs are not activated even I have activated two SPs which has several fixes (checked in readme.txt).

 I am probably missing something and I can not play with the ASR because it's in production network.

I could also be that CMS is still not supporting Service packs?


    C O N F O R M A N C E     R E P O R T  -  Wednesday, May 28, 2014 8:27:10 AM CEST
                                                                                                                                                          NUMBER OF DEVICES            
IMPACT         SMU NAME                         DESCRIPTION                                                                     UNCOMPRESSED SIZE INSTALLED  NOT INSTALLED
Hitless         asr9k-px-4.3.4.CSCum97742       EIGRP topo entry with bogus nexthop created when SoO and TAG are present                   2681061         0              1
Traffic Loss   asr9k-px-4.3.4.CSCun32418       BGP Umbrella DDTS #1 for 4.3.4                                                            34423061         0              1
Hitless         asr9k-px-4.3.4.CSCun19764       Umbrella SMU for BNG                                                                      53184132         0              1
Traffic Loss   asr9k-px-4.3.4.CSCum27065       511-SIT: PVRSTAG doesn't send BPDU packet after RPFO                                       3161155         0              1
Hitless         asr9k-px-4.3.4.CSCuj83661       Can't poll rttMonJitterStatsEntry after 9 hours (hr index  > 9)                           5124711         0              1
Hitless         asr9k-px-4.3.4.CSCui09934       Bindings are not created for IANA and IAPD with same IAID for standalone                   3640355         0              1
ISSU/Reload     asr9k-px-4.3.4.CSCui15435       Recovery mechanism needed for FPGA soft errors on Trident Linecards                      57075873         0              1
Needs Reboot   asr9k-px-4.3.4.CSCun26020       VIDMON umbrella SMU3                                                                       3517245         0              1
Needs Reboot   asr9k-px-4.3.4.CSCuo22306       Umbrella DDTS for NP lockup fixes                                                        22728119         0              1
Needs Reboot   asr9k-px-4.3.4.CSCun75418       DWDM Umbrella SMU for 4.3.4                                                              12653072         0              1
Hitless         asr9k-px-4.3.4.CSCuj01579       CEF Wrong RPF pointer                                                                     3127188         0              1
Hitless         asr9k-px-4.3.4.CSCum26074       for RPs, voltage, power & on-board temp sensors values are not available                   1951589         0              1
Needs Reboot   asr9k-px-4.3.4.CSCul58246       Service Pack version handling                                                            65961577         0              1
Traffic Loss   asr9k-px-4.3.4.CSCun15934       Need to back out CSCuc61851.                                                               6259290         0              1
ISSU/Reload     asr9k-px-4.3.4.CSCug75299       PPS input to NPU should be managed as needed by chip errata                              75280071         0              1
Needs Reboot   asr9k-px-4.3.4.CSCul39674       Fabric link retrain between typhoon and RSP440 (RX)                                      18738655         0              1
Hitless         asr9k-px-4.3.4.CSCum51429       SW fix for power supply fan failure false alarm                                            451508         0              1
Needs Reboot   asr9k-px-4.3.4.CSCum03261       Need to drop traffic when lineproto is down on SIP700                                     8705562         0              1
ISSU/Reload     asr9k-px-4.3.4.CSCui94441       Need support for ONS-SC+-10G-C Tunable Optics                                            69451786         0              1
Traffic Loss   asr9k-px-4.3.4.CSCum43188       VRRP checksums not being set on Virtual Interface                                         2866836         0              1
DEVICE NAME         PACKAGE NAME                     COMMENTS                    asr9k-px-4.3.4.CSCum97742       Not Installed                
                    asr9k-px-4.3.4.CSCun32418       Not Installed                
                    asr9k-px-4.3.4.CSCun19764       Not Applicable (requires asr9k-bng-px)
                    asr9k-px-4.3.4.CSCum27065       Not Installed                
                    asr9k-px-4.3.4.CSCuj83661       Not Installed                
                    asr9k-px-4.3.4.CSCui09934       Not Installed                
                    asr9k-px-4.3.4.CSCui15435       Not Installed                
                    asr9k-px-4.3.4.CSCun26020       Not Applicable (requires asr9k-video-px)
                    asr9k-px-4.3.4.CSCuo22306       Not Installed                
                    asr9k-px-4.3.4.CSCun75418       Not Installed                
                    asr9k-px-4.3.4.CSCuj01579       Not Installed                
                    asr9k-px-4.3.4.CSCum26074       Not Installed                
                    asr9k-px-4.3.4.CSCul58246       Not Installed                
                    asr9k-px-4.3.4.CSCun15934       Not Installed                
                    asr9k-px-4.3.4.CSCug75299       Not Installed                
                    asr9k-px-4.3.4.CSCul39674       Not Installed                
                    asr9k-px-4.3.4.CSCum51429       Not Installed                
                    asr9k-px-4.3.4.CSCum03261       Not Installed                
                    asr9k-px-4.3.4.CSCui94441       Not Installed                
                    asr9k-px-4.3.4.CSCum43188       Not Installed                
                    asr9k-px-4.3.4.sp2-1.0.0         Active                        
DEVICE NAME         INSTALLED       SUPERSEDED     NOT INSTALLED       1               0               20             
And great job with all the documents that you are making for us. It makes everything much easier.


Cisco Employee

Hi Sam,


1) Correct SP1 is not needed if SP2 is installed. There is a new command you will see which supports this superce change, the command is show inst superceded, though with that said there is a little problem which is fixed in SP3 which fixes the output. From here on you will only see superceded smus in show inst superceded. they won't appear in show install active. Only partial supers will appear in show install active.


2) CSMv2 supports SP. You need to switch to Service Pack Tab in CSM to manage server packs. Once you do and IF you have those smus installed this is what you would see:You need to switch to Service Pack Tab in CSM to manage server packs.

When do you expect to go live? Can you wait for SP3? I can try to put a small fire under it, a few folks are asking for it.





I totaly missed the service pack tab. Thanks for the hint.

I have to upgrade a second ASR9K next week. It would be nice to have SP3 so that I can finish it all in one step. It's not easy to get a MW and I like it when everything is patched up :)

Service pack is a great feature!


I am a little bit concerned about SP and indivudual SMUs. 

"At the moment individual SMUs are NOT to be installed on top of 
Service Packs unless instructed by Cisco" 

There should not be a problem if I install a SMU which came after the SP?

But what is after a new SP is out and it covers this SMU which is already activated?

Do I have to deactivate it first or can I activate new SP over this SMU?




Cisco Employee

Hmmmm i don't think i can pull SP3 by next week, it wouldn't have completed all its testing.. 2 weeks ok :)?

Theoretically you can, install all SMUs on top of SP, except for those SMUs which have OS-MBI changes, and the system will block you there. Thats because we can only have on OS-MBI Software running at any given time. Apart from that other SMUs can be installed, but we don't test them together, because we just don't have infinite resources. (lean and mean and cranking innovation out is the motto). So because you do it check with me, i can give you a yay or nay. Or wait for next SP. If SMU is installed on system and SP comes later, SP is smart enough, it will say hey i'm newer because my DNA has the SMU you have within me, so i will superced it, you can see this info in four places. a) CSM, b) a new sexy show install which on system command in 5.1.1 and readme, and bug toolkit. You can just active the SP and it will whip the SMU.

Sam believe me, we have had many discussions on SP/SMUs, and a lot of customers have come back and said you know what, keep them separate and parallel, if we mix SP and SMU again then what is the point of SP..? It brings additional complexity which is SP is trying to solve..


Good thing is, your with cisco, we are no backyard shop, we love our customers, we listen and above all we do something about it, i guess maybe thats why we are still in business. SO if you have a situation where a fix is needed on top of SP and you can't wait for the standard SP release cycle, drop me an email or call the TAC, your never alone my friend.





Aha, no problem. I can try to postpone the upgrade, or try to get two MW's

We have some problems with CGNAT and netflow export on 4.3.0. (SR 630437397) where the ISM is crashing. For now netflow export is not configured on the box with 4.3.0. On 4.3.4 it's working fine since the upgrade (finished it this morning). I hope that we have solved this issue for good.

We are totally happy with Cisco, but only if we know the right persons in the BU :).

Cisco (thanks to Xander) made a feature for us on BNG!

If we have a mojor problem I will of course contact TAC and ask for help. There are good people there.


p.s. If you can tell me the extact release date of SP3 I can try to upgrade it this day.


Content for Community-Ad

This widget could not be displayed.