cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

ASR9000/XR What is the difference between the -p- and -px- files ?

10849
Views
10
Helpful
30
Comments

Introduction

With XR 4.2.0 the ASR9000 is releasing a new line of hardware models. This amongst others is the RSP440, the next generation RSP with faster switch fabric along with Typhoon based Linecards, the next generation network processor.

 

Explanation

 

In the TAR file from CCO there are files like asr9k-mini-p.pie or asr9k-mini-px.pie. The reason why there are 2 sets of files is because there are 2 hardware versions of the RSP.

The RSP2, the "old" RSP is based on a dual core PPC. The new RSP440 has an 4 core Intel processor.

Because PPC and INTEL handle endians differently, there are compiler differences to generate sw for the different PPC and the INTEL.

 

Features and functionality are the same between RSP2 and RSP3. Scale might be different.

 

The trident based linecards (2T20G, 40GE, 4T, 8T, 8T/4) as well as the new typhoon linecards (24x10GE, MOD80, MOD160, 100G) are all

PPC based.

 

What that means is that Only when you have an RSP3 in your system, you need to load the PX images.

When you have an RSP2 based system you need to load the P images.

 

The precense of a Trident or Typhoon linecard doesn't matter. So an RSP2 with a typhoon LC, still runs the -p images.

 

When you are upgrading from RSP to RSP440, this can't be done "hot". RSP2 and RSP440 can't coexist in the same system.

 

 

 

This simple table helps in the selection process, note that this applies for XR 4.2.0 and later.

 

 

RSP RP CPU type Linecard
  Trident Based (PPC)
Typhoon Based (PPC)
Tomahawk Based (x86)
ASR9001 PPC N/A P N/A
RSP2 PPC P P N/A
RSP440 x86 PX PX PX
RSP880 x86 N/A PX PX

 

 

 

 

Related Information

If you are considering downgrading RSP2 or ASR9001 from 513 to 43 or earlier, take note of the following stipulation:

https://supportforums.cisco.com/blog/12710781/asr9001rsp2-downgrading-513-434-or-earlier-might-give-smu-installation-issues

 

 

 

Xander Thuijs, CCIE #6775

Principal Engineer XR/ASR9000

Comments
Cisco Employee

Ok make sure you also to include the fpd pie. As thats now on its own....so to reformat: 

1) Download ASR9K-iosxr-px-5.1.3.tar and asr9k-px-5.1.3.sp7.pie from 5.1.3 asr9k section, untar and put asr9k-mini-px.pie-5.1.3, asr9k-fpd-px.pie-5.1.3 and asr9k-px-5.1.3.sp7.pie on your tftp/ftp server

2) On the asr9k, go to admin mode and do the following:

"admin install add source tftp://<ip>/path/asr9k-mini-px.pie-5.1.3 asr9k-fpd-px.pie-5.1.3 activate prompt-level none"

The router will reboot and come up with 5.1.3, log back in and do the following:

admin install commit

Once your on 5.1.3, 

"admin install add tftp://<ip>/path/asr9k-px-5.1.3.sp7.pie activate prompt-level none"

The router will reboot and come up with 5.1.3+SP7, log back in and do the following:

admin install commit

You don't need to install any 4.2.3 SMUs. Just follow the steps above.

Beginner

I was thinking that, thank you for advice Eddie,I'll do it tonight

Regards

Tural

Beginner

Hi Eddie, 

without any SMU, mini with fpd together added and activated.Later activated the SP7.

Thanks for sharing your experience.

Regards

TuralL 

Cisco Employee

Thats great! sorry that it was a little messing about, that was needed as you transitioned from p to px and to Service Packs. Going forward its all much more simple. So simple impact you don't need to do it anymore. CSM Server can automate all this for you, so if you managing multiple devices, CSM server is your software managment friend. 

Beginner

Hi Eddie,

I want to upgrade the image on XR 12000 from 3.6.1 to 4.3.1 but as there is not direct procedure I have to do it as first to 3.9.2 and then from 3.9.2 to 4.3.1. 

I checked there is not Post expiry SMU for 3.6.2 and 3.9.2 for these versions.Does it mean that there is not a problem with certificate in this versions ?

For XR 12000 the SMU is added to the 4.1.1 and later releases.

Regards

TuralL

Cisco Employee

Tural.

The process your stipulated is correct. And your correct we don't have a pre/post expiry smu for old releases. Here is a trick though and use that if you want to avoid the smu foo bar.. disable ntp and set the system clock to 2013 and try the install. 

Eddie.

Hi Xander,

How do we check what any package supports. What are all the features supported in a software package. (Like k9sec -SSH).

Warm Regards,

Thiyagarajan B

Cisco Employee

hi Thiyagarajan,

  • mcast—Multicast package, any mcast forwarding, pim igmp etc
  • mgbl—Manageability package, access to certain mibs, xml
  • mpls—MPLS package, all label switching
  • k9sec—Security package, ssh
  • diags—Diagnostics package
  • fpd—Field-programmable device package, all firmware for the fpd's on RP, LC and chassis.
  • doc—Documentation package, man pages
  • bng - all iedge and subscriber related functionality (not AAA, that is in base)

helps?

cheers

xander

Thanks xander,

This can help a few distance, but was searching for 'track' feature support and found out it in mgbl. Need a document for these things or feature set display in feature navigator.

Warm regards,

Thiyagarajan B 

Beginner

Its is interesting that you would keep using the px name after unifying the images with ppc, when previously it suggested a single specific architecture (x86).

Using a new image name would've helped avoid that confusion.

I'm wondering how the image names will develop with XR61, when RSP440 hopefully gets 64bit linux, something the 32bit PPC CPU on the 9001 won't be able to handle. Do we get 64bit linux for Intel based gear and 32bit QNX for the PPC CPU's in the same image?

Cisco Employee

x in this case is not x86 but a kiss and since we all love xr still, the 'x' was kept.

the 9001 is a 32 bit ppc processor, it won't run 64 bit and correct there will be for the time being a 32bit qnx and a 64bit lnx.

cheers!

xander

Cisco Employee

Hi Xander,

Could you please tell me which type of card is consider as RSP2.

I am looking for a RSP card for ASR99004 which is PPC.

Thanks

Amir

Cisco Employee

hi amir,

the RSP2 is the supervisor card, or the route processor.

note that the RSP2 is end of life (or going to be soon) and its last release is 53x.

the RSP2 can run in the 9904. the 9904 requires a minimal sw release of 52 however.

in order to run the high powered linecards like typhoon you're better of RSP440 or RSP880 if you are running Tomahawk LC's.

xander

Beginner

Does this mean we should be installing and activating SMUs for both px and p types or just one or the other? I am upgrading for a client a 9006 with A9K-RSP-8G, which looks to be an RSP2 and uses p files now.

Cisco Employee

hi geoffrey, the 4.2.3 for RSP2 uses -p- files. anything above, like 51x uses -px- only.

this means that once you upgrade to the -px- based images, the rollback by activating the 4.2.3-p- image doesn't work any longer.

you can rollback by reloading the device if you didnt commit your -px- image yet, or via a turboboot.

there are a few things to consider with RSP2 also, such as the disk repartition to reclaim some extra space.

a good guide is available here for instance as there are some pre-req smu's to get away from 4.2.3:

https://www.cisco.com/web/Cisco_IOS_XR_Software/pdf/ASR9k_Upgrade_Downgrade_Procedure_IOSXR_Rel_512.pdf

if that is all too much, a turboboot on the targeted image may be the fastest option. Or upgrade the standby RSP's in a lab device and bring them back to the site (if the number of devices is limited).

cheers

xander

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards