Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Firmware 1.5 (Transition path to QNAP, Time Machine fix)

Firmware 1.5 for Cisco Smart Storage has just been posted.  See announcement link or check the software center directly.   Release notes for the firmware will also be posted shortly.

The biggest news with Cisco fw1.5 is that users can migrate to QNAP branded software via the standard firmware upgrade process.

  • Upgrade your unit to the new fw1.5
  • Visit and download the latest QNAP fw3.5, upgrade with this file
  • Your unit will now be running the latest feature set from QNAP.

This should give users the ability to receive bug fixes and feature improvements quicker.

Transistion Disclaimers:

  • Visit for a list of feature differences between Cisco fw1.5 and QNAP fw3.5
  • There is no way to migrate a unit back once you upload a QNAP branded software image.  If you have questions about how the QNAP branded features vary or specific support questions, please post those to the QNAP support forum.
  • Two specific features are not supported on QNAP firmware: Mozy online backup and Cisco Access Now remote access.
  • Cisco Small Business Support Center engineers will not be able to help troubleshoot QNAP branded firmware units.  All software support for QNAP branded software will come from QNAP.  Support options are posted at
  • HW warranty will still be processed by Cisco regardless of the software loaded on the unit. 

Apple Time Machine issue with Lion

  • This is not fixed in Cisco fw1.5.  Only the generic AFP issue has been addressed.
  • The path to fix this bug is to migrate to QNAP branded firmware (specifically fw 3.5)

Upgraded to 1.5, went smoothly.

Try to put 3.5 build 816 on it,

[Firmware Upgrade] Update failure: Model mismatch.

Appears this is not ready yet.

The upgrade path from Cisco firmware 1.5.0 ==> QNAP 3.5 is ready. You would need to download the correct base model. Here are the reference to NSS300:

- NSS322  ===> QNAP TS-259 Pro

- NSS324  ===> QNAP TS-459 Pro

- NSS326  ===>  QNAP TS-659 Pro

  Please verify to make sure you have the correct firmware.




Make sure you download the correct QNAP product firmware. 

Bullet E on the page list the models as per below.  If you download the wrong firmware from QNAP (ie. not the correct model, you will see that error).

Cisco NSS322 is QNAP TS-259Pro+

Cisco NSS324 is QNAP  TS-459Pro+

Cisco NSS326 is QNAP TS-659Pro+

Thanks for the reply, that worked.

On bullet point with the download it wasn't really mentioned, and then I didn't immediately see there was a selector on the download page.  Box is rebooting now, thanks again.

Hi David

can you please post those image steps again. in a zip file, because i cant see them for some reason.



Cisco Employee

I had no issues migrating a 324 from 1.4 to 1.5 to 3.5.  No data loss (I did back up my data).  This takes a little bit of time so set aside a few hours.

In between FW revs I did check the satus and operation - It has CIFS, AFP, ISCSI and NFS mounts all to check which I did and have no errors to report.  QNAP 3.5 code also fixes TimeMachine access and backp from Lion.

Best to pre-stage the FW first (go download everything prior to the update)   As a final step I did check the file system when I was up on 3.5.

It all worked out very well for me.   Here is what I did:







Before I did this next step I valided the operation of the NSS and the 1.5 load - it all worked fine so Next:






Message was edited by: David Cappello  (added the graphics/screen shots back in)

I switched over to QNAP last night. Sorry cisco but I was happy to move this device away from Cisco firmware. NSS products never got focus from Cisco because it was not their primary focus. Since QNAP's primary focus is NAS devices, I am sure they would react to any features or issues sooner than cisco.

THanks but I cannot see your screen shots anymore?

When I download the Qnap firmware it comes as a .zip file. I think unzip it into a .dmg file but the firmware upgrade screen for the FW 1.5 NSS will not accept a .dmg file nor the .zip file?

Thanks again.

- Adam

Not sure whats up with not being able to see screen shots - perhaps clear your cache?   I can still see them - no matter if I am logged in or not.  

Yes you have to unzip the Qnap files after you download them - NSS upgrade will NOT take a .zip or .dmg file.  

When you unzip them you will have a .img file - example:  TS-459_3.5.0_Build0815.img  for (Cisco NSS324 is QNAP  TS-459Pro+)

Cisco Employee

My NSS324 appears to be a QNAP 459 Pro after being upgraded, not the Pro+.  The image download apears to be the same exact image for Pro, Pro+ and Pro II.  Anyone getting different results?

I think they are all one and the same - look at the SKU mappings here for the list:

(where in the Qnap software are you seeing what make/model)

David that link on qnap appears to be broken.

Sent from Cisco Technical Support iPad App

Regards Simon

That Qnap and Cisco link does seem to be broken.  Not sure why/how will have look for the moved page.

I can tell you a

NSS324 is a Qnap 459Pro+

and a NSS326 is a Qnap 659Pro+



I have recently come in possession of a NS322 that's on FW v1.3 - does anyone still have the FW1.5 tucked away someplace that I can download please ? I'm looking to make the jump to QNAP on the device but need the intermediatry upgrade.


Many thanks,