Showing results for 
Search instead for 
Did you mean: 

NSS 3000 Permissions Help

I have 2 NSS 3000 (fw 1.15) devices with CIFS shares configured.

- MAC and Windows users.

- Multiple users under the NSUSERS group.

- Users assigned Read/Write access.

Whenever a user creates a folder they become read only regardless of MAC/PC or permission settings.

What am I doing wrong?

Thanks in advance.

Cisco Employee

You are not doing anything wrong. I would be willing to bet that your Mac clients are on 10.6; and or you are on an ADS domain. Is any of this accurate?

Please post more specifics of your environment and user OS versions.

Thank you.


Thank you for the response, network and client details below:

Mix of MAC and Windows PC's on WORKGROUP peer network (no ADS or domain controller)

Router - Linksys WRT160N

Switches - 2 Linksys SR224

MAC O/S versions:





Tested on each client (one user logs in to each mac and creates a folder, then view folder info from the other clients with same result Read Only.

Windows O/S versions:

XP Home

XP Professional

Vista Home Premium

Windows 7 Home Premium

Would any logs help in the diagnosis?

Thanks again.


That is good news.

On the Macs make sure that in the network settings, you have specified the "Workgroup" under WINS.

Next, make the users on the NSS same as on the Macs that are accessing the shares; password and all. This holds true to the PCs as well. Remmember, when sharing files on PCs that are part of a workgroup, all computers need to have an user account for all users in the workgroup.

I hope that made sense.

So Mac user "SJobs" with PWD "loves apples"; will have an account on the NSS exactly like that. Each Mac user should be able to log into their Mac and NSS using the same user name and PWD. Obviously, this is not to imply a Single Sign-on.

PC users that will be accessing the NSS will also need to be configured in the same manner, so each user will have their credentials identical on the NSS and on their work station. This will create the "True" workgroup environment and should resolve your porblems.

Keep us posted.


I'm still not able to successfully create an environment where the MAC clients can create files that are editable by other MAC or Windows clients.

I changed all user accounts and passwords to match the NSS accounts, and confirmed the workgroup name in the WINS field of the client network settings.

Am I the only user to be experiencing this condition?

Any assistance will save my job.




I'm still not able to create an environment where the created files are read/write!

I modified all usernames and passwords to match desktops and the NSS3000 and I confirmed all WINS set to the correct workgroup.

Some files show up with no permissions, and others with read only.

Any additional thoughts?


Dear all,

We are in the same situation with an added point: The problem is with the folders. If you place a file in the share root it works perfectly.

We're working under Mac OSX 10.5 and 10.6, and Windows 7

Any help will be welcome

Best regards,



Hi Joaquim,

I'm still in the same situation.

I have created all new client and NSS accounts, all with aligned usernames and passwords, but the same thing happens.

My improvised solution was to login as Admin, grab all the files and folders, and reset the permissions to the values I needed. Then, have each user connect as Admin.  Because of this I'm not using the NSS for anything important, just a dump for large media files. I've gone back to a Linux server with a RAID card.

I look forward to any further assistance from Cisco.



I've just discovered the problem is just with the OSX Users! (10.5 and 10.6). Windows 7 users has no problems to create folders and files with all the permissions to be modified by the Mac users... Now I'm trying to upgrade the firmware.

Best regards