Showing results for 
Search instead for 
Did you mean: 

NSS3000 "forgets" AD Membership, no CIFS log, shares are unavailable


I have a pretty weird issue with an nss3000:

It has the newest Firmware (1.16), we configured it to be an AD member, it had only one share where all the data have been stored.

Suddenly the NSS decided to "forget" all the configuration settings we made (sounds strange, but was really from one day to the other without any abvious reason).

In detail this means:

1.) the prevously configured share is not available anymore

2.) If I try to take a look at the CIFS log, they are not showing up, when I try to download them, I receive an empty .txt file

3.) Under Network - Identification all three possibilities are blank (Workgroup, NT4 Domain, AD Domain) and if I fill one of those with valid data and submit this information, the nss tells me that has successfully joined the domain, but there is never showing up a computer account in the AD with the corresponding name and I also don´t see any evidence, that the nss tried to connect to the domaincontroller. Before this strange behaviour started, the information I provided for doamin membership showed up in that window.

4.) The User list is completely empty

5.) Under Shares tells me, that there are no shares defined, but if I try to create a new share, tells me that there is nor more space left for creating a new share.

This is what we tried so far:

1.) Reboot - Shutdown -Wait - Start: no change

2.) Flash one more time with the newst firmware: no change

3.) Try to join the domain using NT4 Domain or AD membership: no change

I am afraid to make a complete factory reset, because we don´t have any access to data stored on the nss and would be a pity to loose them, this would be only the very fast possibility to take in account.

I hope somebody got a similar issue or has an idea, what else we could try to reanimate the nss

Thanks in Advance



I have just the same problem with my nss3000.

I also have a nas in an active directory and my CIFS-shares disappear once in a while.

The only thing that works for now to get my data back, is to restore the nas with the configuration file I saved previously with the same nas.
If in this configuration file the shares are saved, then you have your data back.

If you don't have a saved configuration file, I think you have a problem for getting your data back.

But I am still looking for a solution that this won’t happen again.
I have to restore my nas once about every month.
Maybe I have to wait for a new firmware release.

Is there anyone who knows a solution to stop the problem of the strange disappearing CIFS shares?

PS: The FTP shares keep working.



thanks for your reply... I just had the same issue again with another box, the first one we send back to Cisco, but til now is still there, so I don´t know what´s the matter with it :-(

I tried to restore a previously saved configuration as you suggested, but unfortunately I was not as lucky as you ....

This time I had the chance to see at least a little bit in the log files, what´s the reason for this unfriendly behaviour, seems that the Samba Server used on the boxes to provide the shares is a rather old version.

Anyway, this time again no cifs shares, no log files, I guess the box is not able to read/write them wherever they may be stored (Flash?).

I just see under Access - Status Current CIFS Shares written there "params.c" which seem to be a fragment of an Samba Server message...

I guess I will send back also that box and hope that will come back faster than the other one


Hello Sharif,

I know this message is little old but just wanted to know if you are still with this issue. If so please post back with HDD model numbers, capacity, RAID information, etc.

Also, what version of Windows server, functional level, and any other information which you may feel of value. This will help in finding a solution and hopefully the cause.



What version of SAMBA is being used onthe NSS300 series appliances. This is a little scary to read since we just put in 7 326 and 324 units for several clients this week... all with AD integration.


Well, we replaced the NSS3000 with NSS324 and those are working like a charm, especially after the Firmware Upgrade.

I guess we really just had some extremely bad luck with the NSS3000, the new NSS300 Series didn´t fail until now... and we have already a lot of them out therer to our clients.


Hi Support,

     I have installed a NSS3000 on clients site and it has developed the above problem the CIFS shares become unavailable and it seems to fall out of the domain. if i then restore the config file it functions correctly for a few hours then repeats the problem. i have recently upgraded the firmware to the the latest from the support area (1.20.1) and the problem has appeared since the upgrade. if there is a fix or another firmware i should try please respond ASAP as my customer and me are getting a bit stressed with the problems it is causing.




Hello all,

I have the same problem with my NSS3000. Today it forgott half of my CIFS/samba shares and i have no way to access my data.

The seller of the product said that they had similar problems with another unit but this one worked fine... until now.

We had lots of important data on those shares that are now lost. Sadly i did not make a backup of the configuration so I'm hoping for some new firmware that will magicly find our shares again. I am more than willing to answer any questions from cisco support staff by email to help in hunting down this bug in the firmware.

I have gone through all the same steps and have the same problem as sharif.ibrahim stated in his post with the difference that i am running another firmware image.

Tecnichal info:

Firmware: 1.20.1

Serial: 7T600J200031

Disks(4 included): ST31500341AS

No warnings or errors in the logs ecept for that i cannot modify settings because the disk is full(at 21% of capacity)


The NSS300 series runs on a different hardware and software platform and does not share the same source (maybe apart from some Linux kernel stuff)

The NSS300 can therefore not inherit issues experienced with the NSS3000.

I highly recommend the NSS300 also for performance reasons.