Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Cannot login to RV042 or RV042G

I have been using the RV042 10/100 VPN Router for quite sometime. It just recently started having issues with intermittent internet connections. They would come ion, then go away. One of my engineers did some troubleshooting with the help of our ISP Tech support and determined that the router was bad. We ordered the RV042G to replace it. I came back in from a business trip to configure the new router. Before I started, I attempted to login to the RV042 router that was determined to be bad. I tried several browsers (Edge, IT, and Firefox) unsuccessful. It gave me a ssl certificate error and would not connect. So I thought that it must in fact be bad. I unpackaged the new RV042g and attempted to connect to it and I had the same problem. It would not allow me to connect because of the ssl certificate error. I'm using a surface pro 3 with windows 10 pro latest updates and release.

Do I have 2 bad routers or is there a compatibility problem with windows 10 and cisco? Any advice is appreciated!


Cisco Employee

Hi Mike

Can you share the screen error you are getting?

Usually if you do not have a ceritficate the browser should give you the option to bypass this and continue to the login page.

Try to access with internet explorer (not edge) in compatibility view.

Did you try using another Window OS in case there is one available

There is one bug depending on the firmware you have you could be hitting:

CSCuw38521    RV042x: SSL error for weak ephemeral DH key

In that case you can use the WA.




Was having the same issue, and also determined there was something wrong with the SSL cert chain. As it turns out, the built-in router cert only supports SHA1.  The only way I was able to circumvent this issue, and gain access to the admin web portal again, was to use Internet Explorer with advanced settings allowing ONLY SSL3.  This means you must uncheck all other security protocols; uncheck SSL 2.0, TLS 1.0/1.1/1.2, leaving only SSL 3.0 checked.  This will allow you to gain access to the admin portal again.  Cisco has now released firmware version which updates the certificate chain to SHA256 support.  You must download the firmware file first, before modifying your browser's advanced settings, as Cisco's own website SSL requires TLS. 

This is for RV042.  Use the "Cisco Small Business RV Series Routers" link at the top of the page to back up and select the RV042G for the gigabit version (although it's likely the same firmware file).

Here's the release notes:

Firmware Download Page:

Good solution SSL3.0 resolved the issue, thank you.


i had the same issue but in my case i used the safari browser and it worked!!!

Setting the ssl settings did not work for me. I had to use a stripped down browser before I could connect. Even after updating to I could not use Chrome, Firefox or Internet Explorer: same certificate error

My problem was Bitdefender trying to protect from Online Threat Prevention where the encrypted web page was not issued by a trusted authority
Recognize Your Peers
How would you describe your level of technical expertise?