cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2686
Views
0
Helpful
13
Replies

Cisco 897VA-M-K9 - MTU issue using bridge?

Have strange issue. Trying to bridge a vlan through Cisco 897 router. And the end device I'm only able to ping with 1496 MTU. This is a multicast device, everything works except normal file transfer.

I have set this up multiple times before and using same config. Except this is a new version of a router.

bridge irb
!
interface Ethernet0.22
description Outside
encapsulation dot1Q 22
bridge-group 22
bridge-group 22 spanning-disabled
!
!
interface Vlan20
description Inside
no ip address
bridge-group 22
bridge-group 22 spanning-disabled
!
!
interface GigabitEthernet7
description Physical Lan port
switchport access vlan 20
no ip address
spanning-tree portfast
!
bridge 22 protocol ieee
!

I have used this type of config on many different type of routers. 887, 881,1841,1921,1941. Never seen this before.

If I create BVI Interface I can ping with 1500 from outside. But I can't ping through the router with 1500. I'm thinking it has something to do with the 8x Gig port switch. For example I'm no longer able to increase the maximum MTU size on those ports. But I could do that with for example 887. Is there any reason this should not work?

And yes the MTU is just using it's default value. Both on outside interface and LAN interface. But I can't even edit the MTU on the LAN interface.

13 REPLIES 13
Philip D'Ath
Advisor

That config looks correct to me.  So you are bridging a VDSL tagged frame?

What software version are you using on the 897?

I'm just going to replace this router with 887VA. Cause I know this works on them. I would really want answer tho why I can't increase the MTU size above 1500 on these switch ports on 897VA router. Cause there is clearly something different between this router and the old.

I'm using c800-universalk9-mz.SPA.154-3.M5.bin

And yes I'm bridging through the router. I have often used this setup before. The device works on a different home router from the ISP, but not this one. Cause of this MTU issue. 

Philip D'Ath
Advisor

This is what is going through my head.  4 bytes is the size of a dot1q tag, and you are using tags.  I think Ethernet0 will need to support baby giant frames of 1504 bytes because of the tag.  What size MTU does Ethernet0 say it has?  Perhaps see if you can increase it to 1504.

This is a very long shot.  On GigabitEthernet7, try putting in a "switchport mode dot1q-tunnel".

Next long shot to try:

interface GigabitEthernet7
 description Physical Lan port
 switchport mode trunk
 switchport trunk native vlan 20
 switchport trunk allowed vlan 20
 spanning-tree portfast trunk

This did not help. It is very awkward when you have 100$ router next to this monster that does not have this problem and our customer is really considering to just use that router. 

One strange thing. I changed MTU on both outside interface to mtu 1550. And then also on the LAN interface to 1550. I then started to be able to ping. I removed those settings. It is still working?!?! So the config is back to normal after I removed the settings and the device is now working properly. 

I could not ofcourse change the MTU on the physical port. But right after me adding that config it started to work. Then when I removed it, it is still working.

I rebooted the router. After that the problem came back. I then only edited the MTU on the vlan 20 interface. MTU 1504. After that I can see the problem goes away. 

Looking at Cisco1841 router that is working. this is the config.

bridge irb
!

!
interface FastEthernet0/0.110
description inside
encapsulation dot1Q 110
no cdp enable
bridge-group 44
bridge-group 44 spanning-disabled

!
interface FastEthernet0/1.2325
description outside
encapsulation dot1Q 2325
bridge-group 44
bridge-group 44 spanning-disabled
!

bridge 44 protocol ieee

!

Cisco 892SFP-K9 is also working with same config and nearly the same box? Except I have had better experience with this box.

bridge irb

!
interface GigabitEthernet8.2304
description outside
encapsulation dot1Q 2304
bridge-group 44
bridge-group 44 spanning-disabled
!

!
interface Vlan20
description inside
no ip address
bridge-group 44
bridge-group 44 spanning-disabled
!

bridge 44 protocol ieee

!

So 897VA router is clearly handling the traffic in some way differently. 

So to be clear, did changing the MTU on the VLAN20 interfaces resolve the issue - or have you still got a problem?

The problem was resolved yes. But I would like to know why this is happening. I don't see any logical reason why VDSL ethernet0 interface should be treated differently?

Also why is it when I add this config, and then the problem is ok even though I removed the config that fixed this issue. But after a reboot of the router the problem comes again.

It would be great if you could rate and mark responses that were helpful.  :-)

I don't know why it is different.  Probably a different chipset with a different default MTU.

I need to know why. You must have a better answer or able to get answer from someone with better knowledge? This has to be a bug.

If you want an official response and you have a Cisco support contract, like a SmartNet, you can open up a TAC case and ask why.

I'm just a private individual - that was trying to help you.