cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4283
Views
6
Helpful
7
Replies
Highlighted

Cisco Router: RV110W

I'm trying to install a Cisco RV110W router in to my network, currently I have a service contract with TalkTalk broadband, which uses PPOA to connect me to the internet. I was advised to put the router they provided in to bridge mode, which I have done. Tee router they provided is a D-Link DSL-2680.

After connecting the ethernet cable to the WAN port of the Cisco and the LAN port 1 of the D-Link I can't seem to get the Cisco to initialise the internet.

I am selecting the PPPoE function in the Cisco router, however when using the D-Link router, it is usually a PPoA VC Mux connection. There does not seem to be an option to select a PPPoA connection in the Cisco router.

When it trys to connect there is no response from my modem/router in bridge mode.

I would like to use the Cisco router with my current router in this way. If this is not possible, I would like to make the Cisco give out the IP's and then have all the computers on the network route through the Cisco before getting to the internet allowing my firewall and access control setting etc to work. I'm not sure if this would be effective though as I'd also like to use the QoS and VPN options on the cisco too.

Is there a way to have the router/modem D-link run normally and connect the LAN port from the D-Link to my new cisco's LAN/WAN port to achieve this without forcing the cisco to connect itself to the internet and have it recognise the connection?

Any help is much appreciated.

You can see the Cisco GUI here ; Launch the Online Device Emulator

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

The different subnet mask thing we don't need, it was just to avoid having the two routers using the same network, which we took care of by changing the 2680 to 192.168.0.1.

You are correct about the odd gateway on the WAN connection, it should be 192.168.0.1 (the 2680).  I think that might be the problem, because your pings are never getting to the 2680, the RV110W routing table sends those to 192.168.0.2 for some reason. 

I am going to set this up at home here so I can go over it as well, in the mean time make sure you have power cycled everything at least once, and you might want to try reseting the RV110W and setting it up again (everything you've done so far has been correct)  Sounds silly I know but sometimes things just get stuck.

I am setting the same scenario up here right now, and I'll see if I can get it working.

Oh, and the only ping you were missing was to the WAN IP address of the 2680, but since you can't even ping that router's LAN port, it won't work anyway, so don't worry about it.

View solution in original post

7 REPLIES 7
Highlighted
Enthusiast

Hello Graeme,

I have done a bit of research and think I have a solution for you.

From everything I've read the RV110W does not have PPPoA as an option.  However, there is a way to use all of the features on the RV110W and just have the 2680 pass the traffic (basicaly what bridge mode is)

Just to say, I'm no expert on the D-Link 2680, so make sure to write down or backup any settings you might need just in case.

Basically what we are going to do is put the RV110W in the 2680's DMZ, and disable most of the features of the 2680.

Let's start with the 2680.  Setup it up the PPPoA as you normally would.

Then go to the admin page and under LAN settings disable the DHCP server.  Also take a look at the address for the router itself.  The default is usually 192.168.1.1, which is also what the RV110W uses, so change this to something else (I'll use 192.168.0.1 in my examples).  You'll probably lose your connection to the router once you save, to get it back just give your PC and IP address in the same network you just put the 2680 in (192.168.0.10 for example). 

You should now be able to get back into the admin page.  Go to the Firewall and DMZ settings, and disable the firewall.

Then enable DMZ, and pick and address for the RV110W to use (I'll use 192.168.0.2).  This will be the RV110W's WAN port address.

All that is left on the 2680 is to disable the wireless.  So now we should have wireless, DHCP, and the firewall turned off, as well as the DMZ enabled.

At this point you can plug the RV110W WAN port into a LAN on the 2680 and your PC to a LAN on the RV110W.  Change your IP settings back to DHCP on the PC and go to the RV110W admin page.

On the WAN settings page set it to use a static IP, and give it the IP you put in the DMZ (192.168.0.2 in my examples).  The default gateway will be the address of the 2680 (192.168.0.1). 

Save that and give it a test.  At this point the 2680 should be sending traffic directly, without firewall rules or anything, to the RV110W.  You can then go into the RV and set it up as you normally would for your network.

Give this a try and let me know how it works.

Highlighted

Hi Christopher,

Thank you for your help, it is very much appreciated.

I seem to have made some progress following your instructions above, but I still cannot access the internet and I'm not sure why.

I have attached some screen shots. One of the status screen which says the connection is up and one of the WAN settings, which are as you suggested. I've also attached a screen shot of the routing table, which seems to show the WAN gateway to that in the WAN settings?

I have also attached some shots from the 2680's GUI.

Are you able to advise any further on the matter, I think it may be something to do with DNS servers? Do they need to be internalised or something?

Highlighted

Hey Graeme, thanks for all the screenshots, looks correct to me.

Could you ping a few things for me?  That way we can see how far things are getting and where the problem might be.

From your PC hooked up to the RV110W, ping the following addresses:

192.168.1.1  (should definately work since you can reach that routers admin page)

192.168.0.1 (LAN port of the 2680)

The WAN IP of the 2680 (your public IP address, should be under status)

8.8.8.8 (to see if we can get out to a DNS server)

Also try doing a traceroute to something out on the internet.

You also mentioned that you think DNS might be causing a problem, go ahead and run nslookup for any website and see what it says. 

Here is a website about how to do all of that on a Mac in case you need it.

http://guide.netfronts.com/Advanced/Ping_and_Nslookup_with_Mac_OS_X.htm

Screenshot or copy and paste the results here and I will take a look.

Highlighted

Hi Christopher, thanks for a quick response, see results below:

That should be all of the pings etc you asked for...

Thanks - got another question too, but need to go offline to log in to the router for the screen shots.

Highlighted

There seems to be a descrepency between the gateway defined for the WAN in the settings and the one in the Routing Table.. not sure if this is a problem or I'm interpreting the data incorrectly.

I also noticed that when I was trying to get the connection working before I posted here originally, a lot of people were advising on having different subnet masks for the PPPoE modem and the router, I'm wondering if there may be a similar requirement for this. I did try changing it, but didn't seem to have any effect.

Highlighted

The different subnet mask thing we don't need, it was just to avoid having the two routers using the same network, which we took care of by changing the 2680 to 192.168.0.1.

You are correct about the odd gateway on the WAN connection, it should be 192.168.0.1 (the 2680).  I think that might be the problem, because your pings are never getting to the 2680, the RV110W routing table sends those to 192.168.0.2 for some reason. 

I am going to set this up at home here so I can go over it as well, in the mean time make sure you have power cycled everything at least once, and you might want to try reseting the RV110W and setting it up again (everything you've done so far has been correct)  Sounds silly I know but sometimes things just get stuck.

I am setting the same scenario up here right now, and I'll see if I can get it working.

Oh, and the only ping you were missing was to the WAN IP address of the 2680, but since you can't even ping that router's LAN port, it won't work anyway, so don't worry about it.

View solution in original post

Highlighted

Hi Chris,

I've just done a hard reset on the CIsco and turned on and off the D-Link and set everything back up again, I got a connection then, through the Cisco! However it went back down again, but, just turned everything off, and then the d-link on, then the Cisco on, then connecting through wireless/or Lan am getting a connection.

Therefore, at the moment all seems to be in working order. I am ever so greatful for your help.

It still has the random WAN gateway but seems to be playing ball!