cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3602
Views
0
Helpful
17
Replies

Cisco RV016 not so Intelligent Balancer

ict000001
Beginner
Beginner

Hi All,

We have a problem with our Cisco RV016 Routers (we have 12 of them).

Somehow the routers keep switching randomly between internet connections. (2-3 connections per router)

We want to completely disable load balancing and just use the 2nd to 3th internet connection as a failover (when 1st connection is down)

Load balancing breaks the clients session because the ip's switch mid session.

Does anyone have a solution to the problem?

We can't deploy them like this and our distributor does not want to take the unopened boxes with routers back.

We use:

Firmware Version : v4.2.2.08 (Apr 26 2013 19:12:26)

Regards,

1 Accepted Solution

Accepted Solutions

benjamin
Beginner
Beginner

Hi Wouter,

We had the same issue. What I did is create a rule in [System Management] - [Dual WAN] - [WAN 1 --> configuration].

The following rules are in my system:

All Traffic [TCP&UDP/1~65535]->192.168.1.1~192.168.1.254(0.0.0.0~0.0.0.0)WAN1 [Enabled]

All Traffic [TCP&UDP/1~65535]->192.168.1.1~192.168.1.254(0.0.0.0~0.0.0.0)WAN2 [Enabled]

The rest of the settings:

Enable Network Service Detection: Yes

Retry count: 5

Retry timeout: 30 seconds

When Fail: Keep the system log and remove the connection

Only [Remote Host] checked with value 8.8.8.8

Especially the setting with the remote host set to 8.8.8.8 is important.

Of course it's possible to set this to the IP address of the modem, but this only works if the complete modem is switched off. To failover when the internet connection is down, setting it to 8.8.8.8 works.

Hope this helps you.

View solution in original post

17 Replies 17

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Wrong forum, post in "small business router". You can move your post using the actions panel on the right.

Moved as requested.

Perhaps you know the answer?

Samir Darji
Contributor
Contributor

You can fix this problem one of two ways.  One is to bind the applications to a particular wan port.  I had to do this to use the state online sales tax system as it would drop the connection when the ip changed as you describe.

The second would be to disable load balancing and set up the rv016 for backup links.  The only disadvantage here is that all those other pipes will be just sitting idle until an outage.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

"The second would be to disable load balancing and set up the rv016 for backup links.  The only disadvantage here is that all those other pipes will be just sitting idle until an outage."

How do i configure this?

If you create a protocol binding rule to bind all traffic to WAN1, the traffic will be sent out through WAN1 when it's up. If WAN1 goes down, the traffic will then be load balanced to the rest of the WAN ports.

Protocol binding rule can be specified at System Management>Dual WAN page of the Web Admin Interface.

This is for the rv042.  For the rv016 It's System Management-->Multi-WAN, and then click edit on the WAN where you want the traffic to be.  You have to set up a rule there and save it.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

I had a really good answer typed out here and the forum ate it.

I was thinking of the rv042.  Once I checked my rv016, I noticed you can only do IP Group.  And if IP Group doesn't work, I'd use protocol binding or priority binding (which I just discovered).  The protocol binding is super-easy and would be what I recommend since I used it successfully for the exact same thing you're doing.  Post back if you want step-by-steps.  I had it all typed out before, but am too tired to do it again.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

benjamin
Beginner
Beginner

Hi Wouter,

We had the same issue. What I did is create a rule in [System Management] - [Dual WAN] - [WAN 1 --> configuration].

The following rules are in my system:

All Traffic [TCP&UDP/1~65535]->192.168.1.1~192.168.1.254(0.0.0.0~0.0.0.0)WAN1 [Enabled]

All Traffic [TCP&UDP/1~65535]->192.168.1.1~192.168.1.254(0.0.0.0~0.0.0.0)WAN2 [Enabled]

The rest of the settings:

Enable Network Service Detection: Yes

Retry count: 5

Retry timeout: 30 seconds

When Fail: Keep the system log and remove the connection

Only [Remote Host] checked with value 8.8.8.8

Especially the setting with the remote host set to 8.8.8.8 is important.

Of course it's possible to set this to the IP address of the modem, but this only works if the complete modem is switched off. To failover when the internet connection is down, setting it to 8.8.8.8 works.

Hope this helps you.

Thanks!! it works!!

Awesome that this works, and it's even easier as you don't even have to know what port it's using.

But I'm having some trouble understanding why this works.  Both routes are the same, so wouldn't any traffic coming in would be routed to either interface?

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Great that it works Wouter. Glad to be of service.

@Samir: it works because it is set as a fallback. So the Cisco tries to ping 8.8.8.8 every 30 seconds and retries that 5 times. The only thing is that after 2.5 minutes of downtime by 1 modem, the connection gets remove. But hey, use logging to inform you about that .

The list is a priority list. So if 8.8.8.8 can be pinged from the first connection, it doesn't try to use the 2nd option.

We are very happy that the previous issue is resolved, however we have a new one. (seemingly the last one)

As this is related to the multi-wan failover issue, we post it in the same place.


We can't get the VPN backup for a "Gateway to Gateway" tunnel to work. We set the "Remote Security Gateway Type" to "IP Only", but we can only configure one IP per tunnel. So when WAN1 goes down and we set up the "Tunnel Backup" under "Advanced" to connect to the same router in our datacentre over WAN2, we now of course use WAN2's IP and the connection gets refused. We also can't set up another VPN profile for the same local subnet.

Any ideas?

Maybe you can use access rules to convert the IP?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: