cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1069
Views
0
Helpful
6
Replies

Cisco RV345 - S2S VPN

tylerv
Beginner
Beginner

Why does the RV345 drop the VPN Connection every hour. We bought this router to replace an old RV016.

The RV016 always had a stable VPN but now this router does not. 

 

On the RV345 my IP Sec Profile is:

PH1

  • DH - Group2 - 1024 bit
  • Encryption - AES-128
  • Authentication - SHA1
  • SA Lifetime - 28800

PH2

  • Protocol Selection ESP
  • Encryption - 3DES
  • Authentication - SHA1
  • SA Lifetime - 28800
  • PFS - Unchecked
  • DH Group - Group 2 - 1024 Bit

On the other site I didn't make any changes. So should be using exactly what the RV016 was using. The other site has a Cisco 2921

 

Thanks!

6 REPLIES 6

balaji.bandi
VIP Guru VIP Guru
VIP Guru

what is the firmware running, some firmware reported as bug, worth upgrade to latest one, if your firmware is not the latest one.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

akashar2
Cisco Employee
Cisco Employee

Hi ,

 

My name is Akash and I am from Cisco SMB team . 

 

Configuration you have done is OK as VPN is working but as it is disconnecting intermittently , what are workaround done to set up vpn again or it gets connected automatically . 

 

For stable vpn connection the IP on WAN port of router must be static and not dynamic  .

 

Also check the firmware version on device and upgrade it to latest i.e1.0.03.17 .

 

Please find the link below to upgrade firmware if it is not latest . Please take backup of configuration before upgrade 

https://software.cisco.com/download/home/286288298/type/282465789/release/1.0.03.17?i=!pp

 

Thanks ,

Akash sharma 

Just confirmed that I have a static IP with my ISP so that's not an issue. Also firmware is the latest.

 

The VPN reconnects automatically so there isn't anything that I do to fix it.  It disconnects for about 10-15 seconds every hour disconnecting our remote desktops etc.

 

I've attached what I believe are the relevant logs.


Tyler

 

Hi tyler,

 

The issue is related to the SA lifetime. Make changes to Phase 2 SA lifetime. Change it to 3600sec from 28800sec.

 

Also under Advanced settings make sure Keepalive is enabled. Also under Firewall tab make sure Block WAN request is disabled.

 

Hope this helps. 

 

Do not forget to mark this post as the solution if your issue gets solved. Any helpful votes will be appreciated.

 

Regards,

Puneet Sandel

Those changes did not end up helping as it kept disconnecting every hour.

We put our old router back in and everything went back to normal. So there appears to be some issue with the router.

don't buy this Cisco junk its buggy and never works
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: