cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

511
Views
0
Helpful
9
Replies
lucas.pedro
Beginner

Difficulty with load balance and fail over - RV340

Hello, I have an RV340, and I have two internet links from two different ISPs. I would like to configure load balance and failover, but every time I disconnect WAN1 the WAN2 does not automatically take over. I no longer know what to do to make it work.

What have I done so far:

I left the precedence for failover at 1 and 2 respectively
I left both at 1 to load balance, but without success too
In LAN settings, I changed DNS to receive DNS from ISP, so there are no conflicts when one goes down.
In policy binding table, I left priority 1, Source IP Any, Destination IP Any, Services ALL, Outgoing WAN1 Interface, Failover to Backup WAN ON, Status checked.

So far, the closest I've come was that the two WANs worked together, but when I disconnect WAN1, WAN2 didn't take over. I even managed to run ping tests, but I can't navigate, apparently there is a DNS error.

Important things:
WAN1 receives IP via DHCP from ISP1 router
WAN2 receives IP via PPPoE
8.8.8.8 pings normally
other DNS ips pings normally

Below are some images of my settings.

Screenshot_1.pngScreenshot_2.pngScreenshot_3.pngScreenshot_4.pngScreenshot_5.pngScreenshot_6.pngScreenshot_7.pngScreenshot_8.png

2 ACCEPTED SOLUTIONS

Accepted Solutions
lucas.pedro
Beginner

I switched to proxy as suggested, and failover and load balance work, but the DNS error still persists, but in a different way, sometimes I will access a certain page it gives the DNS error, but the next moment the page is reloaded normally, I believe because of trying to resolve the DNS of another operator. What I think would work would be to use the same DNS on both links, but my fear is that when using a DNS like 8.8.8.8 and 8.8.4.4 in a company, the DNS owner will drop my connection for commercial use of DNS free.

I don't know if anyone here on the forum uses these two DNS on the desktop, but I think it could work.

View solution in original post

nagrajk1969
Beginner

Yes, you are thinking correctly. Please use the Google public DNS servers 8.8.8.8, 8.8.4.4....these will work perfectly. Dont hesitate to use the Google servers..they are public dns servers for use by all

Another alternative is OpenDNS servers...

 

 

View solution in original post

9 REPLIES 9
nagrajk1969
Beginner

Hello Lucas

 

My most humble suggestion is 

1. Keep all the present configurations (on the wan interfaces and lan/dhcp ) as it is 

2. But try by deleting the policy-routing/rule that you have added. Dont configure or add any policy-routing/policy-rule for either load-balancing-mode or when configured as Fail-Over mode

- becos by default the RV340 is in fail-over mode, and by default there is NO policy-route-rule observed in the table..so dont add any yourselves

- the same is true for load-balancing mode...there is no explicit rule that is visible in the policy-route table...so dont add any of your own rule....keep everything as it is by default...

- like this attached screenshot

 

 

try it out..maybe it will work correctly after deleting all the policy-routes/rules that you have added

 

nagrajk1969
Beginner

what i think is that irrespective of whether the wan interfaces are in Fail-over or Load-Balancing modes, IF we add policy-binding rules manually, it means that we are "overriding" the "default" behavior of the "mode" we have configured on the wan interfaces in multiwan section of the GUI

 

So if we want fail-over to work properly as per "default" config, then DO NOT ADD ANY MANUAL POLICY-BINDING RULES..

- The same applies for "load-balancing" mode too...

lucas.pedro
Beginner

Looks like it worked, now I have output from both ISPs, end of day I'll test failover.
This is my next doubt, if my router is with the load balance at 50% on each link, automatically when a link goes down, the other will take over? Or, for failover to work, do I need to disable load balance?

nagrajk1969
Beginner

Yes, in Load-Balance too, if wan1 fails, all the traffic simply will be shifted and routed via wan2 automatically (and vice-versa).

No, you should not and need not change from load-balance to fail-over 

 

thanks

 

lucas.pedro
Beginner

By keeping the setting for Failover (1, 2), when I remove the ISP cable on WAN1, I can no longer browse the internet. A DNS error is displayed in the browser (print attached). And when I keep the configuration in Load Balance (1, 1), such error is displayed from time to time, and when removing cable from WAN 1, the error also persists.

The error that is displayed is: DNS_PROBE_FINISHED_BAD_CONFIG (so I assume it is a DNS error)

Important things:
On WAN 1: Use DHCP provided DNS server
On WAN 2: Use PPPoE provided DNS server
On LAN: DNS-Provided-Server-ISP

 

Where am I going wrong? What should I do to make it work correctly?

 

nagrajk1969
Beginner

whats happening in your network, is that 

 

1. when the wan1 was up, and its isp dns-server was set to say for example 11.1.1.2/11.1.1.3. So now the dhcp-clients in your lan/vlan1 network are being assigned the dns-server ipaddrs 11.1.1.2/11.1.1.3, and they all are using these dns-server ipaddresses while browsing the internet via wan1

 

2. Now wan1 is down and wan2 is UP. And the wan2 isp-dns-servers are set to say for example 14.1.1.2/14.1.1.3, And the fail-over OR load-balance mode is active

 

- BUT, i observe that the dhcp-clients in the lan/vlan1 network continue to have their dns-server ipaddresses set to 11.1.1.2/11.1.1.3...which is why you are now unable to resolve your url/http addresses for internet access

 

- i dont know YET whether this is a bug or something...but ideally in both fail-over/Load-balance modes, if say for example wan1 goes down, then since wan2 is to be used for routing all internet traffic, IDEALLY the dhcp-server on the RV160 should re-initialize/restart with the dns-server ipaddresses of WAN2-isp...and this restart/re-initialize of dhcp-server would ofcourse result in ALL the dhcp-clients in lan-network to do a renew/release process and therefore again get their dhcp-ipaddresses re-assigned BUT now with the new set of dns-server ipaddresses that are of wan2-ISP

- and this should result in continued access to internet webservers using wan2 now...

 

 

3. So i would highly recommend that to avoid the problems with dns-resolutions, try using the setting "DNS Proxy" in the lan-dhcp-server settings for lan-interface...

- what this does is to set the dns-server ipaddr as the vlan1-lan-interface ipaddr to ALL the dhcp-clients in the lan-network

- this gives a very added advantage that now you dont have to worry about which wan interface is UP and which dns-server ipaddreses are being used (ISP1 or ISP2) for resolving...for the lan-hosts, the dns-server ipaddr is simply the vlan1-lan interface ipaddress, and the dns-resolution will definitely get resolved by either of the ISP1 or ISP2 dns-servers whichever is reachable

 

 

nagrajk1969
Beginner

so in summary:

 

1. with your present settings of "Use DNS from ISP" for the lan-network, whenever the wan1 goes down (in either fail-over or load-balance modes), you will need to restart the dhcp-client service on each of the lan-hosts in the vlan1 network to get the correct dns-server ipaddresses (of wan2-isp) re-assigned by RV340.

- this is a problem and i think a bug (as explained in point-2 of previous post of mine)

2. So the highly recommended suggestion from me is to change the present setting of "Use DNS from ISP" in the vlan1/lan dhcp-server settings to "Use DNS-Proxy", which will set assign the dns-server ipaddr as the vlan1-interface ipaddress (i think in your case its 10.1.1.1 i guess..whichver you have configured) to all the dhcp-clients in lan-network...and it will work correctly

 

hope this is of help

 

best-regards

 

lucas.pedro
Beginner

I switched to proxy as suggested, and failover and load balance work, but the DNS error still persists, but in a different way, sometimes I will access a certain page it gives the DNS error, but the next moment the page is reloaded normally, I believe because of trying to resolve the DNS of another operator. What I think would work would be to use the same DNS on both links, but my fear is that when using a DNS like 8.8.8.8 and 8.8.4.4 in a company, the DNS owner will drop my connection for commercial use of DNS free.

I don't know if anyone here on the forum uses these two DNS on the desktop, but I think it could work.

View solution in original post

nagrajk1969
Beginner

Yes, you are thinking correctly. Please use the Google public DNS servers 8.8.8.8, 8.8.4.4....these will work perfectly. Dont hesitate to use the Google servers..they are public dns servers for use by all

Another alternative is OpenDNS servers...

 

 

View solution in original post