cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

508
Views
0
Helpful
1
Replies
Beginner

ip sla tracking

Dear Experts,

We have cisco router 3900. I configured IP SLA for redundant link in our Wi-Fi solution. But it is not working. can anyone help on this for trouble the configuration.

ip dhcp excluded-address 10.10.0.1 10.10.1.0
ip dhcp excluded-address 10.20.0.1 10.20.1.0
ip dhcp excluded-address 192.168.100.1 192.168.100.99
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool MGT-VLAN
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1 
dns-server 8.8.8.8
lease 0 3
!
ip dhcp pool WIFI-USER-1
network 10.20.0.0 255.255.0.0
default-router 10.20.0.1 
dns-server 84.235.6.55 84.235.57.230 
option 242 ascii l2q=1,l2qvlan=15
lease 0 3
!
ip dhcp pool Voip
network 192.168.100.0 255.255.255.0
option 242 ascii MCIPADD=192.168.100.20,MCPORT=1719,HTTPSRVR=192.168.100.40,VLA NTEST=0
default-router 192.168.100.19 
!
ip dhcp pool PTT-1 Voice
network 192.168.1.0 255.255.255.0
default-router 192.168.1.15 
option 242 ascii MCIPADD=192.168.1.13,MCPORT=1719 
lease 0 3
!
!
!
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username stcs privilege 15 password 0 stcs
!
redundancy
!
track 1 ip sla 1 reachability

ip ssh version 2
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/0.10
description * Mgnt Vlan *
encapsulation dot1Q 10
ip address 10.10.0.1 255.255.0.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.15
description Voip
encapsulation dot1Q 15
ip address 192.168.100.1 255.255.255.0
!
interface GigabitEthernet0/0.20
description * Wireless Users Interface Vlan *
encapsulation dot1Q 20
ip address 10.20.0.1 255.255.0.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.25
description Voip PTT-1
encapsulation dot1Q 25
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/1
description ****Connection to S-4****
ip address 192.168.4.110 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
no ip address
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/3
description ****Connection to T-2****
ip address 192.168.3.100 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1/0
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip nat inside source route-map LINE1 interface GigabitEthernet0/3 overload
ip nat inside source route-map LINE2 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 8.8.8.8 track 1
ip route 0.0.0.0 0.0.0.0 192.168.101.60
ip route 0.0.0.0 0.0.0.0 192.168.4.1
ip route 0.0.0.0 0.0.0.0 192.168.3.1

ip access-list standard LAN
permit 10.20.0.0 0.0.255.255
permit 10.10.0.0 0.0.255.255
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0/3
frequency 10
ip sla schedule 1 life forever start-time now
!
route-map LINE2 permit 10
match ip address LAN
match interface GigabitEthernet0/1
!
route-map LINE1 permit 10
match ip address LAN
match interface GigabitEthernet0/3
!

 

Everyone's tags (3)
1 REPLY 1
Highlighted
VIP Advisor

Re: ip sla tracking

you need to track as below to work :

 


ip route 0.0.0.0 0.0.0.0 8.8.8.8 track 1 <--- remove this one
ip route 0.0.0.0 0.0.0.0 192.168.101.60

Track below interface :

ip route 0.0.0.0 0.0.0.0 192.168.4.1
ip route 0.0.0.0 0.0.0.0 192.168.3.1

 

Good example here :

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html

BB
*** Rate All Helpful Responses ***