cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1309
Views
0
Helpful
4
Replies

IPv6 Prefix-Delegation with dual stateless ISPs

leosoft
Level 1
Level 1

Hello,

I have a simple working IPv6 configuration with stateless autoconfig on Dialer1 and it is working fine.  My config is this:

!
ipv6 unicast-routing
!
ipv6 dhcp pool BVI1_DHCP
 import dns-server
 import domain-name
!
interface Dialer1
 description connected to Internet through VDSL 
 mtu 1492
 ip address negotiated 
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer idle-timeout 0
 dialer-group 1
 no cdp enable
 ipv6 address autoconfig default
 ipv6 enable
 ipv6 verify unicast reverse-path
 ipv6 dhcp client pd ASSIGNED-PREFIX
 ipv6 traffic-filter IPV6IN in
 ppp authentication chap pap callin
 ppp chap hostname xxxx@myISP-A.com
 ppp chap password xxxxxxxxxxxxxxxxxx
 ppp pap sent-username xxxx@myISP-A.com password xxxxxxxxxxxxxxxxxx
 ppp ipcp dns request accept
!
interface BVI1
 mac-address b000.abcd.abcd
 ip address 192.168.x.x 255.255.255.0
 no ip redirects
 no ip unreachables
 ip mtu 1476
 ip flow ingress
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1436
 ipv6 address ASSIGNED-PREFIX ::/64 eui-64
 ipv6 enable
 ipv6 nd other-config-flag
 ipv6 verify unicast reverse-path
 ipv6 dhcp server BVI1_DHCP
!
ipv6 route ::/0 Dialer1
!

But I also have another stateless connection over Dialer2 which i want to use it concurrently :

!
interface Dialer2
 mtu 1492
 ip address negotiated 
 no ip redirects
 no ip unreachables 
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in 
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 2
 dialer idle-timeout 0
 dialer-group 2
 no cdp enable
 ipv6 address FE80::ABCD:ABCD:ABCD:766C link-local
 ipv6 address autoconfig
 ipv6 enable
 ipv6 dhcp client pd ASSIGNED-PREFIX-Dialer2
ipv6 traffic-filter IPV6IN in ppp authentication chap pap callin ppp chap hostname xxxx@myISP-B.com ppp chap password xxxxxxxxxxxxxx ppp pap sent-username xxxx@mymyISP-B.com password xxxxxxxxxxxxxx ppp ipcp dns request accept !

As I said and before, under IPv4 everything is working fine and I am able to route specific traffic there or doing some load balancing with CEF etc.  Now  regarding IPv6, as you can see, there is a prefix-delegation request on Dialer1 which acquires the assigned prefix from ISP-A connection and I am able to use it with my inside interface (BVI1) ip.  What I want to do is to be able to acquire the prefix AND from my ISP-B and use it in BVI1 as an additional ip:

!
interface BVI1
 mac-address abcd.abcd.abcd
 ip address 192.168.x.x 255.255.255.0
 no ip redirects
 no ip unreachables
 ip mtu 1476
 ip flow ingress
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1436
 ipv6 address ASSIGNED-PREFIX ::/64 eui-64
 ipv6 address ASSIGNED-PREFIX-Dialer2 ::/64 eui-64
ipv6 enable ipv6 nd other-config-flag ipv6 verify unicast reverse-path ipv6 dhcp server BVI1_DHCP !

Unfortunately, ipv6 dhcp client pd ASSIGNED-PREFIX-Dialer2 seems it does not working for some reason. However Dialer2 is getting GUA and seems working.  What I am doing wrong???

cisco#sh ipv6 int d2
Dialer2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::ABCD:ABCD:ABCD:766C
  No Virtual link-local address(es):
  Stateless address autoconfig enabled
  Global unicast address(es):
    2A02:XXX:XXX:ABCD:ABCD:ABCD:ABCD:766C, subnet is 2A02:XXX:XXX:XXXX::/64 [EUI/CAL/PRE]
      valid lifetime 2591878 preferred lifetime 604678
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FFE0:766C
  MTU is 1492 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  Input features: Common Flow Table Stile classification On Cypher Text Dialer i/f override Access List Verify Unicast Reverse-Path Common Flow Table Post VPN Stile classification On Clear Text
  Output features: Common Flow Table Stile Classification CCE Classification Zone based Firewall Dialer idle reset
  Inbound access list IPV6IN
 IPv6 verify source reachable-via rx, allow default
   0 verification drop(s) (process), 0 (CEF)
   0 suppressed verification drop(s) (process), 0 (CEF)
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND advertised reachable time is 0 (unspecified)
  ND advertised retransmit interval is 0 (unspecified)
  ND router advertisements live for 1800 seconds
  ND advertised default router preference is Medium
  ND RAs are suppressed (periodic)
  Hosts use stateless autoconfig for addresses.
cisco#sh ipv6 general-prefix
IPv6 Prefix ASSIGNED-PREFIX, acquired via DHCP PD
  XXXX:XXX:XXX:XXXX::/56 Valid lifetime 69931, preferred lifetime 69931
   BVI1 (Address command)
IPv6 Prefix ASSIGNED-PREFIX-VLAN3, acquired via DHCP PD
   BVI1 (Address command)

Thanks for your time

 

 

4 Replies 4

Martin Aleksandrov
Cisco Employee
Cisco Employee

Hi, 

 

What is the device you are trying to configure the DHCP PD?

 

Here is the space for the Cisco Small Business and Cisco Business products. You may get better assistance if you post your question in the "networking discussion" section in Cisco Community. 

 

Regards,

Martin

 

 

Hello

 

Its a C886VA.  Thanks for suggestion. 

 

Regards

 

Leo

melenia77
Level 1
Level 1

nternet Service Provider (ISP) if you can get IPv6!” ... Resources are shared between the two protocols for both Control and ... IPv6 Next Hop Is an IPv4 Mapped IPv6 Address Built from ... Prefix Delegation w/ DHCPv6 PD (RFC3633) ... Simple, stateless, automatic IPv6-in-IPv4 encap and decap functions on 6rd (​CE & BR).mypantryfeedback

Can you give a config example of what you thought?  Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: