Showing results for 
Search instead for 
Did you mean: 

Issue with RV340 Failover to 4G LTE with a Verizon/Novatel USB730L

( Background, CCNA, trained on CCNP but didn't take exam. I come from enterprise networking working on 2960X's, 4500X's, integrated service routers, etc and these small business appliances I never seem to have luck with, and I hate GUI's because I can't view the config as easily.  I've had a Cisco 4507R+E I decommissioned with an uptime over 900 days.  Is there some major disconnect between Cisco Ent and Cisco SB?  )

I currently have an RV340 at this site, has done us okay so far until now besides the inter-vlan routing glitch with the latest firmware.  The RV325 just seemed much more reliable but is limited on features. 


We have an extremely unreliable cable provider at this site that often goes down for several hours during the weekend or after 5PM, one of those rural cable companies.  (They just now rolled out DOCSIS 3.0 and bumped customers from 8/1.5 to 35/5 megabit, while some customers are still only offered 1.5/0.1 megabit "Lite" internet)

I have purchased and added a Novatel/Verizon USB730L Global 4G LTE Modem with Unlimited Data, 4G speeds up to 15GB, not bad for a fail-over.


The RV340 sees the modem on USB2, connects to the LTE network, and even pulls a public IP address.  By default the modem required SIM PIN (1111) and was performing NAT, but I disabled that.  The modem works 100% fine on my laptop.

Sometimes the routing table shows the USB2 sometimes it does not but it is always metric 4 along with the WAN1 entry and the WAN1 subnet entry.  All VLAN metrics are 0.


Everything looks fine, the USB2 light is green, then I unplug WAN1 to test.  USB2 blinks green a few times, then goes out, then comes back amber.  I check the RV340 and it no longer is connected to the modem.  I plug WAN1 back in and it comes back, and USB2 light eventually goes back to green.

Can anyone provide guidance if I am doing something wrong?  I have tried enabling "Network Service Detection" on both, and then just the WAN, and then just the USB2, no dice.  

Even if I configure the opposite with USB2 as priority 1 on Multi-WAN, it gets skipped as it disconnects and fails over to WAN1.


If this is an issue with the RV340 I'm going to be livid, the modem is listed on the compatibility matrix?

It works fine on my laptop if I plug the USB directly in.

Last resort I'm going to try and get it working as the primary WAN on an RV325 then run double NAT and plug it into WAN2 on the RV340, I would be really disappointed in this RV340 if I had to do this but a colleague said that he's had to do it on every RV340/USB fail-over he's set up.


Let me know if you guys need screenshots, but I've followed just about every other setup I can find online down to a "T" and it has made no progress.


Any help would be so much appreciated at this point as we have signed a 2-year contract for this 4G stick and currently it is useless, and this is the cable companies most unreliable time of the year they claim due to "temperature changes throwing off our routing"... what.....


I am also having difficulty getting my RV340 to reliably stay connected to my Verizon / Novatel USB730L. There's an open bug report on this:

There doesn't seem to be a resolution. Cisco has classified the bug severity as "4 Minor". This doesn't seem minor to me since I'm using my cellular connection as a primary connection to my remote site. I'm extremely disappointed with Cisco's response to this issue.


Still having the same issue as of today, no luck even when I tried using an RV320.  Reprogramming the dongle with Linux also has not helped.


I am also having the same issue.  RV345P with WAN1/WAN2 operating in Weighted by Bandwidth the usb730L never goes down.  As soon as the WAN connection fail the "failover" "usb730L" FAILS....  This is very frustrating!