Showing results for 
Search instead for 
Did you mean: 

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter


new wrv210 issues, wifi drops, reboots

I just purchased a couple of these routers. One for home and for some business clients. So far I have only setup one at home and am kind of disappointed. I can consistently make the wifi drop by clicking to different menu items in the web config gui. In these cases, my wifi clients drop and cannot reconnect, even though the my ssid is still being broadcast by the router, but all clients on the ethernet switch can still ping the router and access the internet. A reboot is required to allow wireless clients to associate. For example, last night my browser was refreshing on the System Performance page for about 20 minutes. I clicked onto Router status and all wifi clients drop. If there is no easy solution to this I will get more technical information (packet captures of 802.11 association, wpa handshakes, etc).

In other cases, using the web interface will cause the router to reboot. I have a syslog server setup (on ethernet) but it doesn't receive anything except for URL Detections and New Connections.

I have a pretty simple setup at home, one ssid, 802.11b/g, wpa2 personal (I've tried Personal Mixed, too). The router seems to be running the latest firmware ( and a recent hw revision (WRTR-221G_V01).

I am heading to a client location to setup the 2nd wrv210 now. Are these known issues? Are there any solutions?


Re: new wrv210 issues, wifi drops, reboots

Good afternoon,

To my knowledge, I have yet to hear of an issue with the wireless clients experiencing connectivity issues. Ensure your firmware is upgraded to the newest version,, and something I would like you to try is doing a factory reset on your router by holding the "reset" button on the back of your device for about 30 seconds while it is powered on. This may just solve your issue on this one particular router; when they ship out fresh from the factory, it may just need a reset to clear out the memory and give it a "fresh" start. This would be my first line of attack for this issue, since it could very well be the cause.

If you follow through with this and are still experiencing issues, I would recommend posting the types of wireless cards that are losing connectivity and also ensure that, in fact, every single client is indeed losing the connection to the wireless.

Let us know how everything goes,



Re: new wrv210 issues, wifi drops, reboots

Thanks for the suggestion Lindsey. There are multiple wireless chipsets losing connectivity: Intel 5100 AGN on Windows 7, a Realtek 8187 on Linux, a Zyxel (not sure what chipset) on XP SP2, and an older Intel ipw2200 chipset on another Linux machine.

I followed your reset procedure but the router no longer responds on the web interface. The router responds to icmp on the default ip ( but telnet's to port 80 time out. So I restarted the router again by unplugging the power cord for 30 seconds and when it came back up it had my previous settings (I use a different subnet on that lan, So I tried that reset procedure a few more times w/ the same result. Now I'm trying the Factory Reset procedure from the web GUI, which is still showing all my settings even after the multiple resets.

Any more ideas?



Re: new wrv210 issues, wifi drops, reboots

This morning I tried reflashing the router (with the same firmware ver that is currently installed, I did it via the web interface, it said it succeeded and the router rebooted, but all my settings were still there, so I assume that means the flash actually failed.

Can you give me the procedure to flash via tftp? Though tftp is mentioned as supported in the specs, the procedure is omitted from the documentation I have (WRV210_AG_OL-20252.pdf downloaded 2 days ago from I attempted to put the firmware image via tftp but it just times out.

Thanks again.


Re: new wrv210 issues, wifi drops, reboots

Well the second wrv210 is installed, configured and performing great at my client's location. It's the same hw revision and firmware as the one I am having so many problems with. Does anyone have any more suggestions? I'm thinking it must be defective hardware. Continuted attempts to factory reset the wrv210 have gotten nowhere...

Thanks in advance,



Re: new wrv210 issues, wifi drops, reboots

Hi Keith, first of all, I want to start by saying that the fact that your configurations were still in place after the upgrade doesn't mean that the upgrade failed, plus if the device actually restart is very possible that everything went thru just ok.

As far as doing TFTP to the router, that option is not supported.

It seems like you have a broken device, please give us a call at the SBSC so we can help you better. 866-606-1866



Re: new wrv210 issues, wifi drops, reboots


The guys at Cisco Small Biz Support are great and RMA'd that first router. So I received the replacement yesterday and set it up. It's performing a lot better than the last one, except I get random reboots/lockups. Firmware The remote syslog seems to work though, so I gathered some evidence last night while I was out to dinner (so network activity was idle/light, is the wrv210 IP):

Mar 31 19:33:36 klogd: Packet type : 0 -- free socket buffer only

Mar 31 19:34:56 klogd: last message repeated 13 times

Mar 31 19:35:56 klogd: last message repeated 26 times

Mar 31 19:36:56 klogd: last message repeated 8 times

Mar 31 19:37:57 klogd: last message repeated 8 times

Mar 31 19:40:08 syslogd started: BusyBox v1.01 (2009.06.03-11:15+0000)
So a random restart while I wasn't home at 19:40 (PST), router restarts, boots, pppoe session starts (at&t adsl). I can see random iphones/wifi clients associating then the logs fill with:
Mar 31 20:17:04 klogd: Packet type : 0 -- free socket buffer only
Mar 31 20:18:07 klogd: last message repeated 36 times
Mar 31 20:19:10 klogd: last message repeated 36 times
Mar 31 20:20:11 klogd: last message repeated 18 times
Mar 31 20:21:29 klogd: last message repeated 33 times
Mar 31 20:22:29 klogd: last message repeated 30 times
Mar 31 20:23:29 klogd: last message repeated 22 times
Mar 31 20:24:29 klogd: last message repeated 18 times
Mar 31 20:25:29 klogd: last message repeated 26 times
Mar 31 20:26:29 klogd: last message repeated 22 times
Mar 31 20:27:29 klogd: last message repeated 38 times
Mar 31 20:28:29 klogd: last message repeated 16 times
Mar 31 20:29:29 klogd: last message repeated 12 times
Mar 31 20:29:41 syslogd started: BusyBox v1.01 (2009.06.03-11:15+0000)
Again it reboots, almost 50 min later.
Mar 31 21:30:46 klogd: rtl8651_user_pid set to 273
Mar 31 21:30:47 klogd: Packet type : 0 -- free socket buffer only
Mar 31 21:31:52 klogd: last message repeated 20 times
Mar 31 21:32:54 klogd: last message repeated 44 times
Mar 31 21:33:56 klogd: last message repeated 36 times
Mar 31 21:34:57 klogd: last message repeated 28 times
Mar 31 21:36:03 klogd: last message repeated 39 times
Mar 31 21:36:52 syslogd started: BusyBox v1.01 (2009.06.03-11:15+0000)
boom. another restart 67 minutes later....
Mar 31 22:20:35 klogd: last message repeated 19 times
Mar 31 22:21:29 syslogd started: BusyBox v1.01 (2009.06.03-11:15+0000)
Mar 31 22:21:29 klogd: klogd started: BusyBox v1.00-pre2 (2008.02.27-15:42+0000)
and again about 50 mins later. This happened all night.
I can only guess that some buffer is filling up and causing a restart. The funny thing is this happens less often while the network is utilized. I'd like to help figure this problem out any way I can. I've done the factory reset and re-configured. I'm about to try that again.
I also disabled the DoS attack stuff because:
Mar 31 12:18:59 [DoS] [Detected UDP Land Attack] (UDP) Incomming [Droped]
the router was getting some strange false positives (same src/dst IP, my wan interface). Also it doesn't inspire a lot of confidence that there are typo's in the firmware! "Incomming" and "Droped"
Thanks in advance,

Re: new wrv210 issues, wifi drops, reboots

First of all, this is my first post on here and I would like to say that I've learned a lot about these WRV210's since attempting my recent project.In advance, i don't claim to be any kind of expert here, just what I can think of.

On to business,

Setup is as follows

Device:               WRV210 (brand new) set as 'Gateway'

Firmware:   (on advice from many of the cisco reps on here)

Connection:        DSL  with PPPoE authentication on the router.

Networking:        2 SSIDs and 2 VLANs, - 1 for Internal (Hardwire ONLY, Local Ports ONLY), 1 for External (Wireless ONLY w/o access to remote admin)

DDNS:               YES, initially configured on the router, more recently moved OFF the router.


What has happened is that EVERY single night for 4 days, this DSL connected router has somehow been getting it's configuration reset back to initial factory defaults to the degree that it is giving back out 192.168.1.x addresses and losing it's DSL connection because the PPPoE credentials get wiped from the device.

Most recently I have tried the following:

MTU Size: I read in the forums here that there might be an issue with the MTU padding incorrectly some of the packets traveling through the router. So as told to me by the tech the other day, Jeff, with whom i spent 2 hours with on the phone, we found out that by setting this to MANUAL from Auto and leaving the value the same that when we saved it, the router would back to it's original 'AUTO' state. We found that by setting the value to less than the normal rate (1480) we thought that it would prevent whatever was causing the router to reset might correct it self. I was told that as this happens, at some point the WAN interface, after recieving too many erroring packets will "shutdown" entirely, causing all traffic to cease.

DDNS is Enabled issue: A side effect of the MTU packet change was the DDNS now being seen as 'enabled' and not the 'disabled' state that it has been for the last 4 days. I thought this to be a good sign until it went down again either last night or this morning. I think it was unresponsive at 1am when i got home from work having been reconfigured about 15 hours earlier

I have been trying everything I can think of to try and keep this router up and stable and accessible. It hasn't stayed up for over 18 hours since i installed it

Please HELP!!



Re: new wrv210 issues, wifi drops, reboots

Solution: If you check on google you will find that there are many users who are having this "lock-up" problem and they are very frustrated - this includes myself.

                Here is the solution - just upload the software version You can download this version from this Cisco website. It solves all problems. The GUI looks different, but all features are still there.

                So - I really think that this is a software problem and can be fixed by just loading a previous revision.

                 I do like this Router and I just purchased many more of them and I am loading the above software in all of them.

                 I like that it has VLAN and VPN and that you do not need to purchase any software and license for your computers to make VPN work.

                 If you have any question drop me note


Re: new wrv210 issues, wifi drops, reboots


Same problems (firmware and only help was to (update) firmware to After that, everything was better than fine. With firmware it drops wireless connection suddenly and sometimes hangs. Linksys firmware seems to work now. I hope Cisco is going to do, in future, updates, that have same reliability than Linksys team.


new wrv210 issues, wifi drops, reboots


I also have the same problem, however i cannot find the firmware available at cisco. can someone please send it or upload somewhere. Thanx.

Rising star

new wrv210 issues, wifi drops, reboots

Hello Ashken,

Thank you for posting. There was a new firmware released in June 2011, version Have you tried this? Also, I had some issues with the WRV210 when I had logging enabled all the time. The router would drop the internet connection and sometimes lose wireless connections. I disabled logging and the router has worked fine for over two years.