cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2329
Views
0
Helpful
9
Replies
Highlighted
Beginner

Possible bug with RV220W PPTP with firmware 1.0.1.0

I have a RV220W that I was running firmware 1.0.1.0 and I was having a very hard time getting the PPTP VPN to work on it so last night I did some testing

I downgraded to firmware 1.0.0.26 and did a factory reset and set up PPTP and tested and it worked.

I then restored my setting from a backup and tested and it worked

Then upgraded to 1.0.1.0, did a factory reset and tested and got disconnected from the VPN right away (no data in logs)

So in order to use PPTP I had to downgrade back to 1.0.0.26

Thanks,

Phil

9 REPLIES 9
Highlighted
Beginner

I have the exact same issue as well. I cannot connect viat PPTP using the latest firmware 1.0.1.0, but if I go back to 1.0.0.26 PPTP works fine!

Highlighted
Beginner

I experienced the same exact thing.  This is definitely a problem that should get fixed.

Highlighted
Rising star

Hi All,

I saw the same behaviour , but thought I must have done something wrong.

Now that I have confirmation.  I opened a case with the Small Business Support Center (SBSC)

The good folk at SBSC said yes, you guys are correct,  downgrade the firmware fixes the issue.

wow.

But then they said after the router is downgraded, upgrade it again to the current version of code and PPTP server will work .

OK

I also noticed that the software wouldn't  allow me to add the IP range for PPTP users in the same subnet as my VLAN1 addressed.

SBSC told me to set the vlan1 or the LAN ip address to another value, say 192.168.200.1.

Then set my PPTP range of addressed in PPTP server to say  192.168.1.250-192.168.1.253, the range I want to use.

Then alter the LAN setting back to say 192.168.1.1.

Wierd, but it worked.  I have no idea when the new software will come out, but SBSC told me they were aware of these little issues.

OK., it worked , but a little annoying, the router rebooted every time I altered the IP address of the LAN (vlan1) interface.

I was forced to grab a cup of tea.

regards Dave

Highlighted

Dave,

Thank you for the additional info! It gives me a few more work arounds at least.

Regards,

Jason

Highlighted

Same problem - can't make PPTP work at all with new firmware.  I would rather not back up to previous version.  Can CISCO advise when this bug might be fixed?

Highlighted

Hi all,

I retrograded and upgraded , as i was told that it would work, but it didn't.

I reached out to Small Business Support Center and they esclated my case .

I  agreed to accept some Betacode and test to see if it fixed the pptp server.

I will try out on my machine and update this posting, it may be that if it works, you open or update your case and ask for any potential beta fixes.

Hang in and let me see what it does, and better understand the implications of this betacode

regards Dave

Highlighted

Hi Guys,

A bug fix has gone into development,  it is bug id CSCto08922.  I wlll push it along on your behalf.    There is a wierd work around for the problem.

It involved doing the following;

step 1.  Getting hold of beta firmware from Level 2 support by asking the SBSC technician to escalate the case .

    refer the good folk at the SBSC to this posting if you are having any trouble.

    I am happy for them to contact me. You will need Firmware version 1.0.2.1, BUT don't install it yet

step 2. The new beta code has a problem with configuration of the PPTP server, you can't see the PPTP setting, hey it's betacode.

Step 3. So,  I made sure my RV220W is at the  current generally available  code version 1.0.0.26 so I could  configure the pptp server options.

Step 4.  unfortunately  i  had to altered my LAN network setting, as version 1.0.0.26 code does not allow you to have the PPTP range of addresses inside the existing LAN network.

So if you LAN address is 192.168.1.1 you will find you get a error if you try to  set the PPTP address range to 192.168.1.X to 192.168.1.Y

My LAN network was going to be 192.168.20.X, but after factory reset the LAN reverted back to 192.168.1.1.

I set my PPTP server to allocate IP range 192.168.20.250 to 192.168.20.254.

Step 5  I added my five PPTP user accounts.

step 6. I altered the  LAN IP of my router from 192.168.1.1  to my desired address of  192.168.20.1

Step 7.  Then upgraded to beta code. version 1.0.2.1.

PPTP  then worked like a dream - at last

There  should be no difficulty getting hold of Beta code version 1.0.2.1, but your case may need to be escalated . The following URL had contact details for the SBSC. 

Again my apologies for this hassle.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

regards Dave

Highlighted

Hi Dave,

I have a copy of this FW for my hair-pinning issue I don't know if you know this but the PPTP address and the checkbox to enable it is under IPsec/VPN Users (don't ask me why) know don't ask me if any changes made there take effect as I have not had time to test that part yet as I've been busy getting IPsec working with my Blackberry Playbook (got it working from my wifes school but not from my buildings wireless (going to my home network)) (oddly using the Juniper VPN client)

If you have a chance test out enableing PPTP from that screen and let me know if you have any luck!

Phil

Highlighted

Hi Phillip and others,

I have been in discussions on and off for the last days with Technical Engineers, so regarding this PPTP issue.

I have been told that the software given to me is not beta , but alpha - still not great code candidate  to release as a beta.

Phillip,  I have no idea how you got the code,  but great . 

So folks may have difficulty in getting the same code as Phillip, I have been told that better code will be abale for beta in a couple of weeks.

Doesn't help you today.

regards Dave