cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1763
Views
0
Helpful
6
Replies
skiNEwhere
Beginner

PPP not authenticating (Home ADSL connection)

I'm trying to migrate from my PK5001Z modem to my 2801 that I've used for labs in the past. It seems like I'm not getting very far in the authentication process.

Connecting to Centurylink, current configs on the working modem


Broadband Mode Setting: MULTIMODE
Broadband Mode Detected:ADSL_2plus
Path Parameter:0/32
Priority:UBR without PCR
Service Type:LLC Bridged
MTU Size:1492
MSS Size:1452
Wan Protocol:PPPoE

Current configs on router, omitted irrelevant parts.

Local#sho ver
Cisco IOS Software, 2801 Software (C2801-ADVENTERPRISEK9-M), Version 12.4(24)T8, RELEASE SOFTWARE (fc1)

Local#sho debug
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on

Local#sho dsl int
ATM0/3/0
Alcatel 20190 chipset information
Line not activated: displaying cached data from last activation
         ATU-R (DS)            ATU-C (US)
Modem Status:     Showtime (DMTDSL_DO_OPEN)
DSL Mode:     ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:      0x03                 0x2
Chip Vendor ID:     'STMI'                 'IFTN'
Chip Vendor Specific:  0x0000             0x71C5
Chip Vendor Country:   0x0F             0xB5
Modem Vendor ID: 'CSCO'                 '    '
Modem Vendor Specific: 0x0000             0x0000
Modem Vendor Country:  0xB5             0x00
Serial Number Near:   
Serial Number Far:     
ModemChip ID:      C196P (1)
DFE BOM:     DFE3.0 Annex A (1)
Capacity Used:     78%                 100%
Noise Margin:     -3.5 dB             17.0 dB
Output Power:     14.5 dBm             10.0 dBm
Attenuation:     20.0 dB             11.0 dB
FEC ES Errors:      7                  0
ES Errors:      7                  0
SES Errors:      7                  0
LOSES Errors:      7                  0
UES Errors:      0                 26
Defect Status:     LOS  LOF  LCD       LOM     LOS       LCD           
Last Fail Code:     None
Watchdog Counter: 0x29
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:     285035 (0 spurious)
PHY Access Err:     0
Activations:     6
LED Status:     OFF
LED On Time:     0
LED Off Time:     0
Init FW:     init_AMR-3.0.014_no_bist.bin
Operation FW:     AMR-3.0.014.bin
FW Source:     embedded
FW Version:     3.0.14

          DS Channel1      DS Channel0    US Channel1      US Channel0
Speed (kbps):              0           15872             0             892
Cells:                  0               1             0           29276
Reed-Solomon EC:          0             695             0             315
CRC Errors:              0             690             0             140
Header Errors:              0               2             0               7
Total BER:          0E-0         0E-0
Leakage Average BER:      0E-0         2E-0
Interleave Delay:      Available only during SHOWTIME
            ATU-R (DS)    ATU-C (US)
Bitswap:           enabled          enabled

LOM Monitoring : Disabled


DMT Bits Per Bin information for ADSL2+ is available only during SHOWTIME.

DSL: Training log buffer capability is not enabled
Local#sho inv
NAME: "chassis", DESCR: "2801 chassis"
PID: CISCO2801         , VID: V04 , SN:

NAME: "WIC/VIC/HWIC 1", DESCR: "Four port FXS DID voice interface daughtercard"
PID: VIC-4FXS/DID=     , VID: 3.1, SN:

NAME: "WIC/VIC 2", DESCR: "2nd generation two port FXO voice interface daughtercard"
PID: VIC2-2FXO         , VID: V02 , SN:

NAME: "WIC/VIC/HWIC 3", DESCR: "ADSL over POTS"
PID: HWIC-1ADSL        , VID: V01 , SN:

NAME: "PVDM 1", DESCR: "PVDMII DSP SIMM with one DSP"
PID: PVDM2-16          , VID: V01 , SN:

NAME: "AIM Service Engine 0", DESCR: "AIM Service Engine"
PID: AIM-CUE           , VID: V01 , SN:

(Plug in cable)
Local#
Oct  8 06:30:00.379: %LINK-3-UPDOWN: Interface ATM0/3/0, changed state to up
Oct  8 06:30:01.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/3/0, changed state to up
Local#
Oct  8 06:30:01.839: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
Oct  8 06:30:01.839: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
Local#
Oct  8 06:30:01.839: Vi2 PPP: Using dialer call direction
Oct  8 06:30:01.839: Vi2 PPP: Treating connection as a callout
Oct  8 06:30:01.839: Vi2 PPP: Session handle[10000005] Session id[3]
Oct  8 06:30:01.839: Vi2 PPP: Phase is ESTABLISHING, Active Open
Oct  8 06:30:01.839: Vi2 PPP: Authorization required
Oct  8 06:30:01.839: Vi2 PPP: No remote authentication for call-out
Oct  8 06:30:01.839: Vi2 LCP: O CONFREQ [Closed] id 76 len 10
Oct  8 06:30:01.843: Vi2 LCP:    MagicNumber 0x1D72BE94 (0x05061D72BE94)
Local#
Oct  8 06:30:03.851: Vi2 LCP: Timeout: State REQsent
Oct  8 06:30:03.851: Vi2 LCP: O CONFREQ [REQsent] id 77 len 10
Oct  8 06:30:03.851: Vi2 LCP:    MagicNumber 0x1D72BE94 (0x05061D72BE94)
Local#
Oct  8 06:30:05.867: Vi2 LCP: Timeout: State REQsent
Oct  8 06:30:05.867: Vi2 LCP: O CONFREQ [REQsent] id 78 len 10
Oct  8 06:30:05.867: Vi2 LCP:    MagicNumber 0x1D72BE94 (0x05061D72BE94)
Local#
Oct  8 06:30:07.883: Vi2 LCP: Timeout: State REQsent
Oct  8 06:30:07.883: Vi2 LCP: O CONFREQ [REQsent] id 79 len 10
Oct  8 06:30:07.883: Vi2 LCP:    MagicNumber 0x1D72BE94 (0x05061D72BE94)
Local#
Oct  8 06:30:09.899: Vi2 LCP: Timeout: State REQsent
Oct  8 06:30:09.899: Vi2 LCP: O CONFREQ [REQsent] id 80 len 10
Oct  8 06:30:09.899: Vi2 LCP:    MagicNumber 0x1D72BE94 (0x05061D72BE94)
Local#
Oct  8 06:30:10.375: %LINK-3-UPDOWN: Interface ATM0/3/0, changed state to down
Oct  8 06:30:11.347: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
Oct  8 06:30:11.347: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0
Oct  8 06:30:11.347: Vi2 PPP: Sending Acct Event[Down] id[5]
Oct  8 06:30:11.347: Vi2 LCP: State is Closed
Oct  8 06:30:11.347: Vi2 PPP: Phase is DOWN
Local#
Oct  8 06:30:11.375: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/3/0, changed state to down
Local#u all
All possible debugging has been turned off
Local#ter len 0
Local#sho run
Building configuration...


Current configuration : 3659 bytes
!
! Last configuration change at 00:29:15 MDT Thu Oct 8 2015
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Local
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone MDT -6
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.0.0 192.168.0.31
!
ip dhcp pool Phones
   network 192.16.0.0 255.255.255.192
   default-router 192.168.0.4
   option 150 ip 192.168.0.4
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
vpdn enable
!
interface FastEthernet0/1
 ip address 192.168.0.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface ATM0/3/0
 no ip address
 no ip mroute-cache
 atm restart timer 300
 no atm ilmi-keepalive
 pvc 0/32
  dialer pool-member 1
  protocol ppp dialer
 !
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 ppp chap hostname xxxxxxxxxx@qwest.net(Verified with ISP)
 ppp chap password 0 omitted(Verified with ISP)
 ppp pap sent-username xxxxxxxxxx@qwest.net password 0 omitted(Verified with ISP)
 ppp ipcp dns request accept
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
ip nat pool Home 192.168.0.1 192.168.0.1 netmask 255.255.255.0
ip nat inside source list 1 interface FastEthernet0/1 overload
ip nat inside source list NAT interface Dialer0 overload
!
ip access-list standard NAT
 permit 192.168.0.0 0.0.0.255
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
!
tftp-server flash:CP7912080003SCCP070409A.sbin
!
control-plane
!
!

 

I tried to ping google via IP from the router to eliminate as many variables as possible but no luck


Local#ping 64.233.185.106

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 64.233.185.106, timeout is 2 seconds:
.....

6 REPLIES 6
cheveret
Beginner

Hello,

 

Have you tried ppp authentication?

Update your dialer config as follows:

interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1

 dialer-group 1

 ppp authentication chap pap callin
 ppp chap hostname xxxxxxxxxx@qwest.net(Verified with ISP)
 ppp chap password 0 omitted(Verified with ISP)
 ppp pap sent-username xxxxxxxxxx@qwest.net password 0 omitted(Verified with ISP)
 ppp ipcp dns request accept

 

Hope that helps.

No luck, still don't make it far w/ authentication

 

Local#sho run | beg interface Dialer0
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxxxx@qwest.net
 ppp chap password 0 xxxxxxxx
 ppp pap sent-username xxxxxxx@qwest.net password 0 xxxxxxxx
 ppp ipcp dns request accept

 

Oct  8 13:36:51.113: Vi2 LCP: Timeout: State Listen
Oct  8 13:36:51.113: Vi2 PPP: Authorization required
Oct  8 13:36:51.113: Vi2 PPP: No remote authentication for call-out
Oct  8 13:36:51.113: Vi2 LCP: O CONFREQ [Listen] id 101 len 10
Oct  8 13:36:51.113: Vi2 LCP:    MagicNumber 0x1EF982D3 (0x05061EF982D3)
Oct  8 13:36:53.129: Vi2 LCP: Timeout: State REQsent
Oct  8 13:36:53.129: Vi2 LCP: O CONFREQ [REQsent] id 102 len 10
Oct  8 13:36:53.129: Vi2 LCP:    MagicNumber 0x1EF982D3 (0x05061EF982D3)

Oct  8 13:36:55.145: Vi2 LCP: Timeout: State REQsent
Oct  8 13:36:55.145: Vi2 LCP: O CONFREQ [REQsent] id 103 len 10
Oct  8 13:36:55.145: Vi2 LCP:    MagicNumber 0x1EF982D3 (0x05061EF982D3)
Oct  8 13:36:57.161: Vi2 LCP: Timeout: State REQsent
Oct  8 13:36:57.161: Vi2 LCP: O CONFREQ [REQsent] id 104 len 10
Oct  8 13:36:57.161: Vi2 LCP:    MagicNumber 0x1EF982D3 (0x05061EF982D3)
Oct  8 13:36:59.177: Vi2 LCP: Timeout: State REQsent
Oct  8 13:36:59.177: Vi2 LCP: O CONFREQ [REQsent] id 105 len 10
Oct  8 13:36:59.177: Vi2 LCP:    MagicNumber 0x1EF982D3 (0x05061EF982D3)

Under the "Ports" tab try setting the PPPoE WAN port to 100M full.

 

I'm not sure which tab you are referring to. I'm trying to migrate off the PK5001Z to a 2801 with an HWIC-1ADSL though. IOS 12.4(24)T8 (HWIC is compatible with this)

I think I found the problem, I'm not received anything from the ISP, I should have an I at some point to show that the ISP is attempting to authenticate. I'm not quite sure what is causing this though.

The ISP is using PPPoE. I know PPPoE can work over ATM, but I'm thinking something isn't set up right for pppoe

Local(config-if)#no shut
Local(config-if)#
Oct 13 05:05:44.339: %LINK-3-UPDOWN: Interface ATM0/3/0, changed state to down
Local(config-if)#
Oct 13 05:06:19.219: %LINK-3-UPDOWN: Interface ATM0/3/0, changed state to up
Oct 13 05:06:20.219: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/3/0, changed state to up
Local(config-if)#
Oct 13 05:06:27.127: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
Oct 13 05:06:27.127: %DIALER-6-BIND: Interface Vi2 bound to profile Di0
Local(config-if)#
Oct 13 05:06:27.131: Vi2 PPP: Using dialer call direction
Oct 13 05:06:27.131: Vi2 PPP: Treating connection as a callout
Oct 13 05:06:27.131: Vi2 PPP: Session handle[35000009] Session id[6]
Oct 13 05:06:27.131: Vi2 PPP: Phase is ESTABLISHING, Active Open
Oct 13 05:06:27.131: Vi2 PPP: Authorization required
Oct 13 05:06:27.131: Vi2 LCP: O CONFREQ [Closed] id 58 len 15
Oct 13 05:06:27.131: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:27.131: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:29.111: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:29.111: Vi2 LCP: O CONFREQ [REQsent] id 59 len 15
Oct 13 05:06:29.111: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:29.111: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:31.127: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:31.127: Vi2 LCP: O CONFREQ [REQsent] id 60 len 15
Oct 13 05:06:31.127: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:31.127: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:33.143: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:33.143: Vi2 LCP: O CONFREQ [REQsent] id 61 len 15
Oct 13 05:06:33.143: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:33.143: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:35.159: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:35.159: Vi2 LCP: O CONFREQ [REQsent] id 62 len 15
Oct 13 05:06:35.159: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:35.159: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:37.175: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:37.175: Vi2 LCP: O CONFREQ [REQsent] id 63 len 15
Oct 13 05:06:37.175: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:37.175: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:39.191: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:39.191: Vi2 LCP: O CONFREQ [REQsent] id 64 len 15
Oct 13 05:06:39.191: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:39.191: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:41.207: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:41.207: Vi2 LCP: O CONFREQ [REQsent] id 65 len 15
Oct 13 05:06:41.207: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:41.207: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:43.223: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:43.223: Vi2 LCP: O CONFREQ [REQsent] id 66 len 15
Oct 13 05:06:43.223: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:43.223: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:45.239: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:45.239: Vi2 LCP: O CONFREQ [REQsent] id 67 len 15
Oct 13 05:06:45.239: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
Oct 13 05:06:45.239: Vi2 LCP:    MagicNumber 0x1D59A9D9 (0x05061D59A9D9)
Local(config-if)#
Oct 13 05:06:47.255: Vi2 LCP: Timeout: State REQsent
Oct 13 05:06:47.255: Vi2 LCP: State is Listen

Should have been more explicit.

Click

Port Management 

 

then click sub menu 

Port Setup

 

You can change the WAN port from auto to 100Mbps FULL

 

It's Cisco IOS. There's nothing to click

 

This will be replacing the PK5001Z, not hanging directly behind it.