cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

2162
Views
11
Helpful
6
Replies
Highlighted
Beginner

PPTP RV220W Firmware 1.0.4.17 NEED HELP !!!

Hi,

I've been trying for a long time to configure the VPN pptp on the RV220w but ultimately I do not succeed.

I think that my problem is at the vlan configuration for the PPTP, cause in the PPTP configuration I cannot set the same subnet as the LAN. So the pptp connexion works but I dont have acces to any of my Lan server ??? I enable inter vlan Routing in the vlan membership default configuration, but doesnt change nothing. I'm completly lost and dont know what to do next. It is a simple config but not able to make it work. Whant can I do next ?

Thanks for your help !

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

I have noticed the same thing with my rv220w

Example:

Vlan1 is 192.168.1.0

Vlan2 is 192.168.2.0

When i set the pptp scoop range to 192.168.2.0 i can save the setting.

I then create an Vlan2 and set it to 192.168.2.0 and enable inter vlan routing.

I can connect to the pptp server from outside but i can NOT ping anything on my other networks.

If i go back now to the pptp server settings im unable to save any settings. Getting an error that the pptp server can't be on the Vlan2 192.168.2.0 range. An check is made if the new ip range is used in any vlan. If it's not it will be allowed to save. But after associating the pptp scoop with an vlan you are unable to go back and make changes to the pptp server since now there is an vlan in that range, well ofc it is i wanted it to be lol...

Here is how i cheated the bultin check and made it work.

Since i want the pptp server to be on my 192.168.1.0 network, but unable to save the changes when doing the config in the pptp server option i did the following.

Change my vlan1 or normal network range if you like to 192.168.100.0 reboot router and login again.

Now goto the pptp server settings and change the range to 192.168.1.0 and save. reboot router.

Go back to network settings and set normal ip range back to 192.168.1.0. You will now most likely lose network connection to the router. Set a fixed ip adress on your pc to 192.168.1.0 range. Login on your router and reboot it, or pull the power, an restart is needed.

When it comes back up you can connect to your pptp server that are in the 192.168.1.0 range. Note that you will not be able to do any changes after in the pptp server since then the fw will do the check and complain that you need to change the range again, and you have to redo all the steps all over again.

I hope they will fix this bugg in upcoming firmware. I have noticed alot more having this and not been able to solve it.

Hope this temporary fix will help you.

BR

View solution in original post

6 REPLIES 6
Highlighted
Advocate

Hi Richard, try to adjust the pptp IP scope to be a member of one of the VLANs.

Example:

Vlan 1 = 192.168.1.1

Vlan 2 = 192.168.2.1

Vlan 3 = 192.168.3.1

Set the PPTP to be 192.168.3.200~211

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted
Beginner

I have noticed the same thing with my rv220w

Example:

Vlan1 is 192.168.1.0

Vlan2 is 192.168.2.0

When i set the pptp scoop range to 192.168.2.0 i can save the setting.

I then create an Vlan2 and set it to 192.168.2.0 and enable inter vlan routing.

I can connect to the pptp server from outside but i can NOT ping anything on my other networks.

If i go back now to the pptp server settings im unable to save any settings. Getting an error that the pptp server can't be on the Vlan2 192.168.2.0 range. An check is made if the new ip range is used in any vlan. If it's not it will be allowed to save. But after associating the pptp scoop with an vlan you are unable to go back and make changes to the pptp server since now there is an vlan in that range, well ofc it is i wanted it to be lol...

Here is how i cheated the bultin check and made it work.

Since i want the pptp server to be on my 192.168.1.0 network, but unable to save the changes when doing the config in the pptp server option i did the following.

Change my vlan1 or normal network range if you like to 192.168.100.0 reboot router and login again.

Now goto the pptp server settings and change the range to 192.168.1.0 and save. reboot router.

Go back to network settings and set normal ip range back to 192.168.1.0. You will now most likely lose network connection to the router. Set a fixed ip adress on your pc to 192.168.1.0 range. Login on your router and reboot it, or pull the power, an restart is needed.

When it comes back up you can connect to your pptp server that are in the 192.168.1.0 range. Note that you will not be able to do any changes after in the pptp server since then the fw will do the check and complain that you need to change the range again, and you have to redo all the steps all over again.

I hope they will fix this bugg in upcoming firmware. I have noticed alot more having this and not been able to solve it.

Hope this temporary fix will help you.

BR

View solution in original post

Highlighted

Thx onlyalex1984, will try this tonight .

Highlighted

When i try to change the PPTP subnet after changing my vlan1 to something different I got this error message:

1. I have change my vlan1 from 192.168.30.1 to 192.168.30.1 - reboot

2. Try to change my VPN subnet to 192.168.25.1 and got this error message ???

thanks !!

Highlighted

I have diseable all my port fowarding and DMZ and all other settings and It work great. Thanks you so much

onlyalex1984 !!!

Highlighted

I have the same error on PPTP RV220W Firmware 1.0.4.17. But I haven't use the vlan setting. Just sample setting to

use the PPTP and QVPN funcation.

PPTP connected

I can't connect by PPTP but the MSN fucation disable and can't go to us.yahoo.com , uk.yahoo.com ??

When I disable the PPTP at win7. Everything go back normal.

QVPN funcation

MSN fucation is OK. But can't see the web site have adobe Flash. I have download the Adobe Flash player.

After disable the QVPN go to same web site. We can see !

I try to downgrade to 1.0.3.5 to testing again. Any news will update on here