cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
672
Views
0
Helpful
11
Replies

Router connected back to back

sachac
Beginner
Beginner

Hi Guy's

 

Is it possible to connect to routers back to back,

R1 has physical interface with ip address.

R2 has a subinterface configured with IP address

I can not ping the IP of R2 from R1, if I move the ip to the physical interface on R2 I can ping both ways.

How can I configure this to work with R2 having the IP on the subinterface.

 

Regards

11 REPLIES 11

fmarshall
Beginner
Beginner

It would be good to have more information and description.  I might ask similar questions as an example:

Can you connect Cisco Small Business routers LAN to LAN? (In Router mode?  In Gateway mode?)

Can you connect Cisco Small Business routers WAN to LAN? (In Router mode?  In Gateway mode?)

Can you connect Cisco Small Business routers WAN to WAN? (In Router mode?  In Gateway mode?)

 

I think the answer is: Yes for most of these cases.

 

"I can not ping the IP of R2 from R1, if I move the ip to the physical interface on R2 I can ping both ways."

 

Since each router has at least 2 IP addresses, at least one on the LAN (and might have more if there are VLANs) and one on each WAN (as there are dual-WAN routers) then knowing which ones you're referring to would be helpful.

When you say "move the ip to the physical interface" I get rather confused about where ELSE would it be present/observable?

And, you mention a "subinterface" which has no meaning for me .... ?

Generally, unless an interface is waiting for an address via DHCP, it will have an IP addrress (static) and can be pinged.

UNLESS it's on the WAN interface and ICMP traffic is being blocked by the firewall.

 

Too many variables and unknowns to comment further I'd say.  But I'll stand by for more info.


Hi,

Thank you for your feedback, please see config below.
In reference to moving the ip I mean removing it from the subinterface and
adding it to gig1/0, there are no Firewalls between the two routers, no
switches it is a straight L3 point to point link.

R1>>>>>>R2

R1
!
interface GigabitEthernet0/1
description WAN link to R2
ip address 10.130.0.90 255.255.255.252
duplex auto
speed auto
no shut
!

R2
!
interface GigabitEthernet1/0
no ip address
no shut
!
interface GigabitEthernet1/0.3190
description WAN link to R1
ip address 10.130.0.90 255.255.255.252
duplex auto
speed auto
no shut
!

Kind Regards
Sacha

as per the config, there is a duplicate IP, charge as below it should work. ( sub-interface you need to use encapsulated with VLAN correctly)

 

 

R1
!
interface GigabitEthernet0/1
description WAN link to R2
ip address 10.130.0.89 255.255.255.252
duplex auto
speed auto
no shut
!

R2
!
interface GigabitEthernet1/0
no ip address
no shut
!
interface GigabitEthernet1/0.3190
description WAN link to R1
ip address 10.130.0.90 255.255.255.252
duplex auto
speed auto
no shut
!

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi,

Thank you for your reply, my appologies I copied and paste the config and
did not change the IP to 89 on R2 before sending.
The interface IP's are correct see below, L2 is up, and I have added encap
dot1Q "tried with and without native statement" to the interface on R2 (not
sure why though as R1 is not tagging packets).
In my original post I did say if I remove the IP from the subinterface and
add it to R2 interface Gig1/0 I am able to ping.
Currenlty IP routing is configred however I have not setup any routing
protocols as you can see from the global routing table.


R1
!
interface Gig0/1
description WAN link to R2
ip address 10.130.0.90 255.255.255.252
duplex auto
speed auto
no shut
!

R2
!
interface Gig1/0
no ip address
no shut
!
interface Gig1/0.3190
description WAN link to R1
encapsulation dot1Q 3190
ip address 10.130.0.89 255.255.255.252
duplex auto
speed auto
no shut
!

R2
R2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
R1 Gig 1/0 164 R B Linux Uni Gig 0/1

Total cdp entries displayed : 1
!

R2
R2#ping 10.130.0.90
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.130.0.90, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
!

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.130.0.88/30 is directly connected, GigabitEthernet1/0.3190
L 10.130.0.89/32 is directly connected, GigabitEthernet1/0.3190
!

R2
See below sucessfull pings after I removed the IP from the subinterface and
added it to the physical GigabitEthernet1/0 how can I get this working on
the subinterface configuration?

R2#ping 10.130.0.90
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.130.0.90, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/6 ms

Regards
SachaC

I have only correct the subnet and suggested dot1q config should be the same both the side.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

fmarshall
Beginner
Beginner

I may well not be the right person to address your question.  I don't generally edit configuration files.

What are the router models?

Martin L
VIP Advisor VIP Advisor
VIP Advisor

 

Subinterfaces on router should be used when you connect to a switch in order to do Router-on-a-stick method of routing vlan traffic (aka ROAS).  Using encapsulation dot1Q on one side and no encapsulation at all on the other is the reason why this does not work.  you could try to use encapsulation dot1Q on both routers just to see if that works; it should.  Otherwise, if R2 (one with subinterfaces) connects to switch who is trunking (over a trunk line), it will work fine.

 

Regards, ML
**Please Rate All Helpful Responses **

Hi All

Thank you for the feedback,
Eventually I created a subinterface on R1 to match R2 subinterface with
encapsulation and I can ping now, this did I did know, was just hopeful I
could get it working in a physical to subinterface arrangement.
Having said that, that was not the configuration I would have liked to have
and will see if I can work with that, to all who participated in this a
big THANK YOU!

Note i did google this type of configuration before asking the form however
that turned out nothing. Yes a ROAS config will work, and here again I do
not want a switch between the two Routers. If anyone can think of another
way to get it working please still do let me know...
R1(Gig0/1) to R2 (1/0.3190) layer 3

Regards
SachaC

 

in your case, another solution is just to add "native" keyword to encapsulation dot1Q 3190 while other end does not have sub-interface / nor uses encapsulation.  this should work because "native" in dot1q means no encap or no tag (no tagging traffic).

try it and  let us know

 

Regards, ML
**Please Rate All Helpful Responses **

 

 

 

here is config example: match both routers but change last octet of IP of course;

 

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.13.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.130.1 255.255.255.0

!

R1#sh ip ei ne
IP-EIGRP neighbors for process 1
....
1 192.168.130.3 Fa0/0.20  14  00:00:37  98    588  0 17
0 192.168.13.3   Fa0/0.10  14  00:07:46  694 4164 0 15
R1#

Martin L
VIP Advisor VIP Advisor
VIP Advisor

 

Here is mix of working sub- and no sub-interface config for back to back router setup

 

R1#
!
interface FastEthernet0/0
ip address 192.168.13.1 255.255.255.0
!

interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.130.1 255.255.255.0

 

Router 3 on the other side has 2 sub-intefaces

!

interface FastEthernet0/0.10
encapsulation dot1Q 10 native
ip address 192.168.13.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.130.1 255.255.255.0

!

Result is ok,

R3#p 192.168.13.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/52 ms
R3#p 192.168.130.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.130.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/27/56 ms
R3#

 

both routers have EIGRP UP over 2 interfaces

 

R1#sh ip ei ne
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.13.3 Fa0/0 12 00:05:58 72 432 0 33
1 192.168.130.3 Fa0/0.20 11 00:20:30 101 606 0 34
R1#

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: