cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1992
Views
5
Helpful
7
Replies
Highlighted
Beginner

RV016 v1 Firmware v 1.3.2 upgrade to v2.0.0

Hi, I am trying to upgrade my RV016 hardware version 1, Firmware version 1.3.2 to firmware version 2.0.0. but can't find the file. Can someone help me with locating RV016_2.0.0? I am trying to upgrade to version 3.0.0.1

thanks

7 REPLIES 7
Highlighted
Enthusiast

Hello,

I have looked over the release notes and they don't mention having to upgrade to version 2 before going to version 3.

Have you tried to upgrade directly to version  3.0.0.19-tm?  That is the newest version that will work on the v1 hardware.

You can download this at:

http://software.cisco.com/portal/pub/download/portal/select.html?&mdfid=282413305&catid=268437899&softwareid=282465789

Just make sure you grab 3.0.0.19-tm, the later versions only work on v2 and v3 hardware.

Please rate helpful posts.

Christopher Ebert

Network Support Engineer - Cisco Small Business Support Center

Highlighted

Thanks for the help Christopher, I have try upgrading from 3.0.0.19 before and again after your post and I got this error message from the upgrade

"Bad upgrade file !  Please input a correct file !"

Here are what some people are saying on google. Copy and paste from word file.

YOU MUST UPGRADE TO FIRMWARE 2.0.0 FIRST!

Once you have upgraded to firmware 2.0.0 you can then upgrade to 2.0.3

Upgrade RV016 firmware from v1.3.2 to v2.0.0    

IMPORTANT: Backup your router configuration before performing this upgrade      .          

Purpose:

This document describes the procedures to upgrade RV016 firmware from v1.3.2 to v2.0.0. The difference between firmware v1.x.x and v2.0.x is that v2.0.x uses a larger flash layout and a newer OS structure. Unlike normal firmware upgrades which upload the system image only, this upgrade uploads both the system image and the boot-loader image. These two images are included in the executable file RV16_2.0.0.exe.

Notice!! After upgrading, it will turn to factory default. If you need the configuration, please export the configuration file before upgrade firmware.

Highlighted

Ah, I saw a few posts like that too, but nothing specific about versions earlier than 2.0.0.  Because the 3.0.0.19 release notes don't mention anything about what version you need to have before the upgrade, and they are usually pretty good about that.

After quite a bit of searching, I found a website where you can grab the 2.0.3, and from there move on up to 3.0.0.19.

http://download.modem-help.co.uk/mfcs-L/LinkSys/RV016/Firmware/

I downloaded these files myself and scanned them, no threats, and the website seems legitimate, but of course I can't make any guarantees.

The 2.0.3 file has instructions on how to do the upgrade, as well as an executable to go up to 2.0.0.  The Read Me included has some very good instructions.

The latest firmware for your hardware version will be 3.0.0.19-tm, which is missing from the modem-help website but you can grab that one directly from Cisco here:

http://software.cisco.com/portal/pub/download/portal/select.html?&mdfid=282413305&catid=268437899&softwareid=282465789

Let me know how it goes,

Christopher Ebert

Network Support Engineer - Cisco Small Business Support Center

Please rate helpful answers.

Highlighted

Thanks for your help Christopher. That work perfecty.

Highlighted

Does anyone know where to find v2.0.0 i have been looking all over.

Highlighted
Contributor

Thank you for posting this link.  My v1 rv016 didn't like the v3 firmware AT ALL.  And then it wouldn't let me switch back to 2.0.6.  Somehow 2.0.6 'disappeared' after I selected it upon rebooting.  Hopefully this will at least get this working again.  Right now it just reboots and is useless.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com
Highlighted

I ran across this thread when searching for the site-to-site IPsec VPN spec for the v1 rv016 hardware, so I thought I'd update.

It took some effort from what recall--mainly endless rebooting before 3.0.0.19-tm was stable on my v1 hardware.  I still need to reboot it every day (as I do for all our rv016s), but it did end up working and retaining the settings.  And it's been in service 2 years now.  And this after being in service for over 5 years before at another site.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com