Showing results for 
Search instead for 
Did you mean: 

RV042 Can't disable DMZ Host


While trying to configure my RV042, I "turned on" the DMZ Host functionality (under Setup > DMZ Host) by entering the LAN IP address of one of our machines. I now believe that I don't actually want this on. According to the Help page (and also the manual) it says:

"Enter the IP address of the network device that you want to use as a DMZ host. Alternatively, enter zero ( to disable the DMZ Host."

So I try to enter as the address, and it give me an error:


What am I doing wrong? Are the instructions just incorrect? Is there a way to turn this off?

1 Accepted Solution

Accepted Solutions

Te-Kai Liu
Rising star
Rising star

If the LAN subnet is 192.168.1.x/24, you might want to try instead of to disable DMZ Host.

View solution in original post

7 Replies 7

Te-Kai Liu
Rising star
Rising star

If the LAN subnet is 192.168.1.x/24, you might want to try instead of to disable DMZ Host.

It accepted my entry of (our subnet is 10.4.20.x). Does this mean that the DMZ Host is now disabled? If this is indeed the correct procedure, may I request a future correction in the Help file and user manual to reflect this? Thanks.

If you could confirm that indeed disables DMZ Host, I could pass it onto the product team to update the help page.

Unfortunitly I'm not sure how to confirm if DMZ Host is disabled. I mistakenly enabled it when trying to get the DMZ working, and (in a different discussion) you informed me that I didn't need to have it enabled. So I was trying to disable it, but was running into the above error. If you can tell me how to test if it's disabled I'd be happy to.

No worry, Brad. I will let the product team know.


Please log in to the RV042 and choose Setup > Network. Scroll down to the DMZ Setting and uncheck Enable DMZ to disable the DMZ .

Thank You.


There *should* be a "disable DMZ" tick box, but since Cisco seems to have hired a monkey to put this firmware together in a short day on Christmas Eve, there is not (actually, kudos for the last update that fixed myriad critical problems), the most certain way to "disable" DMZ is to enable DMZ and point it at a nonexistent internal IP address (or even better, a honeypot, so you can log attempted attacks!  ;-)

This could be a problem if you do not maintain control of your internal IPs--e.g. if you let DHCP dole them out willy nilly.  You can remedy this, assuming your DHCP server is your RV042, and not some other DHCP server:  Set up manual IP tables for RV042's DHCP server at


look down to

DNS Local Database


hostname = --I suggest "honeypot"

IP Address =


That should kill access to any random machine on your LAN from the Internet.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers