Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV042 - Cannot Connect to a BT Home Hub Router - IT Burnout ! HELP !!


I an suffering from what I call 'IT Burnout'. After days of googling forums, reading manuals, working past midnight, and trying and retrying various connections I cannot a RV042 router to access the internet for more than a few seconds.

A) The router is a v1.2 with firmware version   B) The modem is a standard BT (British Telecom) Home Hub modem C) The connection is a standard residential internet connection (without a public IP)

Planned Scenario: The RV042 is to be attached to the BT modem with a Dell T20 server which is to be connected via ethernet to the RV042 to be used for a home office for a small team.

What works:

1 The Internet works- I have connected to the BT modem both via wireless and directly via ethernet cable (Ubuntu server and Win 7 OSes). Works perfectly.

2 The RV042 - I can access the web management by connecting a laptop via ethernet and also can change settings. If I connect additional servers (Ubuntu Server OS) via ethernet, it recognizes them and the RV042 assigns them an IP number 192.168.1.x within the range -149

3 A bog standard DD WRT router I have lying around works with no problems

What Doesn't Work

The RV042 is connected via ethernet cable to the BT router (the same scenario  works if I use other devices connected directly) yet there is no internet to any of the devices connected to the RV042 (Ubuntu Server or Win 7 laptop) via ethernet. That's the problem. I have tried and tried and I just can't get the internet to work. In other words, the modem is connected to the RV042 but anything connected to the RV042 has no internet. Once or twice it appeared for some 40 seconds then it stopped. When I say 'work' I mean that the Local Area Connection on the laptop showed 'internet' and I could browse webpages.

What I Have Tried

1 Opened the firewall completely on both the RV042 and the modem

2 Changed the MAC address of the RV042 in case the ISP was blocking it, rebooted and restarted etc.

3 Upgraded the firmware to 

4 Placed the connected laptop into the DMZ and the RV042 into the DMZ of the BT modem ...nothing

5 Various changes on the web management - load balancing, protocol binding, NAT on and off (with settings), manual MTU to 1500 (and other numbers), releasing and renewing the WAN1 connection to the router, switching off the firewall on the RV042 completely (and the modem), changing the mode to router from gateway, switching off DNS server on the RV042 (this stopped it from working, the BT modem has DNS but I set the range at a lower amount to avoid conflict).  I usually hard reset the RV042 if something does not work and try again from scratch after running the basic set up wizard.

6 The RV042 is set to 'obtain IP automatically'

7 On the BT modem - deleting the device from the home network and refreshing, restarting, opening the firewall, forwarding all ports to it.

8 New cables, re-seating cables.


I honestly, can't think of what I could be doing wrong. It could be something to do with networking, maybe the fact that there is no public IP address (which I can always ask the ISP to give) as it is set to obtain the IP automatically.

The BT modem has information like this

Broadband network IP address:
Default gateway: 
Primary DNS: 31.55.187.xx  
Secondary DNS:

The modem has the IP and the RV042 (the default one). Interestingly, the modem assigns the RV042 the IP of (I don't know if this is important or how it is.)

Maybe this is something to do with it?  Or is it something else? Maybe a hardware problem?

In advance guys...I would be truly grateful for any help. I am sure many of you have been where I am ...not sleeping and burn out etc. Help.




If you have the BT Home Hub giving you a 192.168.1.x address from it's internal interface, and you have the RV042 also using 192.168.1.x addresses for it's own internal addresses, that's your problem - the RV042 ends up having the same address range on both LAN and WAN interfaces which won't work. You'll need to change the LAN IP settings on the RV042 to a different address range, such as 192.168.2.x (so change it's interface to, and the DHCP on it to That way you have a different network on each interface and the RV042 will then route between them.


Alternatively you can change the LAN network address setup on the BT Home Hub, just make sure it's not conflicting with the 192.168.1.x range that the RV042 will be using on it's LAN interface.



Finally solved it,


Thank you for your help by the way. I appreciate it.  I did try what you stated some time in the past. I tried so many things I just couldn't write up the whole list. It didn't work.

What solved the problem was reinstalling the older firmware i.e. . I reset and restarted and it worked ! Same settings as the newer firmware but it recognized the internet connection (as it should have).

I read that the firmware could be buggy. After so long trying different settings, and researching solutions I have finally got there.


Thank you again for your post.