Showing results for 
Search instead for 
Did you mean: 

Get the latest Cisco news in this February issue of the Cisco Small Business Monthly Newsletter


RV042 - port triggering not working?

RV042 Firmware Version:

I've configured my chat application, Trillian, to receive incoming files within a port range of 26500-26599.   Since I use port 5190 (ICQ) to connect to the chat server, I set my trigger port range from 5190 to 5190.  I set my incoming ports to 26500-26599.  I've had several routers over the years and I've configured each of them identically as I have with the RV042, but it's not working with the RV042.

When I examined the firewall log, it shows up as "Connection Refused - Policy violation" and shows the port that's supposed to be triggered open.  I even tried to disable the firewall setting, but that didn't help.

I can open the ports 26500-26599 explicitly, and that works, but it limits me to using only 1 machine.  Again, I've done this configuration a few times before on other routers, including Linksys brand, but I've never run into this problem.

I would be curious to see if anyone successfully uses port triggering as I feel it might be a firmware issue.  Any insights would be helpful.


Everyone's tags (2)

Re: RV042 - port triggering not working?


Have you tried rolling the firmware back to see if that resolves the issue? If it is an issue with the new firmware, then rolling back should fix it.

Please post your results.



Re: RV042 - port triggering not working?


Thanks for the reply.  I grabbed the only other firmware I could find (RV042-v1.3.12.6tm-080527_fw.rmt) and gave it a shot.  I reset to factory default, setup the trigger rule again, and reset the device and that didn't work.

Here is what I know:

I can see that port 5190, my trigger port, is established using netstat.  Netstat also confirms that port 26500 (input range configured by Trillian) is open (listening).  I know that my trigger port rule has a trigger port range of 5190 to 5190 and the incoming port range of 26500 to 26599 (as defined by Trillian).  When "Deny policies" is on in the general system log, I can see the IP of the person sending me a file to the port of 26500 and it being rejected.  This entry appears in the "firewall log" of the system log drop down.  I disabled the firewall setting of the router and it has no effect.   I can open the ports 26500-26599 explicity to make it work.  Finally, I've created this same rule on at least 3 other routers in the past and had it work flawlessly.

Again, any insight would be helpful.

Thanks so much for your time,

Frequent Contributor

Re: RV042 - port triggering not working?

There really is no other test or work around for this.  I would call the SBSC at 866-606-1866 and open a case and if they can't resolve it.  Maybe escalate the case to the design team.  Other than that since you have tried different firmware upgrades and still same result, I would do that.