cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

RV042 Random Reset

david_in_memphis
Beginner
Beginner

Today we came in and our RV042 (v 3) had cleared it's configuration and gone back to default settings. Of course, it was a huge inconvenience, and has made me apprehensive about putting the unit back in place, even though I was able to configure the unit again.

Has a bug been reported or has anyone else had this issue?

One other thing: my unit - which was only recently purchased and put into service - had a firmware date of Apr of 2013. I upgraded it to the most recent version 4.2.3.03 (Apr 2014), but couldn't see anything in the release notes related to this issue.

Please help me resolve this ASAP.

31 REPLIES 31

Wow, quite strange.  I've had this happen to me on one of my rv016s before.  I'd find an older version of firmware and see if that's more stable. 

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Hi bgorigingroup,

Ditto here.

cchamorr,

This is not an unusual problem (and there are several posts about this issue - not to mention the several times I have called regarding this problem).

I have heard all the "fixes".  
- Use a UPS (already standard SOP for us)
- Set up a snmp trap server to capture the details (how am I going to do that with the limited resources I have at over 20 small locations (2-5 computers) when I do not know what is going to fail when or what location.
- Reflash the firmware (been there and done that)

How about just fixing the issue?  Can you please fix the SSL issues at the same time?

Here it is the weekend and I have 3 of these units reset (after about 2+ months of no problem).  So now I lose my weekend (and have 4 hours or driving) for some stupid issue that Cisco could resolve.  At least for my customers sake it is not during their production hours.

My guess is that I am going to have to schedule router reboots about 1 time per month to see if this prevents this until we get them all replaced.

Cannot believe so many are dealing with this issue.... so much for Cisco quality.  I totally understand that hardware and firmware have issues, etc.  Unfortunately, I would also have assumed that Cisco would have been all over this issue and resolved it with the resources they have.  I have totally lost my confidence in all Cisco Small Business Gear.  The last straw has broken... I am cracking open a new manufacturer purchasing guide this weekend.

I've had this problem repeatedly on 3 different RC042's in the last 6 months.  1 at our site and 2 at customer sites.  2 are all at  v4.2.3.08, 1 I left a version back to see if the problems persisted.

The router will fall back to factory settings after about 2 months at our location.  They other 2 locations 1 will just stop working completely and need power cycled, the other site will just get gradually slower and slower internet connection and then need power cycled.

All 3 are on battery backup.

Our location hosts a remote backup service, so it is busy 24/7 with a lot of TLS connections passing through.

1 other site is just regular mix of traffic, no VPN's.  The 3rd site is a doctor's office with about a dozen machines using software VPN connections to their hosted service.

I'm not sure if the detail helps, but I've seen hardware get flooded with specific types of traffic before and would cause issues on the ports due to software issue.

I'm really happy with the RV320, I have several of those in service and have no issues.  Mabye I need to dump the RV042's altogether.  The logs are always cleared by the time they come back up.  I had a very old RV082 that I ran for almost 10years and never had a problem until I compared it's thoughput to a new device so I upgraded to the RV042.  It seems odd that a solution can't be figured out if so many are having the same issue.

Honestly, if the problems only started with a firmware update, obviously something in the firmware is broken.  I would just revert back to the working configuration.  But if that's not enough, then I think it is time to look at upgrading to the rv320, especially if you've had good experience with them.  My old rv042 bit the dust when the capacitors in it died, and the speeds degraded until it finally quit.  It also made some whistling sounds in its last few years of service.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Samir Darji
Contributor
Contributor

Whenever upgrading/downgrading any firmware on any brand smb class routers, factory default the unit, upgrade and then factory default again.  You will need to save screenshots of your configuration so you can rebuild it from scratch, but this keeps junk from being in the configuration written to the unit. 

Upgrading without doing this on almost any brand router will lead to unpredictable performance and problems.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

mavengroup
Beginner
Beginner

Hi David,

I just want to let you know that this is NOT an uncommon issue.  Unfortunate we have numerous (15+) RV042Gs in deployment at small satellite offices.  While they perform well, they often will randomly reset (and I have submitted numerous tickets to CISCO about the issue).  

Basically the issue has become so bad and we have had some many issues with such a lack of support that we have had to slow start to migrate to another small business router manufacturer.

I have found no solution or configuration to stop this from occurring (SSL on, SSL off, etc., etc.).  The other problem with the unit is the SSL fails penetration testing for PCI compliance.  I was hoping for a firmware update, but CISCO has given me no indication that one is coming.

This is sad as I really like the RV042g and its feature set/price, but without the reliability, that all is worthless.

Hope this helps you.

David Cordovez
Beginner
Beginner

"NO MORE SYSTEM"

Please, Cisco... Please pay attention to this problem.!!

In my case, two routers RV042G both with the same firmware (4.2.3.06). They have lost the settings twice in a month. (I tried to return to factory settings and reconfigure manually after the first fault , but just happened again).

For now , I'll try going back to the previous version (4.2.3.03)

My Others Routers RV0XX work perfectly !! (and some are very old!)

  • RV082 with Firmware v4.2.2.08  (3 Years of works)
  • RV082 with Firmware v4.0.0.07-tm  (5 Years of works)
  • Linksys RV042 Firmware Version: 1.3.13.02-tm ( 7 - 8 Years of works)
  • 2 Linksys RV042 Firmware Version: 1.3.12.19-tm (7 - 8 Years of works)
  • RV042G with  Firmware Version  v4.2.1.02 (2 Years of Works)
  • 2 Linksys RV042 Firmware Version: 1.3.12.6-tm  (7 - 8 Years of works)

https://supportforums.cisco.com/discussion/12705751/rv042-rv082-no-more-system#comment-10978226

Hello,

i tested my two rv042g with firmware v4.2.3.03 (Mar 19 2014), routers worked well for weeks ; until today still work and I had already forgotten the problem.

but today, after receiving the mail notification response to this thread , I remembered the problem and enter again my routers settings....

BAD surprise !! The words "not more system" was back in the configuration ; and I know that if any of the routers loses power for any reason, I'll have to configure them from again, and configure them would not be such a problem if both routers were not in different cities over 1000km away !.

Please cisco ! provide us some help or solution!

.... For now, whit no answer from Cisco... if says "no more system", then I say "no more Cisco" and i go for Mikrotik

HI David,

This product is now End Of Life.  This is a final firmware version available (.07 I believe) which may or may not fix your issue.  We have switched to a different manufacturer due to this reason and the router reaching end of life.

Hi everybody,

I´m having the same problem. We bought this device three weeks ago and I burned with the last firmware version (07). Does anyone know if it´s solved there or if cisco is working on this issue.  This is urgent and we ´ve to decide if we change it or could be repaired.

Thanks!

Hello,

I have in use the firmware v4.2.3.07 in one RV042G for a least 2 months, and until now without  problem. ;)

Great news David! thanks for your prompt response.

Regards,

Matias.

Unfortunately I can report that this problem still plagues this device, even with the latest firmware installed.  

I can also attest to the fact that the same issue happens with the Linksys line of business routers (LRT214 and LRT224) which I tested as a possible replacement (they are almost exactly the same as the RV042G).

I had over 40 (at first I thought I had only a bad lot of them, but have since had problems with them all) of these in production and am replacing them all as I simply got tired of fighting this issue (as I posted 3 months ago).

I see that the latest firmware listed (https://software.cisco.com/download/release.html?mdfid=284170426&softwareid=282465789&os=&release=4.2.3.07&relind=AVAILABLE&rellifecycle=&reltype=latest&i=!pp) is labeled as final... so I would see no reason in hoping that there would be any fix for this in the future.

I really liked this device for its simplicity of use and configurability.  Unfortunately, when the device is 2-6 hours away and resets itself, that makes for a bad day.  Simply could not rely on it.

Hope this helps. Good luck!

John

Gerry Rigney
Beginner
Beginner

Hi

Experiencing the same issue on a brand new RV042G, latest firmware.  Just wondering for anyone that reverted back to an old FW version did it stop the resets and if so what FW did you downgrade to?

Thanks

gR

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: