cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter

961
Views
0
Helpful
2
Replies
Beginner

RV042 V03 "Bricked"?

I have been upgrading all the RV042s that are in service to V03.  There were quite a few units purchased to do this and some existing V03 units that needed firmware upgrades - to get to 4.2.3.08.

Two of the "upgraded" RV042 V03 units ended up in a "bad place" and may as well be "bricked" for what I've been able to do with them.

I started by doing the 4.2.3.08 firmware upgrade.

These two devices are both in the same situation.  ( I regret that I'm not able to say what firmware they started with).

1) The DMZ Mode light is on all the time (green).

2) The DIAG light shows amber some of the time but is off most of the time.  If this is described as a "slow blink" then I'd have to say that it's VERY SLOW.

3) The units respond to the GUI login but the display thereafter only shows the menu on the left edge.  The menu items respond to a cursor by changing color but when clicked on do nothing.  Nothing shows on the rest of the window.  So doing anything with the GUI is impossible.

4) The TFTP recovery software (Windows .exe) will run but ends up with a big red message that says "TFTP FAIL".

5) The device can be pinged successfully.

I have tried 30/30/30/10 reset to no avail as well as variations of this.

What should I be trying next?

Everyone's tags (1)
2 REPLIES 2
Beginner

I still have the problem but

I still have the problem but here's an update:

It seems that the situation with the DIAG light and the DMZ Mode light has gone away on both units.  That is, they are both not lit now nor blinking.  That part looks normal.2017-03-01_9-02-41.jpg

When I log into the GUI, I've noticed that the "About" and other links on the top right of the page will work.  Selecting "About", I see that the firmware version is 4.0.0.07-tm.  That's the same as what the TFTP recovery program would load I do believe.  

I can also look at the page source.  I can see the things that should be showing on the page that are not showing.  It appears they are part of a Javascript construct.  Could this problem have to do with Javascript?  I've tried two laptops and multiple browsers but the result remains the same.  So I don't think it's the computer's problem.

What should I be trying next?

Highlighted
Beginner

Re: RV042 V03 "Bricked"?

Here's an update:

Trying to upgrade RV042 v03s from 4.2.3.07 to 4.2.3.08 using http from the GUI.

Some succeeded, some became unresponsive - so "brick-like".

 

Solution (from Cisco) that works:

Have TFTPD32 on your computer ready to go.

Also have the firmware file on your computer ready to go.

 

NEXT / GET THE ROUTER INTO RECOVERY MODE:

Put the router into "recovery mode" like this: 

- Turn the router off

- Press and hold the reset button and turn the router on

- Hold the reset button until the orange diag led is flashing (it flashes very slowly and the blinks are long)

-Assign a static IP address to your computer (192.168.1.x) where x<>1

- disable the computer's firewall

-Ping 192.168.1.1 to confirm that the router is alive and waiting.  Use the -t option.

 

NEXT: Transfer the firmware to the RV042 using TFTPD32: 

TFTPD32.png

- From the Host pulldown, select the IP address of your computer on server interfaces.  It might be 127.0.0.1 or it might be 192.168.1.x from above.

-Enter port 69

-For the local file, select the firmware file

-Click on Put

The firmware upload will proceed.

 

NEXT: Complete the process.

At this point I was told that the router would restart itself.  Either I didn't wait long enough (and believe me I waited!) or it doesn't actually do that.  Does anyone know if it does and how long it should take?

Otherwise, I power cycled it after quite a while and all was fine.

 

I did this on one unit and it retained its configuration - unlike the 30/30/30/10 process which resets everything.