cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2395
Views
12
Helpful
4
Replies
ACadmalmere
Beginner

RV042 VPN Timeout Problem

Hi,

I have trouble to remove the timeout created by the RV042 VPN Router.

If I configure the Cisco VPN, the timeout occur every 30min.

If I configure SBS 2003 VPN, the timeout occur every 30min.

I have enabled/disabled the following:

1. PING on WAN enabled

2. SPI disabled

I have upgraded the Firmware to the latest version.

The exact problem:

VPN connection doesn't drop, only the communication with the external network.

This happens only when the VPN is idle for 30min.

When I adjusted the Cisco TCP Timeout from 30min. to 3 or 8 hours, the connection with the external network will drop after 18min. of idle time.

If I change it back to the default of 30min. the connection will drop after 30min. of idle time.

Question:

How can I make sure that the connection with the external network will be active for at least 3 hours?

I know I can setup a Batchscript with a ping, for keeping the connection alive, but I don't want to use workarounds.

1 ACCEPTED SOLUTION

Accepted Solutions
jonatrod
Rising star

Good morning.

Thanks for using our forum.

Hi Jan my name is Johnnatan and I am part of the Small business Support community.

You can try a factory reset in order to resolve you problem (always make a backup of you r configuration), and restart you VPN configuration, if the problem persists, check your MTU packets size (recomended 1500). You can also Go configure your VPN tunnel and disable the “perfect forward secrecy ” and enable “Keep-Alive”, you can do this in the step 12th and 13th of the following document.

http://www6.nohold.net/CiscoSB/Loginr.aspx?login=1&pid=4&app=search&vw=1&articleid=3294

I hope you find this answer useful, if it was satisfactory  for you, please mark the question as Answered.

Please rate post you consider useful.

Greetings,

Johnnatan Rodriguez Miranda.

Cisco network support engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

View solution in original post

4 REPLIES 4
jonatrod
Rising star

Good morning.

Thanks for using our forum.

Hi Jan my name is Johnnatan and I am part of the Small business Support community.

You can try a factory reset in order to resolve you problem (always make a backup of you r configuration), and restart you VPN configuration, if the problem persists, check your MTU packets size (recomended 1500). You can also Go configure your VPN tunnel and disable the “perfect forward secrecy ” and enable “Keep-Alive”, you can do this in the step 12th and 13th of the following document.

http://www6.nohold.net/CiscoSB/Loginr.aspx?login=1&pid=4&app=search&vw=1&articleid=3294

I hope you find this answer useful, if it was satisfactory  for you, please mark the question as Answered.

Please rate post you consider useful.

Greetings,

Johnnatan Rodriguez Miranda.

Cisco network support engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.

View solution in original post

Thanks,

The "Factory Defaults", I didn't tried it yet.

I will do this a.s.a.p.

The MTU was part of my first Troubleshoot, but good that you mention it.

The VPN "Keep Alive" was turned on, when I used the Cisco build-in VPN.

I will try the "Factory Defaults" as last resort.

If it doesn't solve the problem, the customer have to deal with the 30min. idle timeout or change router.

You may try to adjust the timeout period

https:///f_general_hidden.htm

example:

https://192.168.1.1/f_general_hidden.htm

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

I changed the MTU packet size, it fixed the problem TY