Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV042G WAN Bandwidth has only 100Mps?


I just got the RV042G today.  I found the router can only accept 100000 Kbit/sec as bandwith, which is 100Mps only.  According to the specification, it should have 1000Mps WAN.  I have a internet link of 1000Mps, which is now limited by this router.  Any idea if there is something wrong?



Wen-Li Huang

104 REPLIES 104
Tom Watts

Hi Wen Li Huang, the router does have a 10/100/1000 internet port. How are you measuring the throughput? Can you post a visual result?

-Tom Please mark answered for helpful posts

Hello Thomas

Yes, the internet port shows 1000Mps in port status.  However, I cannot set more than 100Mps for upstream & downstream for the WAN port.

I tested the link speed provided by my ISP.  The upload & download speed with Netgear WNDR4500 are 740Mps & 580Mps respectively.  With RV042G, the corresponding speed are 130 Mps & 110Mps respectively.  Therefore, I believe it is limited by RV042G.  Cisco states its NAT throughput is 800Mps, however, my testing does not match the specification...Is there anything wrong / bug?  It seems get same throughput as previous model, RV042.

Anyway, I can post the speed test result later.


Thanks for the reply Wen Li Huang,

Please call the SBSC to open a service request (case).

Here are the telephone numbers;

-Tom Please mark answered for helpful posts

Built-in 4-port Gigabit Ethernet switch
The LAN side is NOT 1000MBPS


I've not tested full throughput on my RV042G as yet but it is faster than 100mbps. I'll try doing to throughput tests soon on mine and see what I get.

Sent from Cisco Technical Support iPad App

Regards Simon

Sorry for my late reply  I was on a business trip.

I will contact cisco to see what happens.

By the way, Simon, the throughput of RV042G should be faster than 100Mps, but it is significantly lower than its specification, 800Mps...with Netgear WNDR4500, my link test can reach 7xx Mps, but with RV042G, the performance is only 130Mps, that is really a big surprise to me.

Dear Wen

I was just reading your post at the cisco forum and I´m myself thinking of buying a RV042G to replace my RVS4000.

I noticed that you can not set the WAN speed to 1 Gbit because the interface does not allow that high number to be entered.

Did you open a support case with cisco - and if - what was the feedback?

Would be great if you could let my know and also how you like the new RV042G.


Andreas Knoflach


I bought the RV042G over 1 month, I also got the same problem. And I found there are 2 major problems:

1. GE wan port, but the SPEED is limited to 100Mbps

2. Under the load balancing mode, it's not using sticky IP, that's mean no static resturn IP session on same URL page.

     For example some  Ebanking will be display error after login due to return to wrong IP.

I am so disappointed that why 2 basic function bug was found in this product, Why cisco don't follow this critical bugs.

I heard many user got the same problem. Don't tell me it's the setting problem.

Hi Patrick, The first point, is the bandwidth management for services, not for the entire router's performance. Your second point is not a  bug. The router has protocol binding. For your HTTPS browsing, you should bind HTTPS for a specific WAN (if that WAN happens to fail, the protocol bind will fail over to the operational WAN).

Please rate helpful posts

-Tom Please mark answered for helpful posts

The first issue, where the Web GUI capped the WAN bandwidth at 100Mbps, will not affect the bandwidth that ISP provides you. The maximum WAN bandwidth parameter is used by the router to calculate the bandwidth of the low, medium, and high priority of traffic. Regardless how the bandwidth management rules are configured, the WAN throughput is not going to be rate limited unless there is a real congestion.

Dear Tom and Tekliu,

Thanks for your quick reply. For the https  or protocol issue, I will try on it.

About the Speed problem, I have a Draytek 2130n, NAT throughout tested over 900Mbps, but after I changed the RV042G, it's only around 110Mbps. I have 1G and 200Mb fiber broadband network. Now bandwidth are limited. So, can you help to mention that how can I set and test the NAT throughput can be up to 800Mbps ?

Patrick, personally I've had the RV042G at 300 mbps using jperf on default setting (cat 5e wire)

The one thing a lot of people always neglect, cat 5 cable is 100 mbit, cat 5e is 350 mbit wire.

I don't doubt the Drtek may test for 900 mbps, but that test is a simulated test using programs such as jperf.

But also consider, the router is marketed for cable and dsl connections.

Only thing I'd recommend to you, make sure the router has the latest firmware release, ensure you're using proper cabling. You can try to disable some firewall features, it may help some as well.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Dear Tom,

Cabling also is the issue. but I am using Cat 6 cable.

I tested other brand high speed router like Draytek, QNO, Asus...etc

Test on jperf, and speed test site like both are acceptable.

But only RV042G make me confused. I tested on and, only around 110Mbps.

I tried same test many time with different brand of router, So I belived that this is the RV042G issue.

May be you said there are many other factor affect the speed test. But I can't see any problem on other high speed router.

I also tried point to point ftp test on different brand of router via internet zone. Both side is 1Gbps network. Both can reach over 500Mbps....but RV042G is around 100Mbps. The performance is simualar to RV042....

Sometimes I think I am using RV042 rather than RV042G....

I don't think only me are facing this problem. I checked many people are also have the same problem including my friend.