Showing results for 
Search instead for 
Did you mean: 

RV120W cannot select n speed under wifi

I recently purchased a RV120W router and I am having a problem selecting n speed under the wireless settings.

If I select B/G/N-Mixed mode then when I go to save the change I get B/G/N-Mixed B/G/N-Mixed in red letters and it does not save.  If I select N only then when I go to save it says in red letters N only N only.

It does not matter if I pick 20 only or 20/40.  It does not matter if I enable or disable U-APSD.  It does not matter if I use the LSB or USB side.

Firmware Version:

When I got the router it had an older firmware if I remember correctly, and it would let me change to n speed.

Any suggestions?

Rising star

Hi Frederick,

Since you recently purchased the RV120 you should be under warranty.  Please call the Small Business Support Center and speak with an engineer.

Contact information for the Small Business Support Center is located here:

Cindy Toy
Cisco Small Business Community Manager
for Cisco Small Business Products
twitter: CiscoSBsupport

Regards, Cindy If my response answered your question, please mark the response as answered. Thank you!

Hi Frederick,

     The first thing I would do is do a factory reset on the unit, if you are able to, as you will lose all your configurations. To perform factory reset, I would hold down the reset button for about 30 seconds to make sure the device does reset. Your device could be corrupted from the old and the new firmware. After the factory reset, if you are still not able to change to your wireless settings, please give us a call as mentioned by Cindy Toy. I hope it was informative.


Brian Ng

Cisco SBSC Network Support Engineer.


Well I had done all sorts of testing and stuff for the problem to still be there.  Recently I had been fighting a bouncing DSL connection that would bounce from 20 minutes to an hour or so.  Everything I had tried with the firmware and the firmware yielded the same result.  If you touch any of the settings under basic wireless the speed would drop on my WiFi to 54.0MB and I would get the B/G/N-Mixed red warning next to the Wireless Network Mode.

My final was to do a complete setup in firmware, save it with everything set.  Then Factory Default the router.  Upgrade to firmware  Once done do a simple reset.  After that reset then use the saved config file to restore the router.  But my connection did not stay stable on the n speed and would drop back to G a lot.

Well as I said I was fighting DSL issues which ended up resulting in a modem/gateway change.  I had a ZyXEL PK5001Z.  I put in my older ZyXEL PK5000Z, which is compatiable with my DSL as it was my modem at the old house.  Now my DSL connection is stable.  So I went and checked the router and my WiFi is a solid 117 - 130MB and if I make a change on the Basic Settings page for the Wireless I no longer get an error.

So it appears my DSL modem/gateway (modem/router), an ZyXEL PK5001Z, was the cause of my router problems as well as my DSL bouncing and noise on my phone line too.

At this point I am running the firmware and I am having no problems.

Thank you for at least replying Cindy Toy and Brian Ng!

Message was edited by: Frederick Frahm How do I mark this as Answered?