cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

1582
Views
0
Helpful
3
Replies

RV215W Static DHCP Issue

RV215W_FW_1.1.0.5.bin

After setting up LAN / Static DHCP Entries ...

An error appears in the log file after reboot: error reading config file.

Static DHCP is not working. GUI still shows the config.

Kind Regards,
AB

Everyone's tags (7)
3 REPLIES 3
Highlighted
Enthusiast

RV215W Static DHCP Issue

Hello Andreas,

Thank you for reaching Small Business Support Community.

When you mention to have "LAN static DHCP entries", do you mean you statically assign IP addresses to your LAN hosts so the DHCP feature is disabled on the router? If that's the case please make sure DHCP is turned off.

If the RV215 is or must be acting as a DHCP server; make sure you the IP address pool is set to its default class C 192.168.X.X and that if you must assigned static IP's you use the ones outside of the DHCP pool range.

Notice there is also an option for "DHCP relay" in case you have a DHCP server different than this RV215 on your LAN.

I am not familiar with the firmware release version you are running on so I can not tell for sure if this might be the problem, but please check under "Administration" menu for "file management" for "DHCP Auto Configuration", if there disable it since it seems like when rebooting it is attempting to load a configuration file from somewhere else.

I'll be looking forward to hear from you.

Kind regards,

Jeffrey Rodriguez S. .:|:.:|:.
Cisco Customer Support Engineer

*Please rate the Post so other will know when an answer has been found.

Jeffrey Rodriguez S. .:|:.:|:. Cisco Customer Support Engineer *Please rate the Post so other will know when an answer has been found.
Highlighted

Re: RV215W Static DHCP Issue

Hello Jeffrey,

Iv'e used the terms from the device menu - you can check it with online emulator, if you don't have acces to the device.

https://www.cisco.com/assets/sol/sb/RV215W_GUI/default_EN.asp.htm

Network / LAN / Static DHCP

Please do not mix up static IPs configured on devices themselves and static IP Addresses assigned via DHCP based on MAC Addresses.

My Issue:

The Static DHCP Addressesawere within the DHCP Range of the Router but individual IPs with gaps (so no range, not starting at the beginning of the DHCP Range). The Router is running the DHCP Server. There is no DHCP Relay.

The router was new when I tried it the first time.

I've reflashed the firmware, factory defaults and did a reconfiguration ... it works now. Altough there is currently just one device assigned. I'll need to check further on this - the issue happened with multiple DHCP static IPs assigned. I'll post a picture when I'll retest this ...

There was also an error in the syslog, but I didn't keep this log file ...

Even with after my reconfiguration, there are errors in the syslog during boot ...

53: 2010-01-01 00:00:22 RV215W kern.err pflash: found no supported devices

102: 2010-01-01 00:00:23 RV215W kern.err SQUASHFS error: Can\'t find a SQUASHFS superblock on mtdblock3

151: 2010-01-01 00:00:21 RV215W daemon.err dnsmasq[498]: failed to load names from /etc/hosts: No such file or directory

Kind Regards,

Andreas      

Highlighted
Contributor

RV215W Static DHCP Issue

Depending on how much time you have to exchange this unit if it is new, I'd exchange it.  It seems like something odd is going on beyond just the software.  If you discover it's hardware at a later point, getting a replacement may require more downtime.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com