Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV220w DNS resolution issue

Hello chaps,

My RV220w has a problem with DNS.  I have configured the device for my network, but it seems as though DNS is not working correctly.

For a background, I have a primarily Windows environment in my network, W7 PCs.  I use homegroup to share files/printers amongst them.  I like that I can type "\\<server-name> in the Windows search box, and up comes the other computer's files.  This functionality is still there with the RV220w, so that's not my issue.

My problem arises when attempting to type "<server-name>" into the Remote Desktop Connection dialog box.  I can no longer RDP to my other computers by name.  Attempting by IP does get me there.

I've run a nslookup on my pcs, and the result is:

->nslookup <server-name>

Server:  <RV220w-HostName>

Address: <>

Non-authoritative answer:

Name:  <server-name>.<network-domain>



Note that the addresses listd are NOT my server addresses.  <server-name> has an address of

After I saw this, I saw the "DNS proxy" setting on the RV220w's LAN config page.  I unchecked that, restarted the router, and that ALLOWED DNS to start working in RDP again.  I could then access PCs via hostname, like I want.  HOWEVER, the WAN connection seems to be non-existent.  I cannot access an www page, even  It must be that is trying to get resolved in only the RV220w, which isn't going to happen - it needs to communicate over the WAN port to get DNS info from ISP.

Then, I figured it was a setting inconsistency within the RV220w so I attempted to restore my previous settings - see my other discussion for that issue:

Thanks for any help,

Sam Malone

Jens Janssen

funny, just posted

Same problems for me.

Jens Janssen

In the RV220W manual is written, that the provider's DNS setting are passed through to the client if DNS proxy is disabled. The DNS settings box is clearly labelled "optional". So I left it empty.


I've tried both leaving it empty and putting in RV220w's IP address of - neither setting allows WAN DNS to work.

It seems we have to make a choice between local DNS functionality or WAN DNS functionality... since I need internet, I choose WAN.

Try to put in provider's DNS server addresses. Anyway, it is supposed to work with fields blank.

If you have trouble with local host name resolution (DNS proxy enabled), check if "Network discovery" is enabled or a WINS server (or equivalent) is running. This is exactly my problem I just solved today I tried to solve today.

Do you have a Windows Server running? If yes, which version?

Edit1: local host name resolution just stopped working... all clients/servers have "Network discovery" enabled. But no chance that they see each other when browsing the network.

Edit2: I have a Windows server running with IIS7.5 server role. By putting http://[servername] into the browser's address bar I can't reach the server's default webpage. nslookup [servername] also doesn't work.

When I run the command "net view" I receive the error 6118. Does this means NetBIOS over TCP is not working. Any Idea?

Edit3: I can workaround the error: by enabling "Computer Browser" service I can see the clients/servers again. Both, Computer Browser and WINS are deprecated. Both rely on NetBIOS over TCP afaik (this could explain the 6118 error because Computer Browser was disabled at this time). But both services are replaced by Network discovery which relys on SNMP. Is it possible that SNMP is somehow blocked by the RV220W firewall?

Another observation: When I connect my wireless client to the router's network port I can immediately see the server's shares....

No windows server here, but I am currently contemplating throwing together a 2k3 box ONLY for DNS... which was easily handled by my Netgear el-cheapo router from 2005...

WTF Cisco, your small business products just are not up to par.  Firmware is buggy, UI has poor english... Netgear was awesomely easy to configure.

I can't even figure out how to forward port 3389 to my workstation... This is ridiculous. Pathetic. $249 down the drain as far as I'm concerned.

Very unhappy customer here.


... not to mention the hours I spent in front of this §$%&$"§$ piece of router. I'm not a professional admin. I'm happy when I get my servers up and running (needed for my work!). I don't want to do the debugging. I thought I'd already paid CISCO to do the debugging. Where is the good old craftmanship.

Quality guys, quality and professionalism!!!

Hi, My name is Eric Moyers. I am a Network Support Engineer in the Cisco Small Business Support Center. Thank you for using the Cisco Community Post Forums.

I understand the frustrations that you are having with this product and DNS. I invite all of you to please call into our support center and get a case opened for your issues. This way we can track the problem and help to come to a resolution for them. Currently this DNS issue may be more complex than what can effectively be troubleshot through the forum. Please call 1-866-606-1866 and let one of the answering agents get you a case opened.

It may even be possible that there is a already a solution for some of this.

Eric Moyers
Cisco Network Support Engineer
CCNA, CCNA-Wireless

Hi Eric,

first, thank you for your reply.

Second, something is seriously wrong with the workflow at Cisco. Do you really think I have time to spend on opening/managing cases? I would have to open three cases on which I have to spend quite a lot of time. I'm a small business customer! the engineer:

i. DNS proxy dropouts (domain name resolution not working)

ii. domain name resolution doesn't work at all if DNS proxy is disabled

iii. host name resolution/network discovery doesn't work between wireless and wired network interface

Mr. Janssen, I completely understand about the time involved and managing cases. Each Engineer here deals with multiple cases a day, sometimes even close to a hundred a day. Having case numbers help us keep track of each issue and gives accountability, to us and the customer when we need info from them. Having case numbers also gives each issue face and a way to track the issue.

Without case numbers we would have random engineers, working separate issues with no way compare what everyone around the world is doing. With cases, in a central repository, we are then opened to case analysis on products, can track trends, easily locate issues and/or solutions. Cisco has to be able to recognize where the most important areas lie, so that we can know where to concentrate development for firmware updates or design changes.

So I please implore you open a case, I promise it wont take long, we will manage it for you once it is opened.

To open a case all we need is your Cisco User ID, Product Serial Number and the ability to reach you when we have questions or need to work with you to troubleshoot.


Eric Moyers

Cisco Network Support Engineer

CCNA, CCNA-Wireless


Hi Eric,

when can we expect a new firmware addressing these issues?

Cheers, Jens

Update: I'm running firmware now.

Most of the issues are resolved:

1. The network discovery works across wired and wireless devices thatare in the same VLAN. But only if I visit Networking::Lan::VLAN Membership and tick the box, press edit and save. Make sure "Inter VLAN Routing" is enabled.

Even if "Inter VLAN Routing" was enabled before, saving the configuration is important to get network discovery across VLAN working. So there is still a bug!

2. nslookup works reliable.

3. DNS resolution with enabled DNS proxy now works reliable (disabling of DNS proxy not tested).