cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2429
Views
0
Helpful
8
Replies
Joergen Thomsen
Beginner

RV220W firmware 1.0.5.8 available, but :(

LATEST: Do not upgrade, if you are using IPv6. There are issues not yet fully understood.

After waiting about 1½ year a new firmware release is made available.

The upgrade process from 1.0.4.17 did not run as simple as described in the release notes. I followed the instructions, but ended up with a device, which did not handle IPv6. After some twiddling with saving unchanged settings I managed to make it respond to a ping6, but not to route IPv6 through my tunnelbroker tunnel.

As an attempt to fix it I decided to select the IP4-option with the intent to revert to the dual-stack IPv4 and IPv6 again.

After the reboot I ended up with a router displaying only

$| trStrings["11383"] or 'i18nHTMLMissing' |$

on the web interface and did nothing but reply to pings.

After a factory reset (Press the red reset button for 10+ seconds and login with cisco/cisco) I restored the 1.0.4.17 configuration from a backup taken before the upgrade and the router returned to full operation again, it seems.

However, the IPv6 has now stopped working again. No response on ping6 and no routing.

The release notes are interesting. It is of course fine, that some errors in an option in DHCP is fixed, but a number of bugs reported 1½ year ago are still present and not at all acknowledged in the 'Known issues" section of the release notes. Apparently the development department is living in another world.

Just to mention a few: 

- hairpinning is not fixed. The source IP address is still the router's IP address

- reordering access rules can still only be made within one page

- front lights are fixed and do not indicate amount of traffic

- RIP1 is announcing a WAN of /8 when it should only be /30

- SNMP is not using the standard Cisco prefix 1.3.6.1.4.1.9 for private fields

8 REPLIES 8
Joergen Thomsen
Beginner

After once again restoring the 1.0.4.17 configuration. IPv6 over the tunnel is working.

However, the router is in a 99-100% CPU usage situation.

The dashboard, when it is actually possible to load it beyond the "Please Wait ... The page is being loaded", will display partly proper data and partly

$| trStrings["11383"] or 'i18nHTMLMissing' |$

and occasionally the full page.

If the IPv6 functionality is lost again and/or this CPU usage continues, it will be downgraded to 1.0.4.17

A fallback to 1.0.4.17 has been done. The 1.0.5.8 version is buggy and useless in my setup.

The IPv6 tunnel stopped working after some time and the CPU usage was still 100%.

I have backed up the 1.0.5.8 configuration, have a copy of the IPv6 routing table and some logs from the unit, which is available for Cisco.

However, based on earlier experience with Cisco, these data will never be requested and used.

No, the data was never requested and the IPv6 tunnel problem never solved.

In firmware 1.0.6.6 it is still present and now the router is EOL, so it will never be solved.

 

Hakiru-84
Beginner

Very important notes but as usual there aren't (any or constructive) reaction from the people responsible for firmware ...

One question: my rv220w wi-fi is very slow (firmware 1.4.17). About 72.2 mbps. My notebook wi-fiis 802.11n.  I m very close to rv220w.  What velocity with new firmware?

Marc Nagao
Cisco Employee

I have asked my team to take a look.

Joergen - if not already, pls get a case created.

Thanks,

Marc

@Marc Nagao

With auto mode - max velocity is 72.2 (all the laptop).

If i change in manual mode and I set low channell (1-2-3 for example) I have 150 mbps (WoW!!!!!) but only for 3-4 hours, after the RV220w crash and I have to reset the router,

HI Daniele - please get a case created so we can take a look. 150Mbps is great, sustained!

Best,

Marc