cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

3501
Views
5
Helpful
4
Replies
Highlighted

RV220W Forwarding a Port Range

How can one forward a range of ports?

Suppose I have defined the following service:

Service: TEST

Port type: UDP

Starting port: 5060

Ending port: 5070

and I want to forward it to a specific IP. Then, if I create a new port forwarding rule for this service it asks me to specify a single port number to be used internally as:

Action: Always Allow

Service: TEST

Source IP: Any

Destination IP: 10.0.0.100

Internal Port: ?

I want to forward all ports from 5060 to 5070 to the internal range 5060 to 5070.

How can I do that?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I have the same issue with needing to forward a range of ports to a single ip address. Right now I can't put the rv220w in the network to test it as we are in the middle of the day and I can't take the network down.

Just a warning:

**This has not been tested in an active network**

What I did was the following:

Go to Firewalls/

Access Rules

Add new rule:

Connection type: inbound (wan (internet) > LAN (Local Network)

Action: Always Allow

Service: "TEST"

Source IP: Any

Send to Local Server (DNAT IP): 10.0.0.100

Hit save and it "appears" to work. Again I haven't tested it myself so just be careful as I am not sure if it works correctly at this time. When I am able to put the router in the network and test this I will follow up.

View solution in original post

4 REPLIES 4
Highlighted
Advocate

Hi Panos, the range is specified within the custom service. It should be the same as incoming port when you're trying to allow access. The internal port is for port translation.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted

The problem is that the user interface does not allow me to leave the port translation field marked as "Internal Port" empty. And since my service has a port range I cannot specify there a single port number.

Highlighted

I have the same issue with needing to forward a range of ports to a single ip address. Right now I can't put the rv220w in the network to test it as we are in the middle of the day and I can't take the network down.

Just a warning:

**This has not been tested in an active network**

What I did was the following:

Go to Firewalls/

Access Rules

Add new rule:

Connection type: inbound (wan (internet) > LAN (Local Network)

Action: Always Allow

Service: "TEST"

Source IP: Any

Send to Local Server (DNAT IP): 10.0.0.100

Hit save and it "appears" to work. Again I haven't tested it myself so just be careful as I am not sure if it works correctly at this time. When I am able to put the router in the network and test this I will follow up.

View solution in original post

Highlighted

Hi !

I ran into the same issues trying to setup a brand new RV220W.

The answer from Richard Coleman is correct. Thanks.

Just to detail a bit further. If you create the rule from the firewall rules you can NAT a service (range of ports) to an IP. Then a rule is automatically created in the port forwarding section but with no internal port. Firewall rules and port forwarding rules seem to be linked toghether. However you cannot create by yourself a forwarding rule with an empty internal port, nor you can modify the one automatically created by the firewall (without setting an internal port). No ideea why. Maybe it will be fixed in the next firmware.