Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV220W, having trouble connecting to local sever through Internet

I recently bought an RV220W. I run several game servers from a server on my network. With the new router, I can connect to the server with the LAN IP, of course, but I can not connect using the internet IP of the server. I believe it is properly port forwarded, as well as the correct DNS server.

My old router, the Linksys WRT160n, had no troubles. It was also port forwarded properly.

Any suggustions? I can provide any information that would help resolve this issue.


Joergen---After you installed the firmware did you do a factory reset on the router? It is always suggested that

you do this after a firmware upgrade. If you are still experiencing problems I would ask that you call the Cisco

Small Business Support Center (1-866-606-1866) USA and let us open up a case for you.


Rick Roe

Cisco Small Business Report Center

Guys you may want to ask the Cisco Business Center for an updated firmware. is the latest known beta I think.

Regards Simon

I actually already have several cases, and 3 CISCO engineers on them, but apparently these guys have been on vacation last week, because after requesting information from me Monday last week and my response to them with a list of 10-15 issues nothing has happened. Maybe because the CISCO engineer closed the main case (618579721)

to reopen it later  to make his case statistics look better

Your suggestion of a factory reset is reasonable, and I probably should do this, but having 25 port forwarding rules as well as VPN configuration etc to enter manually will be an error prone hassle, which should not be needed.

In connection with the hair pinning problem I have discovered an issue about the port forwarding rules, which I am currently investigating. If a rule is edited (no changes) and saved again these lines appear in the configuration for the rule

FirewallRules[2]["DestinationPublicInterface"] = "WAN1"

FirewallRules[2]["ScheduleName"] = ""

FirewallRules[2]["SNATAddressType"] = "7"

BUT only for the rules on the GUI page 1 (sic!)

Fortunately, having at least one of these rules seems to enable hair pinning.


Yes, i pulled up your case (618579721) noticed that it was escalated to our escalation engineers. If you were currently working with other engineers at T1 they shouldn't touch the case since it is escalated. Please contact the escalation engineer that was assigned your case. If no contact is made, just give us a call @ SBSC @ 1-866-606-1866 and open another support ticket. We can reference your existing case 618579721 into the new case and attach any documents we need and escalate back to our product engineers.



Cisco Support Engineer


The issue of hair pinning has NOT been solved.

After 60 screen dumps I made a factory reset, reflashed the unit, made a factory reset and manually reconfigured the unit (several hours !)

It still has the hair pinning problem, and the

FirewallRules[2]["DestinationPublicInterface"] = "WAN1"

only appeared in the first rule reedited.

This time it did not solve the hair pinning problem.

(I suppose I am using the latest beta available !)

This hair pinning problem is really weird.

After writing the message above I went back to the same open browser window (in another browser) and reloaded the page which ended up in the router and not in the proper web page.

Now it worked !

Absolutely nothing had been changed.

The conclusion is: the hair pinning problem is intermittent and should still be solved.


Although it does not fully explain that above, it appears that the hair pinning has only been solved for port 80 connections.

https or telnet to port 25 or 110 is not possible on IPv4, but OK on IPv6. Port 80 is OK on both.

strangely, the hairpinning doesnt work for one of my port fowarding (https/443/Zimbra) , I always get the Cisco router instead !

Other https ports I have are fine.

Is there another new beta firmware available ?  

Cisco really need to fix this asap. Even my 10 years old D-Link can do this !

It is working here. Try using the Firewall -> Access Rules to define the port forwarding.

New firmware ? Don't hold your breadth. It took Cisco from  March to August to release a new version despite of all the serious bugs found.

In the latest firmware there are still plenty of bugs:

Hello Joergen,

like I said in my post, it works for all my other ports , so I already know how to forward a port.

I was actually testing the fw in july and it was working for me and not for you.



jasbryan wrote:

If no contact is made, just give us a call @ SBSC @ 1-866-606-1866 and open another support ticket. We can reference your existing case 618579721 into the new case and attach any documents we need and escalate back to our product engineers.

I would prefer CISCO supporters to do their work and am not wasting my time by opening new cases, which subsequently are being closed without any action. This is close to being too much.

I have heard a lot of sweet talk from CISCO supporters, but we are past the stage now, where this is enough !


You're case was escalated to level 2, discuss between you and that engineer your case was closed the engineer said when contacted was established back then he would reopen your case. When you (customer) agree to close case; Cisco policy is after 14 business days a new case has to be opened. So as i mentioned if you can't get in contract with level 2, you can give us a call SBSC ,we can reference your existing case in a new case and escalate. Sorry you feel I wasn't doing my job, guess i could have not e-mail you and explained what could have been done next.



Cisco Support Engineer



I have not complained about you. I appreciate you taking time to spend on this.

I went on a planned vacation for one week but did not want to close the case, but was pressured into it by the supporter (MD). After one week I returned and submitted a list of 10+ issues, but that gave no response for more than one week and the case was not reopened.

My main problems are

1) the hairpinning problem (fortunately mostly solved by a strange way of doing nothing for 26 access rules!, but there is still a source address problem)

2) The reluctance of CISCO support to provide a feedback channel to software developement, so my 20+ issues of the beta firmware after many hours of testing can be handled, and not just stored somewhere without being used.

Might be worth checking SBBC as there has been ongoing work with Developing and bug fixing on the RV220W. is the official latest, but there should by now be a newer firmware to be applied via SBBC.

Regards Simon

Quitr frankly, why should I bother spending more time on this router. The way Cisco is handling customers who voluntarily are spending a lot of time on testing their products is appalling. I don't intend to continue submitting information to a black hole.