cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

6197
Views
0
Helpful
18
Replies
Catalin Burla
Beginner

RV220W - in routing mode changes external Ip with router IP

Good day.

I just installed one RV220W in my network, in routing mode (not NAT) using on WAN port public Ip 193.111.184.xxx and on LAN side on IP from my company public C class (212.100.143.0). It's working, but main ang huge problem is than Router is changing any IP coming from intenet with it's own 212.100.143.xxx IP, which mess up everything (logs, counters, etc).

It was using 1.0.1.0 firmware, I switched to 1.0.0.26 but nothing changed.

Also I have a VPN - gate to gate with another location (RV042), and all computers from other side of tunnel reports same router IP 212.100.143.xxx when accesing servers from my side, which also is bad.

Previously I user an RV082 for this joB and everything was great, except 100 Mb WAN/LAN ports of RV082, which I will use until get Rv220W working right.

Any idea is apreciated.

Thank you,

Catalin Burla

18 REPLIES 18

Ok I eventually have good news.

The Switzerland support was able to reproduce the problem, and they found the problem didn’t appear on a fresh configuration (after a factory reset) they asked me to reset the configuration and re-implement it checking at each step if the problem appears.

One hour after I found the single checkbox that mess up the all internal NAT configuration: PPTP Server.

I reloaded my production configuration disabled the PPTP server and guess what? No more problem, external IP come as external as they should.

Do you have PPTP server enabled by any chance? And if yes disabling it solve the problem for you too? Tell me so the support here can escalade the bug.

Hi.

I enabled PPTP server for test only when first time configuring router, after disabled. Until I noticed probelm and after, no change to PPTP.

Another behavior is that (with a "faulty" config ) if you switch to gateway mode and back to router mode, it works correct. After power off - power on cycle, it goes crazy again.

After factory reset I configured router again, without enabling even once PPTP and router was running ok.

So it seems that what you discovered make sense.

My problem is that after few days running performance got terrible slow, so I revert to RV082 as I am few days off and can't afford "tests" now.

Next week will be back to office and will give another try.

Best regards,

Catalin Burla

Even if disabling the PPTP server fix the "internal NAT" problem i have another issue persisting on the Ipsec tunnel, rpc comunication doen't pass the tunnel, everything else if fine. i'm back to the rv082 till the next firmware anyway, this looks like a beta software...

i keep you informed and thx for yours

Ok the good news is that the issue is as been reproduced by Cisco, they are working on fixing the bug. no ETA is the bad news