Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV220W Packet Loss over wireless

I am having issues where different laptops are dropping packets when communicating to the WAP on the RV220W. I have placed 3 laptops directly next to the router so there is no chance for walls to interfere. From each machine 1 at a time I perform a continuous ping. Here is a quick output from one of them:

Reply from bytes=32 time=3ms TTL=64

Reply from bytes=32 time=1ms TTL=64

Reply from bytes=32 time=3ms TTL=64

Reply from bytes=32 time=3ms TTL=64

Reply from bytes=32 time=3ms TTL=64

Reply from bytes=32 time=5ms TTL=64

Reply from bytes=32 time=25ms TTL=64

Reply from bytes=32 time=3ms TTL=64

Reply from bytes=32 time=3ms TTL=64

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Reply from bytes=32 time=399ms TTL=64

Request timed out.

Reply from bytes=32 time=3657ms TTL=64

Request timed out.

Reply from bytes=32 time=3723ms TTL=64

Reply from bytes=32 time=416ms TTL=64

Reply from bytes=32 time=222ms TTL=64

Reply from bytes=32 time=245ms TTL=64

Reply from bytes=32 time=676ms TTL=64

Reply from bytes=32 time=286ms TTL=64

Reply from bytes=32 time=310ms TTL=64

Reply from bytes=32 time=127ms TTL=64

Reply from bytes=32 time=153ms TTL=64

Reply from bytes=32 time=190ms TTL=64

When performing the tests, I make sure that all other laptops have their wireless NIC turned off. I verified there is only 1 device connecting to the router by using the dashboard. All laptops are running Wireless-N NICs with the latest drivers

From the wireless stats, I can see that there are some Rx Errors

Access Point Statistics Table

SSID Packets Bytes Errors Dropped Multicast Collisions

Rx Tx Rx Tx Rx Tx Rx Tx

MYNET 25863110 24486604 46450645 3530163641 190 0 0 0 38314 0

Can somebody suggest possible ways to troubleshoot this?


Hi Allen,

I have the same problem and very unhappy with this expensive router. Good that I found a solution. You can configure the wireless as a separate VLAN. In my case, my wired network is 192.168.10.x and the wifi network is 192.168.2.x. I have this configuration for the last 3 days without any issues.

Good luck!

Hi Mpyhala,

The network topology is very basic.  There is a single subnet and most reourt settigns are default.

I am using 1-to-1 NAT and some port forwarding rules.

There is only 1 WAP configured.

I have purchased a Linksys E4200 and I am just using the WAP on this hooked into the RV220W.  I have no packet loss and better coverage than the 220w.'

I have not tried the VLAN workaround that was described above.  This should work out of the box without workarounds.

Rising star


This is certainly not normal. Can you provide some detail about your wireless settings as well as LAN topology? Also, are you using the latest firmware? (v.

Hi Mpyhala,

I fully agree this is not normal. I have the latest firmware (v1.0.2.4) and my setup is very simple and similar as Allen.


- A few port forwarding rules

- Wifi using WPA2 personal

- PPoe for WAN

- Dyndns

- External GB switches


After chaning to RV220W, my wife and kids are complaining at me for not able to use their iphone, ipad and etc. This forced me to look into the problem. I noticed the issue is not on the Wifi connection. I did the same ping test like Allen by continuously pinging an external web site. The connection to the web site alterned (I would not say dropped because Wifi is still on) after approximately 30 minutes. This looks like a routing rule problem so I tried to setup a different VLAN, hoping the router to recognize a separate static route. It worked so far without any issue and my customers (wife and kids) are happy now.

After this change, I still have occasional issue connecting to internet via my iMac (with no issue with my NAS on LAN). Need to troubleshoot more in the problem. This might not related to RV220W. It could be Safari, GB switch, lan cable and etc.

I bought the router because of Cisco brand name. Frankly, I am not a happy customer. Hope you can find us a perpetual solution.





I have the same problem too.

Firmware V1.0.2.4

I will test the Allen's solution.


Same problem here This router should never been released to Market - I have spent tons of hours on this router with issues like vpn, logging, lost package and so on - the list is long..not to talk about all reconfiguration after firmware upgrades.  firmware upgrade becasue this shit needs to be reset to factory after..

This product should get a new product manager or be recalled from the market.

Please Cisco - Take this product RV220W back to the drawing table and do it all over again and release a software/router that works.


Hello all,

I'm sorry to see that the RV220W is showing some wireless issues. I have had one running steady for over a month with zero wireless problems. It is connected 24/7 to two WVC210 cameras that stream continuously. Here are my settings for reference:

Operating Frequency: 2.4GHz

Wireless Network Mode: G/N-Mixed

Channel Bandwidth: 20MHz

Channel: Auto

Default Transmit Power: 7 (dBm) (The range was far more than I need so I lowered this)

Advanced Radio Configuration: ALL DEFAULTS

Security: WPA2-Personal

Broadcast: No

Max Associated Clients: 5

AP Isolation: Disabled

Maybe the cameras are keeping the signal alive? I test the cameras with a continuous ping almost daily and usually the first reply is 5-6ms and then 1ms after. I also connect a Macbook Pro and Motorola Droid wirelessly and have never had any problems. I have started watching closer to see if maybe I am missing something. I will update if I find any issues.

If you continue to have problems, please contact Cisco Small Business Support and open a case. This is certainly not a known issue within the support team and if there is an ongoing problem with the hardware/firmware we need to start working toward a resolution. You can find a number to call at the following page:

Hello mpyhala,

Today, I have tried to switch my WiFi VLAN (192.168.2.x) back to LAN VLAN (192.168.10.x) after reading your reply. After 5 minutes, my wife started to complaining her iphone lost connection to Internet. What do I need to provide to the Cisco support team? I have enabled logging function and didn't found any abnormality.

Hi Anthony,

I see that your Channel Bandwidth is Auto. Have you tried it on 20MHz? Also, my Control Side Band is Auto. (Grayed out)

To open a case with Cisco Small Business Support you need a Cisco User ID (login name) and the serial number of the router.

I am also having the same problem, however it's not just over Wifi, it's wired as well.

I have tried 2 different laptops, and different cables pinging the main router IP. I will loose a packet here and there, and then have a few with large response times.


Craig Hjorth

This problem started for me also. I had to switch to using the WAP4400N access point I have connected to the RV220W as the wireless from the RV220W was useless. I called Cisco support and the tech said a new firmware was released yesterday (ver and he asked that I try it first. After installation and 6hrs of monitoring I have not had a problem yet. There was no mention of the release fixing anything with wireless but we will see. I will monitor through Monday. The old problem was making a wireless VoIP phone useless not to mention all the complaints from others trying to use the web.

Thanks Craig.

I opened a ticket with Cisco last week, and they advised I return it for a new one. I purchased via an online store, so RMA'ing is no fun. That said, I should have a new on in a few weeks.

Cisco would have replaced it for me as well, but then it would have been a refurb.


I received a new router, and updated it to the latest firmware. I am still having this issue both wired and wireless.

There is a simmilar thread here:

The suggestion there appeared to make things better, but I still have problems.

Forget it, i've updated this router with several firmware versions and reconfigured it several times from scratch. Connections are dropped, remote syslog server does not provide all logging, wireless disconnects, software is not correct....Unfortunately i'm unable to return the device to the vendor but i'm thinking about replacing this with another brand, it's probably cheaper than spending hours and hours resetting it to factory defaults and reconfiguring it, let alone the annoyance. I have had very good experiences with the Enterprise grade equipment but the SME stuff......not really.

Sat Jan  1 00:01:59 2000(UTC) [rv220w][Kernel][KERNEL] umi: module license 'unspecified' taints kernel.