cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

7361
Views
0
Helpful
8
Replies
AlanHardy
Beginner

RV220W port forwarding issues

I am trying to allow incoming requests from the WAN on a RV220W for http, FTP, and a further service on port 8080.

Note: Firmware is v1.0.2.4.

I have tried setting this up under Firewall / Port Forwarding and under Firewall / Rules.

Despite this, there is no access from outside. I had this all working quite happily with a Dynalink RTA1046VW, which was running the network previously.

Are there known issues which may be affecting this? Suggestions welcome

Alan

8 REPLIES 8
Jens Janssen
Beginner

Hi Alan,

there is a bug described in the 1.0.2.4 release notes:

Internet NAT redirection does not work using firewall port-forwarding rules.

A LAN client cannot access a service by using the WAN IP address of the

LAN device (such as an IP camera or an FTP server).

Work Around: Do not use the Firewall > Port Forwarding page, but instead

create the forwarding rule by using the Firewall > Access Rules page. The

working port forwarding entry is created along with the firewall access rule.

Jens

I had noticed that bug and tried adding the exception under Firewall / Access Rules. But still no go.

The details of the rule for HTTP is as follows:

------------------------------------------------

Add / Edit Access Rule Configuration

Connection Type:
Action:
Schedule:
Service:
Source IP:
Start:
Finish:
Destination IP:
Start:
Finish:
Use This SNAT IP Address:

Enable


SNAT IP:
Send to Local Server (DNAT IP):17.23.50.10
Use Other WAN (Internet) IP Address:

Enable


WAN (Internet) Destination IP:
Rule Status:

---------------------------------------

Is anything amiss there?

do you still have any port forwarding enabled?  it maybe conflicting.  http rules works on my RV220W.  I can only suggest you try to reset the router to factory defaults and try again.

Regards Simon

Same thing on my RV220W with firmware 1.0.2.4. When I create a new firewall rule for HTTPS forwarding, the appropriate port forwarding rule will be generated automatically. So no way to get port 443 open for incoming connections.

Regards,

Thomas

If 17.23.50.10 is the internal IP of your server and port 80 is waiting for requests then everything is correct.

For me this woks as expected. I'm using dynDNS + Reverse Proxy behind port 80.

I too have been knocking my head trying to get this figured out. Not to sound like a stupid question, but is the DNAT address that of the router, or of the machine that you are trying to set the port up for? Right now I have it set at the router IP, thinking that it is doing the NAT duties.

Thanks for any help!

Ron

I've tried everything here and in similar forums, even with 1.0.1.0 and 1.0.2.4, and none of them I have succeeded.

what I'm trying is to get up my FTP server with port forwarding, will also have a small web server (for local USE)

I get in touch with my FTP server locally, but always ends with "Time out"

This will log using FileZilla:

Status: Connecting to 192.168.1.199:21 ...

Status: Connection established, waiting for welcome message ...

Answer: 220 vsftpd 2.0.4 + (ext.3) ready ...

Command: USER admin

Response: 331 Please specify the password.

Command: PASS *********

Response: 230 Login Successful.

Command: SYST

Response: 215 UNIX Type: L8

Command: FEAT

Answer: 211-Features:

Response: EPRT

Answer: EPSV

Response: MDTM

Answer: PASV

Response: UTF8

Response: REST STREAM

Response: SIZE

Answer: TVFS

Response: 211 End

Command: opts UTF8 ON

Response: 200 UTF8 option is on.

Status: Connected

Status: Retrieving directory listing ...

Command: PWD

Response: 257 "/"

Command: TYPE I

Response: 200 Switching to Binary mode.

Command: PASV

Error: Connection closed by server

Error: Failed to retrieve directory listing

But all this works great with my D-Link DIR-655

Want to trade up to me a little more stabiulare router so I chose this, either I get to go back to my D-Link

or you can get any sensible answers here?

AlanHardy
Beginner

This issue has been resolved.

The router was having a problem with the IP range being used, which was 17.23.50.xxx.

When I changed the IP range to 172.23.50.xxx, port forwarding worked as instructed.

My thanks go to Gleb Sharkunov from Cisco Support for this suggestion.